Page 14 of 21 FirstFirst ... 41213141516 ... LastLast
Results 131 to 140 of 201

Thread: Elantech touchpad improperly recognized as “ImPS/2 Logitech Wheel Mouse”

  1. #131
    Join Date
    Aug 2010
    Beans
    1

    Re: Elantech touchpad improperly recognized as “ImPS/2 Logitech Wheel Mouse”

    Thanks a lot ALLurGroceries !

    You solve my problem.
    I linked and translated your post #44 in french to help french users, here...

  2. #132
    Join Date
    Oct 2008
    Beans
    100

    Re: Elantech touchpad improperly recognized as “ImPS/2 Logitech Wheel Mouse”

    Nice job, thanks for linking back.

  3. #133
    Join Date
    Apr 2009
    Beans
    3

    Re: Elantech touchpad improperly recognized as “ImPS/2 Logitech Wheel Mouse”

    Thanks I had a Lenovo B460 and this thread helped me fix this and make my trackpad working

    Cheers

  4. #134
    Join Date
    Apr 2009
    Location
    JVegas, TN
    Beans
    102
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Elantech touchpad improperly recognized as “ImPS/2 Logitech Wheel Mouse”

    OMG what a pain in the .... after upgrading I lost my wireless driver and had a heck of a time working through that but at long last working wireless and a mouse that doesn't have a mind of it's own! Great work!
    . . . go to work, send your kids to school, follow fashion, act normal, walk on the pavements, watch T.V., save for your old age, obey the law. Repeat after me: I am free. --anonymous

  5. #135
    Join Date
    Aug 2010
    Beans
    33

    Re: Elantech touchpad improperly recognized as “ImPS/2 Logitech Wheel Mouse”

    Since this does its work on the X in memory it is not persistent. If you log out and back in the mousepad will be active again. This is desired behavior for me as I occasionally need to be able to use the laptop without my external mouse.

  6. #136
    Join Date
    Aug 2006
    Beans
    Hidden!
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Elantech touchpad improperly recognized as “ImPS/2 Logitech Wheel Mouse”

    sudo apt-get install linux-source linux-headers-`uname -r` build-essential libncurses5 libncurses5-dev make-kpkg fakeroot
    What's make-kpkg? I wasn't able to locate the package.

  7. #137
    Join Date
    Oct 2008
    Beans
    100

    Re: Elantech touchpad improperly recognized as “ImPS/2 Logitech Wheel Mouse”

    Quote Originally Posted by mikewhatever View Post
    What's make-kpkg? I wasn't able to locate the package.
    Brutal. That's a brainfart, sorry. It's kernel-package which has make-kpkg in it. I'm surprised nobody called me out on it!

    http://packages.ubuntu.com/lucid/kernel-package

    I updated my post with the instructions here...

    http://ubuntuforums.org/showpost.php...1&postcount=44

  8. #138
    Join Date
    Aug 2006
    Beans
    Hidden!
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Elantech touchpad improperly recognized as “ImPS/2 Logitech Wheel Mouse”

    Thanks for the quick reply. I've applied the patch on Dell mini 10 running Karmic 2.6.31, and the touchpad now works as before, but when I run 'synclient AreaBottomEdge=600', the output is:
    synclient AreaBottomEdge=600
    Couldn't find synaptics properties. No synaptics driver loaded?
    same for 'syndaemon -i 1 -d'
    syndaemon -i 1 -d
    Unable to find a synaptics device.

  9. #139
    Join Date
    Oct 2008
    Beans
    100

    Re: Elantech touchpad improperly recognized as “ImPS/2 Logitech Wheel Mouse”

    You're on a dell mini, did you force the version by manually editing the patch as in step 5.5?

    In the output from
    Code:
    grep -i elantech /var/log/messages
    You should see lines like 'elantech: assuming hardware version...' and 'synaptics capabilities query result'.

  10. #140
    Join Date
    Jan 2008
    Location
    Miami, Florida
    Beans
    264

    Re: Elantech touchpad improperly recognized as “ImPS/2 Logitech Wheel Mouse”

    I have the same touchpad on my Lenovo Ideapad Z560. What worked for me was the following:
    Code:
    sudo rmmod psmouse
    sudo modprobe psmouse proto=imps
    In order to make the change permanent you must add a file to /etc/modprobe.d/. The file must have .conf at the end. I named my file touchpad.conf. The file must have the following line:
    options psmouse proto=imps

    Hope this helps.
    Ubuntu unleashed

    If you're unsure what a command does then type
    Code:
    man command

Page 14 of 21 FirstFirst ... 41213141516 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •