Page 1 of 21 12311 ... LastLast
Results 1 to 10 of 201

Thread: Elantech touchpad improperly recognized as “ImPS/2 Logitech Wheel Mouse”

  1. #1
    Join Date
    Nov 2009
    Location
    Canada
    Beans
    7
    Distro
    Ubuntu 10.04 Lucid Lynx

    Elantech touchpad improperly recognized as “ImPS/2 Logitech Wheel Mouse”

    Hello everyone!
    This is my first post. I hope I have posted it in the appropriate section.

    Here is the problem I'm having:
    I just purchased the Asus K61IC-A1 laptop and installed Ubuntu 9.10 on it.
    Everything is now working properly with the exception of the Touchpad, which is made by Elantech.
    To clarify, the Touchpad does function correctly, but I cannot configure some of its properties.
    I want to disable 'click' on the pad, but when I go to System->Preferences->Mouse, there is no 'Touchpad' tab; which is where the 'Enable mouse clicks with touchpad' option is located.

    I assume this is a driver/detection issue but I don't really know how to proceed.

    I did find some information about Elantech touchpads in Ubuntu on eeepc's but it did not help, it just kept breaking X.

    Here is the relevant section of my /proc/bus/input/devices (which shows the improper detection - i think!?) and my whole xorg.conf:

    -------start /proc/bus/input/devices-------
    I: Bus=0011 Vendor=0002 Product=0005 Version=0063
    N: Name="ImPS/2 Logitech Wheel Mouse"
    P: Phys=isa0060/serio4/input0
    S: Sysfs=/devices/platform/i8042/serio4/input/input9
    U: Uniq=
    H: Handlers=mouse1 event9
    B: EV=7
    B: KEY=70000 0 0 0 0
    B: REL=103
    -------end /proc/bus/input/devices-------


    -------start xorg.conf-------
    Section "Screen"
    Identifier "Default Screen"
    DefaultDepth 24
    EndSection
    Section "Module"
    Load "glx"
    EndSection
    Section "Device"
    Identifier "Default Device"
    Driver "nvidia"
    Option "NoLogo" "True"
    EndSection
    -------end xorg.conf-------


    Thanks in advance for any help you can provide!

  2. #2
    Join Date
    Dec 2007
    Beans
    16
    Distro
    Hardy Heron (Ubuntu Development)

    Re: Elantech touchpad improperly recognized as “ImPS/2 Logitech Wheel Mouse”

    Affects me on my Dell Mini 10 (1010.)

  3. #3
    Join Date
    Feb 2007
    Location
    Lithuania
    Beans
    Hidden!
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Elantech touchpad improperly recognized as “ImPS/2 Logitech Wheel Mouse”

    Any solution found yet?

  4. #4
    Join Date
    Feb 2007
    Location
    Corona, CA - US
    Beans
    19
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Elantech touchpad improperly recognized as “ImPS/2 Logitech Wheel Mouse”

    Solution found for me in Karmic.

    I have an Asus U81 (Best Buy version of the U80) which has the Elantech mousepad.

    A friend shared this solution.

    9.10 includes an X configuration utility called xinput. It is a command line tool. To see the many things you can do with this simply type xinput at a shell prompt.

    Start by typing in:
    xinput list
    This will show you all the input devices attached to your computer. You will need to know your mousepad's id to continue. On My Asus laptop the internal pointer was found as a "ImPS/2 Logitech Wheel Mouse". The Id I get after booting my system with my external mouse attached is 10.

    Next you need to know how to disable the mousepad. So you need to know what properties it supports. the command is "xinput list-props" followed by your mousepad's id number, which for me was:
    xinput list-props 10
    The "Device Enabled" was what I needed to be able to use to switch it off. On my laptop this line was "Device Enabled (97): 1". The parenthesized number is the properties id number, the 1 that follows it is the value (0 will turn it off).

    So now I need to set it such that the mousepad is disabled. My mousepad id is 10, property id I want to set is 97 and I need to set the property value to be 0. The option for xinput is set-int-prop which needs deviceid, propertyid, format of the value (8, 16, or 32 bit), and the value itself. For me this is:
    xinput set-int-prop 10 97 8 0
    To turn it back on:
    xinput set-int-prop 10 97 8 1
    Since this does its work on the X in memory it is not persistent. If you log out and back in the mousepad will be active again. This is desired behavior for me as I occasionally need to be able to use the laptop without my external mouse.

    When I get a little time, I will write a small shell script that can toggle it on or off based on a grep of the output of "xinput list" and bind it to a key combination so I can do this without having to drop out to a script. (EDIT NOTE: See post #15 in this thread if you want the scripts)

    One last note, xinput interacts with X. It will not be able to function at a normal terminal screen not running under your X. It will work just fine in an xterminal (the one under accessories menu).

    Gram
    Last edited by sg3524; January 10th, 2010 at 08:20 PM.

  5. #5
    Join Date
    Apr 2009
    Beans
    42

    Re: Elantech touchpad improperly recognized as “ImPS/2 Logitech Wheel Mouse”

    sg3524,

    Thank you. Works great. I made a slight modification that I believe is a little more robust. Instead of using the id, use the actual string:

    xinput set-int-prop "ImPS/2 Logitech Wheel Mouse" 97 8 0

  6. #6
    Join Date
    Feb 2007
    Location
    Corona, CA - US
    Beans
    19
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Elantech touchpad improperly recognized as “ImPS/2 Logitech Wheel Mouse”

    Quote Originally Posted by c901906 View Post
    sg3524,

    Thank you. Works great. I made a slight modification that I believe is a little more robust. Instead of using the id, use the actual string:

    xinput set-int-prop "ImPS/2 Logitech Wheel Mouse" 97 8 0
    That's actually a lot better solution. I should have tried that, since the id can change depending on the number of devices attached at boot time.

    Thanks for posting it!

  7. #7
    Join Date
    Dec 2009
    Beans
    38
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Elantech touchpad improperly recognized as “ImPS/2 Logitech Wheel Mouse”

    ive been wrestling with this for a while. Asus laptop, touchpad is identified as a PS2 mouse. All i want to do is enable the "disable touchpad while typing" function as im ALWAYS lightly brushing it and end up typing somewhere other than what i want.

    Its a elantech and any help on this matter would be HUGELY appreciated.

    karmic 9.10 x86_64 - 2.6.31-16

  8. #8
    Join Date
    Dec 2007
    Beans
    97

    Re: Elantech touchpad improperly recognized as “ImPS/2 Logitech Wheel Mouse”

    I am in the same situation as QuanTime. I have a new ASUS K60 laptop with Karmic Koala. I just want to disable the touchpad while typing.

  9. #9
    Join Date
    Dec 2009
    Beans
    38
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Elantech touchpad improperly recognized as “ImPS/2 Logitech Wheel Mouse”

    http://ubuntuforums.org/showthread.p...87#post8505087

    Thats as far as i got.. Im on a K70 Asus laptop.. So it seems to be some sort of common problem with the Asus.

    What does the Asus EEEpc use ? I read somewhere it uses elantech.. but i could be wrong.. Is this some way it might help us ?

    Incidently, you tried the webcam with skype ? i got that sorted. The video from my cam was inverted. But submitted a bug and the dev fixed it.. Freakin my hero !!

    Now just get this sorted, and im set.

  10. #10
    Join Date
    Dec 2007
    Beans
    97

    Re: Elantech touchpad improperly recognized as “ImPS/2 Logitech Wheel Mouse”

    Yeah my webcam is flipped. How can I fix that? If you submitted a bug it should cover mine too, right?

Page 1 of 21 12311 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •