Page 1 of 3 123 LastLast
Results 1 to 10 of 26

Thread: Atheros wireless on Acer 4736ZG fails to connect

  1. #1
    Join Date
    Nov 2009
    Beans
    3

    Atheros wireless on Acer 4736ZG fails to connect

    Hi, all

    I'm new in this forum. Greetings!

    Ubuntu 9.10 Karmic Koala is running on my Acer 4736ZG and everything, except for the lovely wireless connection, works perfectly.

    Here is the information from lspci:

    04:00.0 Network controller: Atheros Communications Inc. AR928X Wireless Network Adapter (PCI-Express) (rev 01)
    Subsystem: Device 1a32:0306
    Flags: bus master, fast devsel, latency 0, IRQ 17
    Memory at 99200000 (64-bit, non-prefetchable) [size=64K]
    Capabilities: <access denied>
    Kernel driver in use: ath9k
    Kernel modules: ath9k

    In the first few minutes after a fresh boot up, the wireless connection is automatically connected, but with very low speed. And then it refuses to work. I repeat to click, wait, fail, click, wait, fail...

    It's so irritating when I need some information from the Internet and have to switch back to the boring Windows for help. (Not trying to say Windows is bad. Just personal preference)

    I'm posting here in my hotel through wired connection. As I said, everything works perfectly, with wired connection there. But I could only get access to the Internet through wireless network when I work in the company. And that hurts.

    Wish there are fellows in here having had the same issue and solved it. Please help me out of this. If you need more information, please ask for it.

    Thanks.

    Zak

  2. #2
    Join Date
    Jun 2006
    Location
    UK
    Beans
    Hidden!
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: Atheros wireless on Acer 4736ZG fails to connect

    I come bearing good tidings. I am posting from an Acer Aspire 7540 running Karmic and with:

    Code:
    06:00.0 Network controller: Atheros Communications Inc. AR928X Wireless Network Adapter (PCI-Express) (rev 01)
    ... the identical wireless chipset to yours. The connection is fast and stable - now. Like you with a default install the connection was weak and soon disconnected and wouldn't reconnect. All I did was to install the packages:

    linux-backports-modules-2.6.31-14-generic
    linux-backports-modules-karmic
    linux-backports-modules-karmic-generic
    linux-backports-modules-wireless-karmic-generic

    You need to reboot and then you should be OK.

    Edit: of course, you will probably want to use the wired connection to do the install of the modules. And you don't need the backports repository enabled. Although they have 'backports' in the package name, they're in the main repository.
    Last edited by coffeecat; November 20th, 2009 at 03:13 PM.
    Ubuntu 16.04 Desktop Guide - Ubuntu 14.04 Desktop Guide - Forum Guide to BBCode - IRC #ubuntuforums

    Member: Not Canonical Team

    Please do not PM me about your forum account unless you have been asked to. The correct place to contact an admin about your account is here.

  3. #3
    Join Date
    Nov 2009
    Beans
    3

    Re: Atheros wireless on Acer 4736ZG fails to connect

    That's delicious!

    I do think this will just work out for me because we are having the same model here. But I could only try out by tomorrow at work. I'll post back here then with my results.

    Thanks.

    Zak

  4. #4
    Join Date
    Nov 2009
    Beans
    3

    Re: Atheros wireless on Acer 4736ZG fails to connect

    Now I come back with good tidings

    Signal improved from 30% yesterday to a stable 70+% today. Very nice connection. Backports guys are a maze!

    Internet speed is not fast as normal though, I don't need to spend that many minutes to restart and boot into another OS.

    Thanks a million!

    Zak

  5. #5
    Join Date
    Sep 2008
    Beans
    31

    Re: Atheros wireless on Acer 4736ZG fails to connect

    yes, thank you so much! I've been struggling with Linux on a Toshiba NB205 with the same wireless radio, and I'm hoping that those days are over!

    Everything seems to be working fine - thanks again!

  6. #6
    Join Date
    Feb 2009
    Location
    Washington State
    Beans
    95

    Re: Atheros wireless on Acer 4736ZG fails to connect

    OK this looks very hopeful.
    I am too new to linux to understand some commonly used words etc.

    Is my kernel jaunty? (I didn't upgrade yet)

    I used these instrux the other day

    ------
    cd Desktop
    tar -xf compat-wireless-2.6.30.tar.bz2
    cd compat-wireless-2.6.30
    make
    sudo make install
    sudo make unload

    ======================
    from:
    http://linuxwireless.org/en/users/Download/stable/

    -------
    I will do all this again but this time I will use the 2.6.31 version, but when I was finished the other day it worked until I rebooted after the most recent update.

    No one has answered this yet.
    Where does this folder go/or belong when it is finished?

    Should I just drop it into the file system folder?
    (Mine ended up on my desktop, and I do not know if that is my problem?? or the choice of the wrong backports?)

    Thank you for any help,

    jeanna

  7. #7
    Join Date
    Mar 2007
    Beans
    57

    Re: Atheros wireless on Acer 4736ZG fails to connect

    Quote Originally Posted by jeannacav View Post
    Is my kernel jaunty? (I didn't upgrade yet)
    System | About Ubuntu

    or

    lsb_release -a

    or

    cat /etc/lsb-release

    Upgrading from Jaunty to Karmic didn't solve my wireless woes though.

    Quote Originally Posted by jeannacav View Post
    Where does this folder go/or belong when it is finished?

    Should I just drop it into the file system folder?
    (Mine ended up on my desktop, and I do not know if that is my problem?? or the choice of the wrong backports?)
    You can unzip that tarball anywhere you like, but normally the desktop is not a good idea cause you don't want too much clutter there. I use a /home/david/downloads folder, or perhaps clearer would be a /home/david/src folder.
    Last edited by The Dragon Master; November 22nd, 2009 at 01:51 PM.

  8. #8
    Join Date
    Mar 2007
    Beans
    57

    Re: Atheros wireless on Acer 4736ZG fails to connect

    Quote Originally Posted by coffeecat View Post
    linux-backports-modules-2.6.31-14-generic
    linux-backports-modules-karmic
    linux-backports-modules-karmic-generic
    linux-backports-modules-wireless-karmic-generic

    You need to reboot and then you should be OK.

    Edit: of course, you will probably want to use the wired connection to do the install of the modules. And you don't need the backports repository enabled. Although they have 'backports' in the package name, they're in the main repository.
    Thanks for the sugfgestion, I don't have a wired connection, but I do have another laptop running a chinese version of XP so I could get the four .deb packages above and do a dpkg -i with them. Didn't solve my problem though.

    In brief my problem is:
    1)lshw shows my AR928X wireless adaptor as disabled,
    2) ifconfig doesn't even show the wlan0,
    3) a "ifconfig wlan0 up" returns an error

    In detail...

    $ sudo lshw
    *-pci:1
    description: PCI bridge
    product: PCI-to-PCI bridge
    vendor: Silicon Integrated Systems [SiS]
    physical id: 6
    bus info: pci@0000:00:06.0
    version: 00
    width: 32 bits
    clock: 33MHz
    capabilities: pci msi pciexpress pm bus_master cap_list
    configuration: driver=pcieport-driver
    resources: irq:25 memory:fdf00000-fdffffff
    *-network DISABLED
    description: Wireless interface
    product: AR928X Wireless Network Adapter (PCI-Express)
    vendor: Atheros Communications Inc.
    physical id: 0
    bus info: pci@0000:02:00.0
    logical name: wlan0
    version: 01
    serial: 00:22:43:51:b2:6b
    width: 64 bits
    clock: 33MHz
    capabilities: pm msi pciexpress msix bus_master cap_list ethernet physical wireless
    configuration: broadcast=yes driver=ath9k latency=0 multicast=yes wireless=IEEE 802.11bgn
    resources: irq:16 memory:fdff0000-fdffffff

    $ sudo ifconfig wlan0 up
    SIOCSIFFLAGS: Unknown error 132

    $ uname -a
    Linux wert 2.6.31-14-generic #48-Ubuntu SMP Fri Oct 16 14:04:26 UTC 2009 i686 GNU/Linux

    $ sudo dhclient
    Internet Systems Consortium DHCP Client V3.1.2
    Copyright 2004-2008 Internet Systems Consortium.
    All rights reserved.
    For info, please visit http://www.isc.org/sw/dhcp/

    SIOCSIFFLAGS: Unknown error 132
    SIOCSIFFLAGS: Unknown error 132
    Listening on LPF/wlan0/00:22:43:51:b2:6b
    Sending on LPF/wlan0/00:22:43:51:b2:6b
    Listening on LPF/eth0/00:23:54:ef:da:51
    Sending on LPF/eth0/00:23:54:ef:da:51
    Sending on Socket/fallback
    receive_packet failed on wlan0: Network is down
    DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 3
    send_packet: Network is down
    DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 5
    DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 7
    send_packet: Network is down
    DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 9

    $ tail -f /var/log/syslog
    Nov 22 13:33:24 wert dhclient: DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 3
    Nov 22 13:33:24 wert dhclient: send_packet: Network is down
    Nov 22 13:33:26 wert dhclient: DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 5
    Nov 22 13:33:27 wert dhclient: DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 7
    Nov 22 13:33:27 wert dhclient: send_packet: Network is down
    Nov 22 13:33:31 wert dhclient: DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 9
    Nov 22 13:33:32 wert kernel: [ 319.108049] eth0: auto-negotiating...
    Nov 22 13:33:42 wert kernel: [ 329.132042] eth0: auto-negotiating...
    Nov 22 13:33:52 wert kernel: [ 339.156044] eth0: auto-negotiating...


    $ ifconfig
    eth0 Link encap:Ethernet HWaddr 00:23:54:ef:da:51
    UP BROADCAST MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
    Interrupt:19 Base address:0xdead

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:4 errors:0 dropped:0 overruns:0 frame:0
    TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:240 (240.0 B) TX bytes:240 (240.0 B)



    $ lsmod
    Module Size Used by
    binfmt_misc 8356 1
    joydev 10272 0
    psmouse 56180 0
    serio_raw 5280 0
    ath_pci 203476 0
    wlan 226448 1 ath_pci
    ath_hal 303104 1 ath_pci
    ppdev 6688 0
    lp 8964 0
    arc4 1660 2
    uvcvideo 59080 0
    ecb 2524 2
    ath9k 307384 0
    mac80211 210408 1 ath9k
    ath 8444 1 ath9k
    videodev 36736 1 uvcvideo
    parport 35340 2 ppdev,lp
    sis190 17824 0
    asus_laptop 17400 0
    v4l1_compat 14496 2 uvcvideo,videodev
    mii 5212 1 sis190
    snd_hda_codec_realtek 203328 1
    cfg80211 130440 3 ath9k,mac80211,ath
    led_class 4096 2 ath9k,asus_laptop
    snd_hda_intel 26920 2
    snd_hda_codec 75708 2 snd_hda_codec_realtek,snd_hda_intel
    snd_hwdep 7200 1 snd_hda_codec
    snd_pcm_oss 37920 0
    snd_mixer_oss 16028 1 snd_pcm_oss
    snd_pcm 75296 3 snd_hda_intel,snd_hda_codec,snd_pcm_oss
    snd_seq_dummy 2656 0
    snd_seq_oss 28576 0
    snd_seq_midi 6432 0
    snd_rawmidi 22208 1 snd_seq_midi
    snd_seq_midi_event 6940 2 snd_seq_oss,snd_seq_midi
    snd_seq 50224 6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_mid i_event
    snd_timer 22276 2 snd_pcm,snd_seq
    iptable_filter 3100 0
    snd_seq_device 6920 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi ,snd_seq
    ip_tables 11692 1 iptable_filter
    x_tables 16544 1 ip_tables
    snd 59204 16 snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec, snd_hwdep,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_se q_oss,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
    soundcore 7264 1 snd
    snd_page_alloc 9156 2 snd_hda_intel,snd_pcm
    usb_storage 52544 0
    video 19380 0
    output 2780 1 video
    radeon 636000 1
    ttm 36212 1 radeon
    drm 159584 3 radeon,ttm
    i2c_algo_bit 5760 1 radeon
    sis_agp 6972 0
    agpgart 34988 3 ttm,drm,sis_agp


    Did I forget anything?

  9. #9
    Join Date
    Mar 2007
    Beans
    57

    Re: Atheros wireless on Acer 4736ZG fails to connect

    bump

  10. #10
    Join Date
    Nov 2008
    Beans
    32

    Re: Atheros wireless on Acer 4736ZG fails to connect

    Quote Originally Posted by coffeecat View Post
    All I did was to install the packages:

    linux-backports-modules-2.6.31-14-generic
    linux-backports-modules-karmic
    linux-backports-modules-karmic-generic
    linux-backports-modules-wireless-karmic-generic

    You need to reboot and then you should be OK.

    Edit: of course, you will probably want to use the wired connection to do the install of the modules.
    Worked like a charm for me and my Toshiba Satellite.
    For those of you who don't want to go searching for ethernet cables, I managed to install these packages by booting into the 2.6.28-16-generic, which had my wireless working perfectly. I installed the four packages using Synaptic Package Manager, rebooted into 2.6.31-15-generic, and everything's peachy!

    Thanks very much, Coffeecat

Page 1 of 3 123 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •