Results 1 to 10 of 10

Thread: Cannot start JACK to use Creox c for my guitar

  1. #1
    Join Date
    Nov 2009
    Location
    New England, USA
    Beans
    8
    Distro
    Ubuntu Studio 9.10 Karmic Koala

    Cannot start JACK to use Creox c for my guitar

    [EDIT - UPDATE] I used the package manager to install linux-rt and dependencies, but I am not given a choice to boot using the realtime kernel - how might I do that? [/EDIT - UPDATE]

    Hey everyone, 3-day Ubuntu noob here, loving it so far!

    I am currently running Karmic and I have encountered a tiny issue. I cannot seem to get the mixer to recognize any input levels from my SB Live Platinum's Line2 from the LiveDrive. I also can't get JACK to start so I can use Creox c. Below is my comp and the steps I've taken.

    Here's my setup (laughs totally welcomed):
    (most equipment circa 2001ish)
    Asus P4t motherboard with last BIOS produced for it.
    P4 1.7gHz and 1 GB of RAMBUS
    200GB HDD
    52X generic CD-ROM
    Plextor Plexwriter 40/12/40x
    nVidia geForce2 MX 200 AGP 4x card with 64 big ones
    SB Live! Platinum with Live Drive (line2/Mic2 inputs - this is the part I need help with)

    I was able to use alsamixer to turn up the levels on the "Line LiveDrive" slider and get sound through my speakers. Clean guitar is good to go! It doesn't register any levels in Preferences > Sound though, no matter which input I select, using "Analog Stereo Duplex." Also tried "Analog Stereo output + Analog Mono input"... no dice.

    I installed JACK and Creox c for guitar effects, but when I open Jack control and click start (searched to get this step), I get this in the log:



    p, li { white-space: pre-wrap; } 14:12:24.280 Startup script terminated with exit status=32512.
    14:12:24.282 JACK is starting...
    14:12:24.285 /usr/bin/jackd -R -dalsa -dhw:0 -r44100 -p1024 -n2
    14:12:24.397 JACK was started with PID=7618.
    no message buffer overruns
    jackd 0.116.1
    Copyright 2001-2005 Paul Davis and others.
    jackd comes with ABSOLUTELY NO WARRANTY
    This is free software, and you are welcome to redistribute it
    under certain conditions; see the file COPYING for details
    JACK compiled with System V SHM support.
    cannot use real-time scheduling (FIFO at priority 10) [for thread -1216829760, from thread -1216829760] (1: Operation not permitted)
    cannot create engine
    14:12:24.422 JACK was stopped successfully.
    14:12:24.431 Post-shutdown script...
    14:12:24.432 killall jackd
    jackd: no process found
    14:12:24.854 Post-shutdown script terminated with exit status=256.
    14:12:26.497 Could not connect to JACK server as client. - Overall operation failed. - Unable to connect to server. Please check the messages window for more info.



    I am stumped. any ideas? I have no idea what to search for at this point. "Operation Not Permitted" is hinting at needing some sort of root command, yes?

    Thanks in advance to anyone who can help!
    Last edited by boredpcguy; November 16th, 2009 at 10:30 PM.

  2. #2
    Join Date
    Jun 2009
    Location
    NSW Australia
    Beans
    124
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Cannot start JACK to use Creox c for my guitar

    RT kernel stuff is a bit over my head, but I'll try to help anyway.
    Personally, I just use jack without realtime by unchecking the "Realtime" checkbox in setup (on the settings tab, under Parameters).

    If the rt kernel option isn't appearing in the boot list, you should be able to add it manually with a bit of effort, but I'll need a bit more info first...
    So open a teminal (applications>accessories>terminal) and type:
    Code:
    find /boot/*rt
    cat /boot/grub/grub.cfg
    And post the results.

  3. #3
    Join Date
    Nov 2009
    Location
    New England, USA
    Beans
    8
    Distro
    Ubuntu Studio 9.10 Karmic Koala

    Re: Cannot start JACK to use Creox c for my guitar

    Thanks for replying. I have tried JACK in non-realtime, but it doesn't seem to play well with that front Line2 input. When I open Creox , start it after starting JACK in said mode, I can adjust the gain and hear something happening, but it is happening to a different input. The guitar remains clean as a bell with no effects. I will find an adapter to check the results of other jacks on my sound card.

    Here's my find output:
    Code:
    boredpcguy@boredbuntu:~$ find /boot/*rt
    /boot/abi-2.6.31-9-rt
    /boot/config-2.6.31-9-rt
    /boot/initrd.img-2.6.31-9-rt
    /boot/System.map-2.6.31-9-rt
    /boot/vmcoreinfo-2.6.31-9-rt
    /boot/vmlinuz-2.6.31-9-rt
    The realtime kernel is there and chilling, but I don't get a boot menu even with recovery options. I should also add I know of no hotkeys to bring up the boot menu during boot so that might be the problem itself.

    Here's the output for my grub.cfg...

    Code:
    boredpcguy@boredbuntu:~$ cat /boot/grub/grub.cfg
    #
    # DO NOT EDIT THIS FILE
    #
    # It is automatically generated by /usr/sbin/grub-mkconfig using templates
    # from /etc/grub.d and settings from /etc/default/grub
    #
    
    ### BEGIN /etc/grub.d/00_header ###
    if [ -s /boot/grub/grubenv ]; then
      have_grubenv=true
      load_env
    fi
    set default="0"
    if [ ${prev_saved_entry} ]; then
      saved_entry=${prev_saved_entry}
      save_env saved_entry
      prev_saved_entry=
      save_env prev_saved_entry
    fi
    insmod ext2
    set root=(hd0,1)
    search --no-floppy --fs-uuid --set 7730e19a-0634-4db9-a6df-ac19a59b99c8
    if loadfont /usr/share/grub/unicode.pf2 ; then
      set gfxmode=640x480
      insmod gfxterm
      insmod vbe
      if terminal_output gfxterm ; then true ; else
        # For backward compatibility with versions of terminal.mod that don't
        # understand terminal_output
        terminal gfxterm
      fi
    fi
    if [ ${recordfail} = 1 ]; then
      set timeout=-1
    else
      set timeout=10
    fi
    ### END /etc/grub.d/00_header ###
    
    ### BEGIN /etc/grub.d/05_debian_theme ###
    set menu_color_normal=white/black
    set menu_color_highlight=black/white
    ### END /etc/grub.d/05_debian_theme ###
    
    ### BEGIN /etc/grub.d/10_linux ###
    menuentry "Ubuntu, Linux 2.6.31-14-generic" {
            recordfail=1
            if [ -n ${have_grubenv} ]; then save_env recordfail; fi
        set quiet=1
        insmod ext2
        set root=(hd0,1)
        search --no-floppy --fs-uuid --set 7730e19a-0634-4db9-a6df-ac19a59b99c8
        linux    /boot/vmlinuz-2.6.31-14-generic root=UUID=7730e19a-0634-4db9-a6df-ac19a59b99c8 ro   quiet splash
        initrd    /boot/initrd.img-2.6.31-14-generic
    }
    menuentry "Ubuntu, Linux 2.6.31-14-generic (recovery mode)" {
            recordfail=1
            if [ -n ${have_grubenv} ]; then save_env recordfail; fi
        insmod ext2
        set root=(hd0,1)
        search --no-floppy --fs-uuid --set 7730e19a-0634-4db9-a6df-ac19a59b99c8
        linux    /boot/vmlinuz-2.6.31-14-generic root=UUID=7730e19a-0634-4db9-a6df-ac19a59b99c8 ro single 
        initrd    /boot/initrd.img-2.6.31-14-generic
    }
    menuentry "Ubuntu, Linux 2.6.31-9-rt" {
            recordfail=1
            if [ -n ${have_grubenv} ]; then save_env recordfail; fi
        set quiet=1
        insmod ext2
        set root=(hd0,1)
        search --no-floppy --fs-uuid --set 7730e19a-0634-4db9-a6df-ac19a59b99c8
        linux    /boot/vmlinuz-2.6.31-9-rt root=UUID=7730e19a-0634-4db9-a6df-ac19a59b99c8 ro   quiet splash
        initrd    /boot/initrd.img-2.6.31-9-rt
    }
    menuentry "Ubuntu, Linux 2.6.31-9-rt (recovery mode)" {
            recordfail=1
            if [ -n ${have_grubenv} ]; then save_env recordfail; fi
        insmod ext2
        set root=(hd0,1)
        search --no-floppy --fs-uuid --set 7730e19a-0634-4db9-a6df-ac19a59b99c8
        linux    /boot/vmlinuz-2.6.31-9-rt root=UUID=7730e19a-0634-4db9-a6df-ac19a59b99c8 ro single 
        initrd    /boot/initrd.img-2.6.31-9-rt
    }
    ### END /etc/grub.d/10_linux ###
    
    ### BEGIN /etc/grub.d/20_memtest86+ ###
    menuentry "Memory test (memtest86+)" {
        linux16    /boot/memtest86+.bin
    }
    menuentry "Memory test (memtest86+, serial console 115200)" {
        linux16    /boot/memtest86+.bin console=ttyS0,115200n8
    }
    ### END /etc/grub.d/20_memtest86+ ###
    
    ### BEGIN /etc/grub.d/30_os-prober ###
    if [ ${timeout} != -1 ]; then
      if keystatus; then
        if keystatus --shift; then
          set timeout=-1
        else
          set timeout=0
        fi
      else
        if sleep --interruptible 3 ; then
          set timeout=0
        fi
      fi
    fi
    ### END /etc/grub.d/30_os-prober ###
    
    ### BEGIN /etc/grub.d/40_custom ###
    # This file provides an easy way to add custom menu entries.  Simply type the
    # menu entries you want to add after this comment.  Be careful not to change
    # the 'exec tail' line above.
    ### END /etc/grub.d/40_custom ###
    I guess the real question is whether or not my noobness is holding me back or if there is something that needs to be switched on.

  4. #4
    Join Date
    Jun 2009
    Location
    NSW Australia
    Beans
    124
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Cannot start JACK to use Creox c for my guitar

    Your grub.cfg has the RT kernel added. So give this a try: if you hold down the Shift key as the computer attempts to boot it should display the GRUB 2 menu.
    Last edited by nathan726; November 18th, 2009 at 01:54 AM. Reason: spelling

  5. #5
    Join Date
    Nov 2009
    Location
    New England, USA
    Beans
    8
    Distro
    Ubuntu Studio 9.10 Karmic Koala

    Re: Cannot start JACK to use Creox c for my guitar

    I was able to boot up using the RT kernel, thanks to that hotkey info! However, JACK still errors to "operation not permitted" as in the first post. Looks like I'll just uncheck realtime and try it out that way.

    In JACK, does anyone know which port I am supposed to connect to the soundcard, to be able to record from line2? maybe that'll be my solution to creox.

    Thanks again!

  6. #6
    Join Date
    Jun 2009
    Location
    NSW Australia
    Beans
    124
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Cannot start JACK to use Creox c for my guitar

    Try this - open a terminal and run:
    Code:
    sudo useradd -G audio yourusername
    That will add you to the "audio" user group, and hopefully let you run jack in real-time.

  7. #7
    Join Date
    Nov 2009
    Location
    New England, USA
    Beans
    8
    Distro
    Ubuntu Studio 9.10 Karmic Koala

    Lightbulb Re: Cannot start JACK to use Creox c for my guitar

    Thanks again. I am now able to run JACK in realtime, ended up adding myself to audio. One more victory!

    Now, I seem to be stuck at the next phase, which is getting some effects working. I tried the line2 input and also my mic input using what audio equip I had lying around that fit. (yeah, I was using some old headphones as a mic - quite effectively - hahaha) Unfortunately, nothing is causing any change in audio from either port. I have tried alsa-mixer on mic1, mic2, and line livedrive, but I fail to make a change in the output. I even searched outside of the forum for a tutorial and found out I was setting up my connections right. I tried both Creox c and JACK rack. Nonesuch luck. I am beginning to believe there is something stupidly easy I'm not doing right. Is there a different driver out there that supports SB Live Platinums better than EMU10k1?

    Here's what I have gathered for info so far:
    1. The software is happy as a clam. No errors, looks satisfied with the RealTime kernel etc... I am familiar enough with priorities to know not to mess with it (nice seems scary haha)
    2. I have tried every input in System > Preferences > Sound > Input and made sure they weren't muted, and tried varying levels.
    3. I have tried the proper, and various improper ways to connect the sevices together with playback in JACK.
    4. I have determined the Line2 on my LiveDrive is controlled in AlsaMixer by "Line LiveDrive" and nothing else.
    5. Even the mic input, which works when enabled in AlsaMixer, doesn't get affected in any of the above configurations from points 2 and 3.

    This is driving me (more) insane. I am doing something wrong. I'd give up on it but I have the same issue with Sound Recorder and using that input to record.


    I love open source forums, never had so much good will and help in my life. I can't wait to get better at this so I can return the favors someday.

  8. #8
    Join Date
    Jun 2009
    Location
    NSW Australia
    Beans
    124
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Cannot start JACK to use Creox c for my guitar

    So that's one problem solved
    Now, lets try and figure out why you don't have any audio input...

    Open a terminal and run:
    Code:
    alsamixer -Vcapture
    And take a screenshot of that with <Alt+PrtSc> and post it here.

  9. #9
    Join Date
    Nov 2009
    Location
    New England, USA
    Beans
    8
    Distro
    Ubuntu Studio 9.10 Karmic Koala

    Re: Cannot start JACK to use Creox c for my guitar

    I will get a screenshot going in a sec, apparently there are a billion controls for alsa and/or my sound card. I just remembered one important thing... The only way I was able to get the line2 ever wasa when I was in windows running AudioHQ from Creative, under the recording volume it allowed me to choose a source, and either Line2/Mic2 or "What U Hear" worked with the input. Others have gotten it working but I guess this card is a real PITA to work with.


    EDIT: I added the screenshot, didn't include the first couple (bass, treb, 3d control) because they are trivial and set appropriately. The one I have my cursor over is the one that affects the volume of my Line2.


    Last edited by boredpcguy; November 19th, 2009 at 06:21 AM. Reason: added screenshot

  10. #10
    Join Date
    Jun 2009
    Location
    NSW Australia
    Beans
    124
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Cannot start JACK to use Creox c for my guitar

    A few links:
    http://ubuntuforums.org/showthread.php?t=810442
    http://www.linuxquestions.org/questi...8/#post2892116
    http://folk.uio.no/haakoh/emu10k1/

    From http://alsa.opensrc.org/index.php/Emu10k1:
    In alsamixer, set Capture to something reasonable (I have 53) and *hit space bar* to enable Capture. Then set the volume for the source you want, and hit spacebar for capture on that too. I have AC97 set to zero and AC97 Capture set to 100, not sure if this does anything, but mic/line/cd recording now works for me.
    Last edited by nathan726; November 19th, 2009 at 07:52 AM.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •