Results 1 to 8 of 8

Thread: modem huawei E1752 on ubuntu 9.04

  1. #1
    Join Date
    Nov 2009
    Beans
    2

    modem huawei E1752 on ubuntu 9.04

    hi everybody, can somebody advice me, how to configure huawei E1752 modem on ubuntu 9.04?

    many thanks

  2. #2
    Join Date
    Nov 2009
    Location
    Dubai UAE
    Beans
    19
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: modem huawei E1752 on ubuntu 9.04

    It is simple Just plug in your modem if it is USB modem. go to the network manager click the mobile broadband tag if it is taken by ubuntu. it would be as a "auto cdma connection" edit the connection by clicking the edit button give the no to dial for the connection and the username and password dont forget to check the automatically connect options and also to check the box which makes it available for all users then click ok then close the program


    next time you plug in the modem before booting on to ubuntu. then boot the system it will be available



    Note user name and password and no to dial will be provided by the ISP So check it and do the procedure

    ALL THE BEST Happy browsing



    dalfish

  3. #3
    Join Date
    Nov 2009
    Beans
    2

    Re: modem huawei E1752 on ubuntu 9.04

    hi, thanks for answer, but I tried it and it didn't work

    finally I found great and easy article:

    http://www.blogcatalog.com/blog/iwrite-2/dbbfb38ae5ef9ccef8540aad7f9edbd6

  4. #4
    Join Date
    Apr 2008
    Beans
    152

    Post Re: modem huawei E1752 on ubuntu 9.04

    Quote Originally Posted by harvejs View Post
    hi, thanks for answer, but I tried it and it didn't work

    finally I found great and easy article:

    http://www.blogcatalog.com/blog/iwrite-2/dbbfb38ae5ef9ccef8540aad7f9edbd6
    That's what I found most helpful as well. I have tried (London, England) T-Mobile dongle and it gets recognized immediately and works. Orange E1752 doesn't.

    To sum up:
    1. Activate new dongle
    2. Install usb_modeswitch (preferably through Synaptic)
    3. Alt+F2 and write gksu gedit /etc/usb_modeswitch.conf
    4. Add this at the bottom of opened file:

    Code:
    ########################################################
    # Huawei E1752
    #
    # Contributor: 
    
    DefaultVendor=  0x12d1
    DefaultProduct= 0x1446
    
    TargetVendor=	0x12d1
    TargetProdct=	0x1001
    
    MessageEndpoint=	0x01
    
    MessageContent=	"55534243000000000000000000000011060000000000000000000000000000"
    5. Create the file: /etc/udev/rules.d/10-huawei-e1551.rules or 10-huawei-e1752.rules
    6. Paste that into it:

    Code:
    ATTRS{idVendor}==”12d1″, ATTRS{idProduct}==”1446″, 
    RUN+=”/usr/sbin/usb_modeswitch”
    7. Reboot
    8. Plug in dongle after system loads
    9. Go to Places -> Computer -> Unmount Dongle (error will pop up if you don't have memory card in it. Ignore error)
    10. Terminal and: sudo usb_modeswitch
    11. All should go fine. If not - dig the net
    12. Right click on Network Manager
    13. When adding New Mobile Connection on first screen is HUAWEI device you have succeed.
    14. Follow steps. For Orange UK use:
    number *99#
    user
    pass
    apn: consumerbroadband

    (user and pass leave blank)



    At this stage I need to unmount and start it from terminal every time.

    -Question to those who know programming well - is there any way to automate it ?
    Zorin

  5. #5
    Join Date
    Jun 2010
    Beans
    1

    Re: modem huawei E1752 on ubuntu 9.04

    hello, please if anyone could help a mostly noob at ubuntu
    I wouldn't ask if I wasn't desperate but I've been trying to ru.n huawei e1752 on my Lucid Lynx and it gives me no chance.

    in lsusb it says:


    Bus 002 Device 014: ID 12d1:1417 Huawei Technologies Co., Ltd.

    in /etc/usb-modeswitch.conf i wrote:

    ################################################## ######
    # Huawei E1752
    #
    # Contributor:

    DefaultVendor= 0x12d1
    DefaultProduct= 0x1417

    TargetVendor= 0x12d1
    TargetProdct= 0x1001

    MessageEndpoint= 0x01

    MessageContent= "5553424300000000000000000000001106000000000000000 0000000000000"


    and when i run usb_modeswitch it appears the next and doesn't let me connect:


    Looking for target devices ...
    No devices in target mode or class found
    Looking for default devices ...
    Found default devices (1)
    Accessing device 013 on bus 002 ...
    Using endpoints 0x01 (out) and 0x82 (in)
    Not a storage device, skipping SCSI inquiry

    USB description data (for identification)
    -------------------------
    Manufacturer: HUAWEI Technology
    Product: HUAWEI Mobile
    Serial No.: not provided
    -------------------------
    Looking for active driver ...
    OK, driver found ("option")
    OK, driver "option" detached
    Setting up communication with interface 0 ...
    Trying to send the message to endpoint 0x01 ...
    OK, message successfully sent
    -> Run lsusb to note any changes. Bye.

    and if in
    /etc/usb-modeswitch.conf i write 1446 instead of 1417 (as the code i've been fouding around) it just doesn't find any device.

    what could I be doing wrong?

    thx a lot



  6. #6
    Join Date
    Jun 2010
    Beans
    1

    Re: modem huawei E1752 on ubuntu 9.04

    OK NOW A BIT EASIER. We in Poland do it that way:
    1.Open Synaptic
    2. Instal usb-modeswitch
    3. Connect the modem into an USB.
    The modem should already work. The one last thing You may be expected to do is configuration of the connection.

    Have a nice day.

  7. #7
    Join Date
    Apr 2008
    Beans
    152

    Thumbs down Re: modem huawei E1752 on ubuntu 9.04

    That re-connection if it is not discovered properly is quite important as not always usb-modem which detect modem correctly...


    Quote Originally Posted by gtriderxc View Post
    We in Poland do it that way:
    [/B]
    Pozdrawiam Polske....

  8. #8
    Join Date
    Apr 2006
    Location
    UK
    Beans
    6,646
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: modem huawei E1752 on ubuntu 9.04

    Quote Originally Posted by gtriderxc View Post
    OK NOW A BIT EASIER. We in Poland do it that way:
    1.Open Synaptic
    2. Instal usb-modeswitch
    3. Connect the modem into an USB.
    The modem should already work. The one last thing You may be expected to do is configuration of the connection.

    Have a nice day.
    Indeed - for Orange UK (contract) customers - I am on the special £5 / month deal, this works too (Ubuntu 10.04).

    The Connection Manager gets the correct username etc - just select Britain (UK) as country, and Orange as network, and then "Contract"

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •