Results 1 to 3 of 3

Thread: Where do you enable user sharing

  1. #1
    Join Date
    Aug 2009
    Location
    United States
    Beans
    4,459
    Distro
    Ubuntu Development Release

    Where do you enable user sharing

    Terminal: gksudo nautilus

    (nautilus:5591): Eel-CRITICAL **: eel_preferences_get_boolean: assertion `preferences_is_initialized ()' failed
    Initializing nautilus-gdu extension

    ** (nautilus:5591): WARNING **: No marshaller for signature of signal 'UploadFinished'

    ** (nautilus:5591): WARNING **: No marshaller for signature of signal 'DownloadFinished'

    ** (nautilus:5591): WARNING **: No marshaller for signature of signal 'ShareCreateError'
    Nautilus-Share-Message: Called "net usershare info" but it failed: 'net usershare' returned error 255: net usershare: cannot open usershare directory /var/lib/samba/usershares. Error No such file or directory
    Please ask your system administrator to enable user sharing.

    Nautilus-Share-Message: Called "net usershare info" but it failed: 'net usershare' returned error 255: net usershare: cannot open usershare directory /var/lib/samba/usershares. Error No such file or directory
    Please ask your system administrator to enable user sharing.

  2. #2
    Join Date
    Aug 2009
    Location
    United States
    Beans
    4,459
    Distro
    Ubuntu Development Release

    Re: Where do you enable user sharing

    Went alt/F2 entered gksudo nautilus opened nautilus as root.

    traveled to folder I wanted to share-right clicked choose share.

  3. #3
    Join Date
    Sep 2009
    Beans
    4

    Re: Where do you enable user sharing

    I know this is a late response, but I found this through google and it gave poor advice - it wasn't solved!

    The error message is because the folder /var/lib/samba/usershares does not exist if samba is not installed. It doesn't matter.

    As the folder doesn't exist, you can't solve it by travelling to the folder!

    Either:
    1. (Recommended) Ignore the error message - Nautilus still runs in super user mode (tested on 10.4.1 X64).
    2. Install Samba - this creates the directory (empty) and the error message does not appear. Don't bother unless you actually want Samba for Windows sharing.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •