I'm running the legacy proprietary drivers in jaunty. I think it will be more tricky in karmic since the drivers only support kernels up to 2.6.28. Yeah, one could downgrade xserver to version 1.5.2 (intrepid), but I would be hesitant to the prospect of downgrading the kernel to 2.6.28 from 2.6.31, quite a big drop.