Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: unable to correct problems you have held broken packages

  1. #1
    Join Date
    Nov 2009
    Location
    Tuscaloosa, AL
    Beans
    10
    Distro
    Ubuntu 9.10 Karmic Koala

    unable to correct problems you have held broken packages

    I am new to Ubuntu, roughly two months, and recently upgraded from 9.04 to 9.10.
    For some reason my flash player, or lack there of, is not working properly on different websites.
    Youtube, for example, is fine. However, when I go to Aion to look at 3D character models it doesn't detect my flash player.
    When I was prompted to download a new one (java) I received an error message stating "unable to correct problems you have held broken packages,"
    I honestly don't know where to go from here please help me.

  2. #2
    Join Date
    Aug 2006
    Beans
    Hidden!
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: unable to correct problems you have held broken packages

    Hi, and welcome to the forums,

    the fact that youtube works is a good start. If you want others to test something that doesn't work for you online, provide a link. I don't know what's the problem with Aion, whatever that is, but java isn't the same as flash player. You can install it from the Software Center.
    ...and here is how to fix broken packages:
    https://help.ubuntu.com/community/Sy...ken%20packages

  3. #3
    Join Date
    Nov 2009
    Location
    Tuscaloosa, AL
    Beans
    10
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: unable to correct problems you have held broken packages

    Thank you for responding and I am very happy to be here.

    This is a link to what I was talking about.

    http://na.aiononline.com/livestatus/...&charID=137411

    Furthermore, I included some screen shots of my experience and your link was, unfortunately, unhelpful.
    Attached Images Attached Images

  4. #4
    Join Date
    Apr 2009
    Beans
    Hidden!
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: unable to correct problems you have held broken packages

    Enter the following command in a terminal and post any error message you get.
    Code:
    sudo dpkg --configure -a

  5. #5
    Join Date
    Nov 2009
    Location
    Tuscaloosa, AL
    Beans
    10
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: unable to correct problems you have held broken packages

    The command prompted for my password then nothing happened.
    sudo dpkg --configure -a

  6. #6
    Join Date
    Apr 2009
    Beans
    Hidden!
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: unable to correct problems you have held broken packages

    Ok, then try this:
    Code:
    sudo apt-get install sun-java6-plugin

  7. #7
    Join Date
    Nov 2009
    Location
    Tuscaloosa, AL
    Beans
    10
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: unable to correct problems you have held broken packages

    I would like to thank you for your efforts to help me before I begin.

    I was met with this (see attachment)
    Attached Images Attached Images
    Last edited by Raymond Lanphere; November 10th, 2009 at 10:49 PM. Reason: typo

  8. #8
    Join Date
    Apr 2009
    Beans
    Hidden!
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: unable to correct problems you have held broken packages

    Post the output of
    Code:
    cat /etc/apt/sources.list
    (or open the file /etc/apt/sources.list and paste the contents here.)

  9. #9
    Join Date
    Nov 2009
    Location
    Tuscaloosa, AL
    Beans
    10
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: unable to correct problems you have held broken packages

    This is what appeared.
    Attached Images Attached Images

  10. #10
    Join Date
    Aug 2008
    Location
    South East Montana
    Beans
    6,153

    Re: unable to correct problems you have held broken packages

    Not butting in here but where you can, cut and paste. It is easier to read and take snips from, if needed, to clarify points for you.
    Dell 480 XPS 3G ram Quad Core 2.40GHz, Radeon HD 2400 PRO, Audigy1, 3x320G HDD, 320G External, Debian Testing for use, Debian Squeeze for secure use, Debian Sid for FUN

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •