Results 1 to 10 of 10

Thread: Sony Vaio VGN-CR220E Webcam Issue

Hybrid View

  1. #1
    Join Date
    Nov 2009
    Beans
    1

    Unhappy Sony Vaio VGN-CR220E Webcam Issue

    I have googled all over, and checked every forum I could find, including this one. Yes there are tons of posts about this, but every link to all the drivers are broken. So I guess I'll create a new thread and get some fresh responses.

    I have a Sony Vaio VGN-CR220E with a built in webcam, when I partitioned my drive and installed Ubuntu 9.04 (now 9.10) the webcam has not worked.

    I "lsusb'd" and got:

    Code:
    Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 001 Device 002: ID 05ca:1839 Ricoh Co., Ltd Visual Communication Camera VGP-VCC6 [R5U870]
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 005 Device 002: ID 046d:c024 Logitech, Inc. MX300 Optical Mouse
    Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

  2. #2
    Join Date
    Nov 2009
    Beans
    36

    Unhappy Re: Sony Vaio VGN-CR220E Webcam Issue

    Just to say I have the same problem. Think there's currently no driver that's working under Ubuntu 9.10 Karmic from what I see.

    My lsusb line reads:
    Bus 001 Device 002: ID 05ca:1837 Ricoh Co., Ltd Visual Communication Camera VGP-VCC4 [R5U870]

    Running on a Sony Vaio VGN-FZ11Z

    Sincerely hope someone fixes this before too long, as I'm loathe to buy an external webcam when one's built in!

  3. #3
    Join Date
    Dec 2009
    Beans
    1

    Smile Re: Sony Vaio VGN-CR220E Webcam Issue

    I got my Vaio cam working on Ubuntu 9.10, by building the kernel module from source. Not as hard as it sounds.
    Code:
    lsusb output:
    Bus 001 Device 003: ID 05ca:1836 Ricoh Co., Ltd Visual Communication Camera VGP-VCC4 [R5U870]
    1. Install the packages required to build the module (I may have missed some):
      • sudo apt-get install build-essential linux-headers-`uname -r`

    2. Download and unzip the latest, although now unsupported, version of the r5u870 module.

    3. Build and install the module.
      • make
      • sudo make install
      • sudo modprobe 5u870


    Afterwards my webcam appeared as /dev/video0 and works as a v4l device. I've tested it with skype, VLC and motion.

  4. #4
    Join Date
    Mar 2010
    Location
    Indiana - USA
    Beans
    17
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Sony Vaio VGN-CR220E Webcam Issue

    Below is a link with the pertinent quote below that. Worked like a charm.

    http://ubuntuforums.org/showthread.php?p=8930938

    Quote Originally Posted by JanHJT View Post
    To try this driver open a terminal and type

    $ sudo apt-get install libglib2.0-dev libusb-dev build-essential gcc automake mercurial
    $ hg clone https://bitbucket.org/ahixon/r5u87x/ *[I changed the link to reflect SSL]
    $ cd r5u87x
    $ make
    $ sudo make install
    $ sudo r5u87x-loader --reload

    The loader will automatically be run on boot when it detects your webcam.

    My Logfile:
    Code:
    Jul 30 17:44:32 jan-vaio-vgn-tz31-vn kernel: [    33.628213] uvcvideo: Found UVC 1.00 device <unnamed> (05ca:183a)
    Jul 30 17:44:32 jan-vaio-vgn-tz31-vn kernel: [   33.640293] uvcvideo:  UVC non compliance - GET_DEF(PROBE) not supported. Enabling workaround.
    Jul 30 17:44:32 jan-vaio-vgn-tz31-vn kernel: [   33.640543] uvcvideo: Failed to query (129) UVC probe control : -32 (exp. 26).
    Jul 30 17:44:32 jan-vaio-vgn-tz31-vn kernel: [   33.640603] uvcvideo: Failed to initialize the device (-5).
    Jul 30 17:44:32 jan-vaio-vgn-tz31-vn kernel: [   33.640768] usbcore: registered new interface driver uvcvideo
    Jul 30 17:44:32 jan-vaio-vgn-tz31-vn kernel: [   33.641451] USB Video Class driver (v0.1.0)
    related bugfile: https://bugs.launchpad.net/ubuntu/+s...ux/+bug/460290
    * Sorry for editing the quote, it was necessary - Charles07

    [ETA: Oh, and install both "webcam" and "cheese" {I did it under terminal with "sudo apt-get install XXX", XXX being the aforementioned packages}. Cheese will then be found under "sound and video".]
    Last edited by Charles07; January 7th, 2011 at 11:46 PM. Reason: Additional Information

  5. #5
    Join Date
    Mar 2010
    Location
    Indiana - USA
    Beans
    17
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Sony Vaio VGN-CR220E Webcam Issue

    Oh, and for anyone searching for this under a fresh install of Linux Mint 10/LinuxMint 10:

    The line "hg clone https://bitbucket.org/ahixon/r5u87x/" may be omitted.

    The driver came installed. Just follow the rest of the steps above to make the loader.

  6. #6
    Join Date
    Nov 2010
    Beans
    16

    Re: Sony Vaio VGN-CR220E Webcam Issue

    $ sudo apt-get install libglib2.0-dev libusb-dev build-essential gcc automake mercurial
    $ hg clone https://bitbucket.org/ahixon/r5u87x/ *[I changed the link to reflect SSL]
    $ cd r5u87x
    $ make
    $ sudo make install
    $ sudo r5u87x-loader --reload



    HEY! Thanks - This worked perfectly on a Japanese Version Sony VGN-FE53B - Cheese first showed a black and white pic type only but camorama showed up fine.

  7. #7
    Join Date
    Oct 2011
    Beans
    6

    Re: Sony Vaio VGN-CR220E Webcam Issue

    Quote Originally Posted by Fictitious1 View Post
    $ sudo apt-get install libglib2.0-dev libusb-dev build-essential gcc automake mercurial
    $ hg clone https://bitbucket.org/ahixon/r5u87x/ *[I changed the link to reflect SSL]
    $ cd r5u87x
    $ make
    $ sudo make install
    $ sudo r5u87x-loader --reload



    HEY! Thanks - This worked perfectly on a Japanese Version Sony VGN-FE53B - Cheese first showed a black and white pic type only but camorama showed up fine.
    Followed the instructions above and now my web-cam is working fine. Thanks everyone.

  8. #8
    Join Date
    Aug 2010
    Location
    Kolkata
    Beans
    2
    Distro
    Ubuntu 10.04 Lucid Lynx

    Smile Re: Sony Vaio VGN-CR220E Webcam Issue

    Quote Originally Posted by Fictitious1 View Post
    $ sudo apt-get install libglib2.0-dev libusb-dev build-essential gcc automake mercurial
    $ hg clone https://bitbucket.org/ahixon/r5u87x/ *[I changed the link to reflect SSL]
    $ cd r5u87x
    $ make
    $ sudo make install
    $ sudo r5u87x-loader --reload



    HEY! Thanks - This worked perfectly on a Japanese Version Sony VGN-FE53B - Cheese first showed a black and white pic type only but camorama showed up fine.

    Worked for my VGN CR353
    thanks a ton

  9. #9
    Join Date
    Dec 2006
    Beans
    Hidden!

    Re: Sony Vaio VGN-CR220E Webcam Issue

    Quote Originally Posted by Fictitious1 View Post
    $ sudo apt-get install libglib2.0-dev libusb-dev build-essential gcc automake mercurial
    $ hg clone https://bitbucket.org/ahixon/r5u87x/ *[I changed the link to reflect SSL]
    $ cd r5u87x
    $ make
    $ sudo make install
    $ sudo r5u87x-loader --reload



    HEY! Thanks - This worked perfectly on a Japanese Version Sony VGN-FE53B - Cheese first showed a black and white pic type only but camorama showed up fine.

    Worked for my vgn-tz290. Many thanks!

  10. #10

    Re: Sony Vaio VGN-CR220E Webcam Issue

    i have a sony vaio vgn-fz19vn
    lsusb gives
    Bus 001 Device 002: ID 05ca:1837 Ricoh Co., Ltd Visual Communication Camera VGP-VCC4 [R5U870]
    so its the same camera
    so i installed this driver as above, but i gen in upside down image in camorama, and a black image in skype and cheese...
    any clues? I can provide further diagnostic output... Best, D

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •