Page 9 of 114 FirstFirst ... 78910111959109 ... LastLast
Results 81 to 90 of 1132

Thread: Wacom Bamboo Pen and Touch Series Development

  1. #81
    Join Date
    Nov 2009
    Beans
    73

    Re: Wacom Bamboo Pen and Touch Series Development

    Quote Originally Posted by dnprossi View Post
    you have "patch -p1 < fdi.patch" twice in instructions 1st line and last of patches.
    D'oh, I could have seen that myself...

    I installed the new patch, unplugged/replugged/rmmod'ed/modprobe'd, and all works like before. Is there an easy way to check if I am using the latest patch and not by accident the old one? Output in some logfiles or so?

    Otherwise, double-clicking does work too, but the eraser functions as pressure-sensitive stylus in Gimp, MyPaint and xournal. Does anyone know if these applications are supposed to recognise the eraser as an eraser? I could check that in Vista, but probably not before saturday.

  2. #82
    Join Date
    Aug 2007
    Beans
    113

    Re: Wacom Bamboo Pen and Touch Series Development

    Eraser should work automatically in mypaint. in gimp you will have to turn your pen and select eraser from tool box so that it is assigned to stylus eraser.

    I can't get anything to work. I'll have to try again.

  3. #83
    Join Date
    Oct 2009
    Beans
    121

    Re: Wacom Bamboo Pen and Touch Series Development

    Quote Originally Posted by dnprossi View Post
    Eraser should work automatically in mypaint. in gimp you will have to turn your pen and select eraser from tool box so that it is assigned to stylus eraser.

    I can't get anything to work. I'll have to try again.
    I'm getting the same nothing. Have recompiled a couple of times to no avail.

  4. #84
    Join Date
    Apr 2007
    Location
    Mount Horeb, WI
    Beans
    4,312
    Distro
    Kubuntu Development Release

    Re: Wacom Bamboo Pen and Touch Series Development

    Quote Originally Posted by rebecca2525 View Post
    D'oh, I could have seen that myself...

    I installed the new patch, unplugged/replugged/rmmod'ed/modprobe'd, and all works like before. Is there an easy way to check if I am using the latest patch and not by accident the old one? Output in some logfiles or so?

    Otherwise, double-clicking does work too, but the eraser functions as pressure-sensitive stylus in Gimp, MyPaint and xournal. Does anyone know if these applications are supposed to recognise the eraser as an eraser? I could check that in Vista, but probably not before saturday.
    You can check in /var/log/messages and once you start using the pen, there should be messages in there with [wacom-10] data:

    If it shows [wacom-9], you are using the older version.

  5. #85
    Join Date
    Apr 2007
    Location
    Mount Horeb, WI
    Beans
    4,312
    Distro
    Kubuntu Development Release

    Re: Wacom Bamboo Pen and Touch Series Development

    Quote Originally Posted by marek_online View Post
    I'm getting the same nothing. Have recompiled a couple of times to no avail.
    Can you and dnprossi both edit src/2.6.28/wacom_wac.c? Go to line 924 where the code looks like:
    Code:
    void wacom_init_input_dev(struct input_dev *input_dev, struct wacom_wac *wacom_wac)
    {
            switch (wacom_wac->features->type) {
                    case WACOM_MO:
                            input_dev_mo(input_dev, wacom_wac);
                    case WACOM_G4:
                            input_dev_g4(input_dev, wacom_wac);
                            /* fall through */
                    case BAMBOO_PT:
                    case GRAPHIRE:
                            input_dev_g(input_dev, wacom_wac);
                            break;
    and change it to look like:
    Code:
    void wacom_init_input_dev(struct input_dev *input_dev, struct wacom_wac *wacom_wac)
    {
            switch (wacom_wac->features->type) {
                    case BAMBOO_PT:
                    case WACOM_MO:
                            input_dev_mo(input_dev, wacom_wac);
                    case WACOM_G4:
                            input_dev_g4(input_dev, wacom_wac);
                            /* fall through */
                    case GRAPHIRE:
                            input_dev_g(input_dev, wacom_wac);
                            break;
    Pierre Chambert's change has the devices starting at input_dev_g instead of input_dev_mo. There is also some other code changes in 0.8.5-3 that removed some lines here.

    So once those changes are made, you can recompile the code. If that works, I will make the updates for everyone to test again. If it does not work, please post the /var/log/messages log so that we can see if the wacom kernel module is loaded properly.

    EDIT: If you are not comfortable with making the change yourself, let me know. I can make the update also. I am trying to reduce the number of changes if this does not make the device work.
    Last edited by Ayuthia; November 12th, 2009 at 11:14 PM.

  6. #86
    Join Date
    Apr 2007
    Location
    Mount Horeb, WI
    Beans
    4,312
    Distro
    Kubuntu Development Release

    Re: Wacom Bamboo Pen and Touch Series Development

    Quote Originally Posted by rebecca2525 View Post
    D'oh, I could have seen that myself...
    Sorry. I should have been paying closer attention.

    I have updated the post and have removed the wacom.h.patch also. It was an empty patch so it does not really do anything.

  7. #87
    Join Date
    Nov 2009
    Beans
    73

    Re: Wacom Bamboo Pen and Touch Series Development

    Booted into Vista and tried MyPaint 0.7.1 again. There, the eraser works as a stylus as well. I wanted to install Gimp, too, but I couln't reach sourceforge. I'm starting to believe it's IE's fault, but that will have to wait until saturday. I would like to know if I can get the eraser working in Vista to make sure it's not a hardware problem.

    Now that I booted Linux again, I'm having the same nothingness as others, so I guess I was still using the old version before. Trying the patch for the patch right now...

  8. #88
    Join Date
    Aug 2007
    Beans
    113

    Re: Wacom Bamboo Pen and Touch Series Development

    Ayuthia,

    Before changing source i discovered that pen works sporadically when plug/unplug.

    see my messages.log towards end i plugged unplugged.

    tried also after changing code, same happens.

    reading the log pen seems to have worked for a while.
    Attached Files Attached Files
    Last edited by dnprossi; November 12th, 2009 at 11:30 PM.

  9. #89
    Join Date
    Nov 2009
    Beans
    73

    Re: Wacom Bamboo Pen and Touch Series Development

    I changed the source (and this time, I rebooted after the install), and I have the same problem as dnprossi. When I plug the tablet in and use the pen, I get a few lines in /var/log/messages, then nothing more until the next plug out/in.

    Code:
    Nov 12 23:33:15 zam559 kernel: [  359.748070] usb 6-1: new full speed USB device using uhci_hcd and address 4
    Nov 12 23:33:15 zam559 kernel: [  359.911999] usb 6-1: New USB device found, idVendor=056a, idProduct=00d3
    Nov 12 23:33:15 zam559 kernel: [  359.912025] usb 6-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
    Nov 12 23:33:15 zam559 kernel: [  359.912031] usb 6-1: Product: CTH-661
    Nov 12 23:33:15 zam559 kernel: [  359.912035] usb 6-1: Manufacturer: Wacom Co.,Ltd.
    Nov 12 23:33:15 zam559 kernel: [  359.912210] usb 6-1: configuration #1 chosen from 1 choice
    Nov 12 23:33:15 zam559 kernel: [  359.915270] input: Wacom Bamboo P&T 6x8 as /devices/pci0000:00/0000:00:1d.0/usb6/6-1/6-1:1.0/input/input19
    Nov 12 23:33:15 zam559 kernel: [  359.927384] input: Wacom Bamboo P&T 6x8 as /devices/pci0000:00/0000:00:1d.0/usb6/6-1/6-1:1.1/input/input20
    Nov 12 23:33:15 zam559 kernel: [  359.969911] [wacom-10] data:  0:2 1:80 2:0 3:0 4:0 5:0 6:0 7:0
    Nov 12 23:33:15 zam559 kernel: [  359.973917] [wacom-10] data:  0:2 1:80 2:0 3:0 4:0 5:0 6:0 7:0
    Nov 12 23:33:15 zam559 kernel: [  360.021896] [wacom-10] data:  0:2 1:80 2:0 3:0 4:0 5:0 6:0 7:0
    Nov 12 23:33:15 zam559 kernel: [  360.025892] [wacom-10] data:  0:2 1:f0 2:64 3:21 4:3c 5:21 6:0 7:0
    Nov 12 23:33:15 zam559 kernel: [  360.033896] [wacom-10] data:  0:2 1:f1 2:5e 3:21 4:3c 5:21 6:b7 7:1
    Nov 12 23:33:15 zam559 kernel: [  360.061876] [wacom-10] data:  0:2 1:f1 2:60 3:21 4:36 5:21 6:c1 7:1
    Nov 12 23:33:15 zam559 kernel: [  360.093858] [wacom-10] data:  0:2 1:f1 2:62 3:21 4:35 5:21 6:95 7:1
    Nov 12 23:33:15 zam559 kernel: [  360.097864] [wacom-10] data:  0:2 1:f1 2:6d 3:21 4:36 5:21 6:91 7:1
    I don't see any reaction of the pointer, though, maybe it stops working too soon for me to see anything.
    Last edited by rebecca2525; November 12th, 2009 at 11:39 PM.

  10. #90
    Join Date
    Apr 2007
    Location
    Mount Horeb, WI
    Beans
    4,312
    Distro
    Kubuntu Development Release

    Re: Wacom Bamboo Pen and Touch Series Development

    I just had some time to review Pierre Chambert's code and found out that there is no coding for the eraser. I am going to add it.

    However, the first issue appears to be with the connection of the device. Does /var/log/messages always report a "must rebind"?

Page 9 of 114 FirstFirst ... 78910111959109 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •