Page 87 of 114 FirstFirst ... 3777858687888997 ... LastLast
Results 861 to 870 of 1132

Thread: Wacom Bamboo Pen and Touch Series Development

  1. #861
    Join Date
    Nov 2008
    Beans
    9,635
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Wacom Bamboo Pen and Touch Series Development

    Hi nossifer,

    We need to look at the output of:
    Code:
    xinput --list
    and
    Code:
    xsetwacom list
    Please sepecify which .fdi you're using. Also did you remember to copy the newly compiled wacom.ko into place?

    We should also look at your lshal. In a terminal:
    Code:
    lshal>nossifer_lshal.txt
    Compress it by right clicking on it and Create Archive. Then upload it to your post with Manage Attachments.

  2. #862
    Join Date
    Oct 2006
    Beans
    51

    Re: Wacom Bamboo Pen and Touch Series Development

    Hi Favux.

    I did the instructions on Post 1 and it had instructions to copy that .ko file. The .fdi is the same one as used in the 5-10. The rest of the stuff you asked for is attached (including an error message)

    EDIT: I am going to try back on my normally used laptop (XPS). I can post back the results, and if you like include a similar attachment if it helps you diagnose stuff.
    Attached Files Attached Files
    Last edited by nossifer; February 13th, 2010 at 02:53 AM. Reason: small update

  3. #863
    Join Date
    Nov 2008
    Beans
    9,635
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Wacom Bamboo Pen and Touch Series Development

    Hi nossifer,

    I'm out the door (way late) but it's looking like in your lshal the new .fdi (that's what you're using right?) is making a hash of things.

    I'll look at it later. In the mean time you could try the new-working .fdi on post #384.

  4. #864
    Join Date
    Oct 2006
    Beans
    51

    Re: Wacom Bamboo Pen and Touch Series Development

    Quote Originally Posted by Favux View Post
    Hi nossifer,

    I'm out the door (way late) but it's looking like in your lshal the new .fdi (that's what you're using right?) is making a hash of things.

    I'll look at it later. In the mean time you could try the new-working .fdi on post #384.
    Hi,

    Tried the new-working, and it seems to behave similarly: no touch. The stylus is working, and that will keep carpal away. Touch is a bonus and the gestures is really the super-bonus. Have a great weekend.

  5. #865
    Join Date
    Nov 2008
    Beans
    9,635
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Wacom Bamboo Pen and Touch Series Development

    Hi nossifer,

    With the new-working do you see eraser in xsetwacom? With it xsetwacom should look something like:
    Code:
    stylus		stylus
    eraser		eraser
    touch		touch
    pad		pad
    Basically what's happening with the default wacom.fdi in 0.8.5-10 is it is not distinguishing between the two usb channels labeled with udi's (unique device identifiers) that differ by containing 'if0' or 'if1'. In other words there should be two separate usb pci by-paths. But the .fdi is treating them as one so the info.callout to hal-setup-wacom is duplicating everything. The lshal shows two each of stylus, eraser, cursor, pad, and touch. A mess.

    And bizarrely your webcam is showing up as:
    Code:
    CNF7129     stylus
    Which is something we are also just seeing with N-trig using linuxwacom 0.8.5-9. Maybe something is messed up in the linuxwacom code also?

    So I need you to post a repeat of all the diagnostics like before, this time using the new-working .fdi. It would also help if you could include the 'Xorg.0.log' which is in '/var/log'. That'll also need to be compressed. That may tell us if another driver is grabbing touch and that's why you are not seeing it.

  6. #866
    Join Date
    Jan 2010
    Location
    Not Texas
    Beans
    333
    Distro
    Kubuntu 13.10 Saucy Salamander

    Post Re: Wacom Bamboo Pen and Touch Series Development

    Quote Originally Posted by Ayuthia View Post
    Hopefully this does not create any confusion for anyone, but there is now a new 0.8.5-10 release and it contains ob1kenobi's patches. I have updated the first post to reflect the information. If I missed anything, please let me know.
    this is so confusing. Lol, not really. Anyways, since there's another new release, I'll try it as sson as possibe and post my results. What kernel directory should I take the new wacom.ko driver out of this time.

  7. #867
    Join Date
    Nov 2008
    Beans
    9,635
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Wacom Bamboo Pen and Touch Series Development

    Hi texaswriter,

    It still should be 2.6.27.

  8. #868
    Join Date
    Mar 2009
    Beans
    10

    Re: Wacom Bamboo Pen and Touch Series Development

    Hi
    I've just started with Bamboo Fun Pen&Touch A5. Yetserday I've done all what was in the very first post of this thread. All went fine. Today I see there's new version (0.8.5-10) and I did the same as yesterday but with this new version.

    Now, this is my problem:
    Some helpful xsetwacom commands
    To set your touch so that it works like a mouse touchpad:


    Code:
    xsetwacom set touch Mode Relative
    To set the resolution of your touch (Example is for the medium sized tablet -- the small is X=480 Y=320):

    Code:
    xsetwacom set touch bottomx 740
    xsetwacom set touch bottomy 500
    To turn the touch on/off:

    Code:
    xsetwacom set touch Touch off
    xsetwacom set touch Touch on
    When I try any of these commands I get:
    Code:
    michal@michal-desktop:~$ xsetwacom set touch Touch off
    Error (2): WacomConfigOpenDevice: No such device
    Set: Failed to open device 'touch'
    Is something changed in this version, or I'm doing something wrong.


    Thanks for great effort to make this stuff work!

  9. #869
    Join Date
    Nov 2008
    Beans
    9,635
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Wacom Bamboo Pen and Touch Series Development

    Hi mmiicc,

    Welcome to the thread!

    That's what nossifer and myself are trying to figure out. I assume your pen is working along with eraser? See the last few posts by us.

    Either we need to change the .fdi somehow or 0.8.5-10 has broken touch and maybe the pad (tablet buttons).

  10. #870
    Join Date
    Mar 2009
    Beans
    10

    Re: Wacom Bamboo Pen and Touch Series Development

    Actually, now I can't configure GIMP to work well. Pen works just like mouse. Yesterday I've got working both pen and eraser.

    Update:
    Alexia Death helped me with "touch" thing. I had to use:
    Code:
    xsetwacom set "Wacom BambooFun 2FG 6x83 touch" Touch off
    instead of
    Code:
    xsetwacom set touch Touch off
    Another update:

    I've managed to configure GIMP. Pen and eraser works.

    After another unplug and plug "Wacom BambooFun 2FG 6x83 touch" changed to "Wacom BambooFun 2FG 6x85 touch".
    Last edited by mmiicc; February 13th, 2010 at 01:01 PM.

Page 87 of 114 FirstFirst ... 3777858687888997 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •