Results 1 to 9 of 9

Thread: 9.10 desktop black

  1. #1
    Join Date
    May 2009
    Location
    Austin, TX
    Beans
    417
    Distro
    Ubuntu 10.04 Lucid Lynx

    9.10 desktop black

    I did an upgrade from 9.04 to 9.10 and had all kinds of problems, so I did a fresh install last night, bootup and grub looked all good, but my desktop is black (plus I have no sound, but I think I can fix that using the same things from after the upgrade).

    I ran accross this thread which is closed, but never solved, and looks just like what I am expierencing. http://ubuntuforums.org/showthread.php?t=1302069

    I have an old pc with Radeon 9250 card, Gygabite MB, 1g ram, and all worked just fine (compiz, wobbly, etc...) in 9.04. Maybe the new 9.10 drivers don't like old ATI cards?

    Has anybody came up with a solution?

  2. #2
    Join Date
    Aug 2007
    Beans
    190

    Re: 9.10 desktop black

    Have you tried running xfix from recovery mode?

  3. #3
    Join Date
    May 2009
    Location
    Austin, TX
    Beans
    417
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: 9.10 desktop black

    Have not tried xfix, but I guess it couldn't hurt.

    just as much as I've been reading with other people wit the same problem, if that fixed it, you would THINK someone would have said "Hey... xfix fixed my black screen problem!"

    So I do have doubts it will work, but I will try it tonight.

    Thanks...

  4. #4
    Join Date
    Aug 2007
    Beans
    190

    Re: 9.10 desktop black

    Yeah, you're probably right, but one can always hope

  5. #5
    Join Date
    Jan 2007
    Location
    London, UK
    Beans
    3,521
    Distro
    Ubuntu Development Release

    Re: 9.10 desktop black

    Can you try ubuntu 9.10 live cd on your machine and see if it gives you same problem within livecd environment?
    You came empty handed, that is how you shall leave. Whatever you claim as yours today, belonged to someone else yesterday, will be someone else's tomorrow.

  6. #6
    Join Date
    May 2009
    Location
    Austin, TX
    Beans
    417
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: 9.10 desktop black

    Quote Originally Posted by ukripper View Post
    Can you try ubuntu 9.10 live cd on your machine and see if it gives you same problem within livecd environment?
    I forgot about that... I did run live CD the day before trying to fix the sound problem, (before I finally did a fresh install) and it did the same black screen.

    At the time I just figured it was a cd issue.

    I did run the ck cd for errors last night before I did the install, and it came back w/no errors.

  7. #7
    Join Date
    Jun 2006
    Location
    UK
    Beans
    Hidden!
    Distro
    Ubuntu 14.10 Utopic Unicorn

    Re: 9.10 desktop black

    Quote Originally Posted by Tholley View Post
    http://ubuntuforums.org/showthread.php?t=1302069

    <snip>

    Has anybody came up with a solution?
    Actually a sort-of solution is in the OP of that thread. Disable compiz and you'll get your desktop back. Sorry I can't offer any better fix.

    Please do not PM me about your forum account unless you have been asked to. The correct place to contact an admin about your account is here.

  8. #8
    Join Date
    May 2009
    Location
    Austin, TX
    Beans
    417
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: 9.10 desktop black

    Yeah... turn off desktop effects and desktop background returns, but that was just a work around, not a fix.

    thanks for trying tho!

  9. #9
    Join Date
    May 2009
    Location
    Austin, TX
    Beans
    417
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: 9.10 desktop black

    This is what worked for me.

    I'm having the same issue on an old Dell laptop with an ATI Radeon RV250 (Mobility FireGL 9000) running a 1400x1050 panel. When I moved this machine to Karmic, my desktop was black, with no desktop items appearing on it; but you could see the desktop wallpaper beneath the semi-transparent top panel.

    In my case, the fix was exactly the opposite of what tormod described. Here's how to do it, step by step.

    In terminal, run these two commands:

    Code:
    grep XAA /var/log/Xorg.0.log
    grep EXA /var/log/Xorg.0.log
    One of them will return nothing; the other will return something like this:

    Code:
    (**) RADEON(0): Option "AccelMethod" "XAA"
    (**) RADEON(0): Using XAA acceleration architecture
    (II) RADEON(0): Using XFree86 Acceleration Architecture (XAA)
    This tells you which method is currently in use on your system. Whichever one it is, try the other. For me it was EXA, and switching to XAA solved the problem. Here is what to do.

    If it reported XAA:

    In terminal, do this:

    Code:
    sudo gedit /etc/X11/xorg.conf
    This will give you a text editor window. Paste this into the text editor:

    Code:
    Section "Device"
    Identifier "my-radeon"
    Driver "ati"
    Option "AccelMethod" "EXA"
    EndSection
    Save, and reboot, and see if the problem is solved.


    If it reported EXA:

    In terminal, do this:

    Code:
    sudo gedit /etc/X11/xorg.conf
    This will give you a text editor window. Paste this into the text editor:

    Code:
    Section "Device"
    Identifier "my-radeon"
    Driver "ati"
    Option "AGPSize" "128"
    EndSection
    Then save the file and exit the editor, and reboot.

    If the problem still isn't solved when you have rebooted, open the file in text editor again, and change it to look like this:

    Code:
    Section "Device"
    Identifier "my-radeon"
    Driver "ati"
    Option "AccelMethod" "XAA"
    EndSection
    Then save the file and exit the editor, and reboot.

    Both of these solved the problem for me. The first one (with the AGPSize option) is the preferred choice and will result in better performance.

    Post back and let us know if it fixes it for you.

    Mine was also EXA and switched to XAA and my cherries are back!

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •