Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: disable screen lock after sleep

  1. #1
    Join Date
    May 2009
    Beans
    2

    disable screen lock after sleep

    I've searched for possible solutions, and this did not help:

    - uncheck all (use_screensaver_settings, suspend, blank screen, etc...) in gconf-editer /apps/gnome-power-manager/lock
    - check disable_lock_screen in /desktop/gnome/lockdown
    - LOCK_SCREEN=false in /etc/default/acpi-support

    It's still show password prompt after I wake my laptop from sleep.

    what else should I try?

    //ubuntu 9.10

  2. #2
    Join Date
    May 2009
    Beans
    2

    Re: disable screen lock after sleep

    up

  3. #3
    Join Date
    Apr 2008
    Beans
    231
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: disable screen lock after sleep

    I'm having the same problem. This is a particularly irritating bug because not even the hackish workarounds do anything to change the situation.

  4. #4
    Join Date
    May 2005
    Beans
    44

    Re: disable screen lock after sleep

    System - Preferences - Screensaver
    Needed to uncheck "Lock screen when screensaver is active"
    Last edited by eris23; January 21st, 2010 at 08:12 PM.

  5. #5
    Join Date
    Apr 2007
    Location
    Hotels around the world
    Beans
    289
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: disable screen lock after sleep

    Quote Originally Posted by eris23 View Post
    System - Preferences - Screensaver
    Needed to uncheck "Lock screen when screensaver is active"
    I've done all of the above, and it still asks for a password from suspend. I even rebooted to make sure the settings were kept, they were. It comes back from suspend to a screen saver, but then asks for a password, even though it doesn't if I just let the screensaver activate with the timer.

  6. #6
    Join Date
    Apr 2005
    Location
    Finland/UK
    Beans
    Hidden!
    Distro
    Ubuntu 15.04 Vivid Vervet

    Re: disable screen lock after sleep

    There's a bug in the indicator-applet-session (the panel applet with shutdown buttons etc) that causes it to lock the screen when suspending (or switching users etc), regardless of what the actual gconf settings for screen locking are.

    Currently there's no workaround other than using some other means to suspend the machine than through that applet.

  7. #7
    Join Date
    Apr 2007
    Location
    Hotels around the world
    Beans
    289
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: disable screen lock after sleep

    Quote Originally Posted by mcduck View Post
    There's a bug in the indicator-applet-session (the panel applet with shutdown buttons etc) that causes it to lock the screen when suspending (or switching users etc), regardless of what the actual gconf settings for screen locking are.

    Currently there's no workaround other than using some other means to suspend the machine than through that applet.
    Yeah, I found that out. The laptop works fine to resume passwordless from suspend if I do an Fn-F1 of close the lid. Working on getting suspend to work on the desktop now...

  8. #8
    Join Date
    Apr 2007
    Location
    Hotels around the world
    Beans
    289
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: disable screen lock after sleep

    Quote Originally Posted by mcduck View Post
    There's a bug in the indicator-applet-session (the panel applet with shutdown buttons etc) that causes it to lock the screen when suspending (or switching users etc), regardless of what the actual gconf settings for screen locking are.

    Currently there's no workaround other than using some other means to suspend the machine than through that applet.
    I have since found an easy way around it, at least if your running Karmic (don't know about earlier releases). Just hit CTRL-ALT-DEL, that brings up a menu much like the indicator-applet-session would. Suspending that way the system will not ask for a password when coming out of suspend, assuming you have it set that way.

  9. #9
    Join Date
    Jun 2006
    Beans
    4

    Re: disable screen lock after sleep

    Open up gconf-editor

    Go to /apps/gnome-power-manager/lock/

    Uncheck suspend and hibernate.

    Cheers.

  10. #10
    MountainX's Avatar
    MountainX is offline Iced Blended Vanilla Crème Ubuntu
    Join Date
    Jan 2008
    Location
    A place with no mountains
    Beans
    1,610
    Distro
    Kubuntu

    Re: disable screen lock after sleep

    Here's my solution. It works on the Gateway LT2115u (LT-Series) which is a rebranded Acer Aspire One 532h.

    Open the terminal, and type gconf-editor. Do NOT use sudo or you will not change the settings for your own user account!
    In the left pane of the window that comes up go to apps > gnome-power-manager > lock .
    On the right, UNCHECK suspend and hibernate and everything else except for use_screensaver_settings (this is the only one that is CHECKED)

    Now go to main menu: system > preferences > screen saver
    At the bottom of the window that comes up, uncheck "lock screen when screensaver is active"

    The following commands should do the same thing...
    Code:
    gconftool-2 --type boolean -s /apps/gnome-power-manager/lock/blank_screen false
    gconftool-2 --type boolean -s /apps/gnome-power-manager/lock/gnome_keyring_hibernate false
    gconftool-2 --type boolean -s /apps/gnome-power-manager/lock/gnome_keyring_suspend false
    gconftool-2 --type boolean -s /apps/gnome-power-manager/lock/hibernate false
    gconftool-2 --type boolean -s /apps/gnome-power-manager/lock/suspend false
    gconftool-2 --type boolean -s /apps/gnome-power-manager/lock_use_screensaver_settings true
    gconftool-2 --type boolean -s /apps/gnome-screensaver/lock_enabled false
    Desktop: KX Studio (Kubuntu 12.04)
    Laptop & Netbook: Kubuntu 12.04
    Tablet: Samsung Galaxy Tab 10.1
    Phone: Nexus 4 Cyanogenmod

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •