Page 2 of 2 FirstFirst 12
Results 11 to 18 of 18

Thread: disable screen lock after sleep

  1. #11
    Join Date
    Jan 2010
    Beans
    2

    Wink Re: disable screen lock after sleep

    Do not know if you guys already solved this but I have a fix. Obviously you're not doing it right. Open gconf editor, do the above steps at apps., where you uncheck all 3 locks (screensaver, suspend and hibernate), but you also have to step back to main tree of gconf editor, desktop, gnome, lockdown, and finally check the: disable_lock_screen. Then reboot and try to suspend, no prompt screen should appear and it should take you to your desktop.

  2. #12
    Join Date
    Mar 2008
    Location
    London
    Beans
    87
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: disable screen lock after sleep

    Settings are immediate - this is not windoze ....You wont need to reboot
    0,= ,-_-. =.
    ((_/)o o(\_))
    ` `-'(. .)`-'
    000\_/

  3. #13
    Join Date
    Jan 2007
    Location
    Cornwall, UK
    Beans
    89
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: disable screen lock after sleep

    Thanks guys, just came looking for that info, and that did the trick for me - had to do what tani1981 said too, before it was fixed.

    What a relief! My laptop has a borked keyboard and I am currently using synergy with it from a mac. Had to plug in a kb to log in before I could carry on with work....

  4. #14
    Join Date
    Mar 2007
    Beans
    68
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: disable screen lock after sleep

    Quote Originally Posted by tani1981 View Post
    Do not know if you guys already solved this but I have a fix. Obviously you're not doing it right. Open gconf editor, do the above steps at apps., where you uncheck all 3 locks (screensaver, suspend and hibernate), but you also have to step back to main tree of gconf editor, desktop, gnome, lockdown, and finally check the: disable_lock_screen. Then reboot and try to suspend, no prompt screen should appear and it should take you to your desktop.
    That really seems like overkill, though; in order to prevent the screen from locking when I don’t ask it to, I have to prevent the screen from locking at all.

    I wish they’d fix this stupid bug >_<

  5. #15
    Join Date
    Feb 2005
    Beans
    15

    Re: disable screen lock after sleep

    @MountainX thank you! That fixed it for me! And a big thanks to the 11.04 developers for fixing the suspend/screen blank problems in this new release

  6. #16
    Join Date
    May 2011
    Beans
    1

    Re: disable screen lock after sleep

    Made the SAME mistake the previous poster pointed out. DO NOT USE SUDO when launching GCONF-EDITOR. Then uncheck the appropriate boxes.
    Thanks!
    They really need to fix this bug so I can just shut it off in the Screensaver settungs. Have have this happen in several itterations of Ubuntu.
    Running 11.04 Natty Narwhal

  7. #17
    Join Date
    Dec 2005
    Location
    Kyšice, Czech Republic
    Beans
    272
    Distro
    Ubuntu 6.06

    Re: disable screen lock after sleep

    Quote Originally Posted by mcduck View Post
    There's a bug in the indicator-applet-session (the panel applet with shutdown buttons etc) that causes it to lock the screen when suspending (or switching users etc), regardless of what the actual gconf settings for screen locking are.

    Currently there's no workaround other than using some other means to suspend the machine than through that applet.
    For anyone interested, it is this bug: https://bugs.launchpad.net/ubuntu/+s...er/+bug/255228

  8. #18
    Join Date
    Sep 2010
    Beans
    4

    Smile Re: disable screen lock after sleep

    Quote Originally Posted by MountainX View Post
    Here's my solution. It works on the Gateway LT2115u (LT-Series) which is a rebranded Acer Aspire One 532h.

    Open the terminal, and type gconf-editor. Do NOT use sudo or you will not change the settings for your own user account!
    In the left pane of the window that comes up go to apps > gnome-power-manager > lock .
    On the right, UNCHECK suspend and hibernate and everything else except for use_screensaver_settings (this is the only one that is CHECKED)

    Now go to main menu: system > preferences > screen saver
    At the bottom of the window that comes up, uncheck "lock screen when screensaver is active"

    The following commands should do the same thing...
    Code:
    gconftool-2 --type boolean -s /apps/gnome-power-manager/lock/blank_screen false
    gconftool-2 --type boolean -s /apps/gnome-power-manager/lock/gnome_keyring_hibernate false
    gconftool-2 --type boolean -s /apps/gnome-power-manager/lock/gnome_keyring_suspend false
    gconftool-2 --type boolean -s /apps/gnome-power-manager/lock/hibernate false
    gconftool-2 --type boolean -s /apps/gnome-power-manager/lock/suspend false
    gconftool-2 --type boolean -s /apps/gnome-power-manager/lock_use_screensaver_settings true
    gconftool-2 --type boolean -s /apps/gnome-screensaver/lock_enabled false
    I wanted to thank you for the quick command list for committing the lock screen/blank screen as well as the hibernate/suspend information. It worked well on 32-Bit Desktop Edition on 11.04 Natty and 11.10 Oneiric.

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •