Page 7 of 7 FirstFirst ... 567
Results 61 to 70 of 70

Thread: Nvidia GT220 & Audio Device "0be2"

  1. #61
    Join Date
    Dec 2007
    Location
    Shakopee, MN USA
    Beans
    211
    Distro
    Xubuntu 12.04 Precise Pangolin

    Re: Nvidia GT220 & Audio Device "0be2"

    Quote Originally Posted by jay214128 View Post
    When I do that, I don't get an HDMI choice to select. Only the motherboard analog and digital devices (IEC958). How do I get the GT220 HDMI audio device to show up? This is with a new install of 10.04 LTS.
    I had to update ALSA first.

    ALSA Upgrade Script

    I posted more detail in my blog link below.

  2. #62
    Join Date
    Feb 2010
    Beans
    218

    Re: Nvidia GT220 & Audio Device "0be2"

    i observed a strange behaviour with (i guess) that new alsa. if im using the sound device for several hourse, say playing music, it then stops. trying to restart the sond file or a video file results in a freeze of the playersoftware.

    first i thought it has something to do with compize cause it went up to 100% cpu usuage. and when i killed compiz it wokred again. but same happens without compize.

    this is only observable if you play something for more than 2 hours.

    i will try again the older 1.0.22.1 alsa drivers.

  3. #63
    Join Date
    Mar 2009
    Location
    San Diego, CA, USA
    Beans
    13
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Nvidia GT220 & Audio Device "0be2"

    Quote Originally Posted by novellahub View Post
    I had to update ALSA first.

    ALSA Upgrade Script
    I followed the alsa upgrade instructions and now I get an HDMI audio device. The output of aplay -l:

    **** List of PLAYBACK Hardware Devices ****
    card 0: Intel [HDA Intel], device 0: ALC889 Analog [ALC889 Analog]
    Subdevices: 1/1
    Subdevice #0: subdevice #0
    card 0: Intel [HDA Intel], device 1: ALC889 Digital [ALC889 Digital]
    Subdevices: 1/1
    Subdevice #0: subdevice #0
    card 1: NVidia [HDA NVidia], device 3: NVIDIA HDMI [NVIDIA HDMI]
    Subdevices: 0/1
    Subdevice #0: subdevice #0
    card 1: NVidia [HDA NVidia], device 7: NVIDIA HDMI [NVIDIA HDMI]
    Subdevices: 1/1
    Subdevice #0: subdevice #0
    card 1: NVidia [HDA NVidia], device 8: NVIDIA HDMI [NVIDIA HDMI]
    Subdevices: 1/1
    Subdevice #0: subdevice #0
    card 1: NVidia [HDA NVidia], device 9: NVIDIA HDMI [NVIDIA HDMI]
    Subdevices: 1/1
    Subdevice #0: subdevice #0


    The output of cat /proc/asound/cards:

    0 [Intel ]: HDA-Intel - HDA Intel
    HDA Intel at 0xfbff8000 irq 32
    1 [NVidia ]: HDA-Intel - HDA NVidia
    HDA NVidia at 0xfaffc000 irq 16



    When I run speaker-test -Dplughw:1,3 -c2, I get no sound. The test appears to be running, though. I checked alsa-mixer, but there is no HDMI device listed there to unmute.

    What should I check next?

  4. #64
    Join Date
    Feb 2006
    Location
    Maryland, USA
    Beans
    166
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Nvidia GT220 & Audio Device "0be2"

    you don't need to update alsa to get it working with 10.04.


    https://bugs.launchpad.net/ubuntu/+s...er/+bug/550655

    Here is how I got my gt220 before my motherboard/cpu went up.



    Code:
        
     -- at command line
    
    sudo add-apt-repository ppa:ubuntu-audio-dev/ppa
    
     -- then 
    
    install linux-alsa-driver-modules-2.6.xx-xx( matches your kernel )
    
     -- at command line
    
    sudo vim /etc/modprobe.d/sound.conf
    
    -- add the following for NV GT220 -- "aplay -l" will tell you which of the following to use
    
    options snd-hda-intel enable_msi=0 probe_mask=0xfff2 # if your device is 0,3
    
    or 
    
    options snd-hda-intel enable_msi=0 probe_mask=0xffff,0xfff2 # if your device is 1,3
    
    or
    
    options snd-hda-intel enable_msi=0 probe_mask=0xffff,0xffff,0xfff2 # if your device is 2,3
    
    
    -- save and reboot
    
    -- then do the following -- I used 1,3 because I used 2 audio outout devices at the time, you might need to use 0,3 or 2,3 etc...
    
    aplay -D plughw:1,3 /usr/share/sounds/alsa/Noise.wav
    speaker-test -Dhdmi:NVidia_1 -c6
    Last edited by jaakan; July 1st, 2010 at 03:31 PM.

  5. #65
    Join Date
    Mar 2009
    Location
    San Diego, CA, USA
    Beans
    13
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Nvidia GT220 & Audio Device "0be2"

    I have not gotten past step 2. I'm a noob at this.

    I successfully added the "ppa:ubuntu-audio-dev/ppa" PPA.

    I am unable to do the next step (install linux-alsa-driver-modules-2.6.xx-xx( matches your kernel )). What command do I use here? I tried many incantations of 'apt-get install' and apt could not find the matching package.

    The instructions then say to edit the /etc/modprobe.d/sound.conf file. I don't have this file on my system. There is an /etc/modprobe.d/asound.conf file (I think that is what it was called), but no sound.conf. Am I supposed to create this file? Did you mean the asound.conf file instead?

    My GT220 will end up being card 1, since card 0 is the onboard audio device (analog & SPDIF), as indicated by 'aplay -l'.

    Jay

  6. #66
    Join Date
    Feb 2006
    Location
    Maryland, USA
    Beans
    166
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Nvidia GT220 & Audio Device "0be2"

    Quote Originally Posted by jay214128 View Post
    I have not gotten past step 2. I'm a noob at this.

    I successfully added the "ppa:ubuntu-audio-dev/ppa" PPA.

    I am unable to do the next step (install linux-alsa-driver-modules-2.6.xx-xx( matches your kernel )). What command do I use here? I tried many incantations of 'apt-get install' and apt could not find the matching package.

    The instructions then say to edit the /etc/modprobe.d/sound.conf file. I don't have this file on my system. There is an /etc/modprobe.d/asound.conf file (I think that is what it was called), but no sound.conf. Am I supposed to create this file? Did you mean the asound.conf file instead?

    My GT220 will end up being card 1, since card 0 is the onboard audio device (analog & SPDIF), as indicated by 'aplay -l'.

    Jay
    run "uname -a" to get the currently installed/active kernel
    for me it's "linux-image-2.6.32-23-generic"

    open up "synaptic" , System > Admin... > Synaptic Package Manager

    and do a search for "2.6.32"

    now look for

    linux-alsa-driver-modules-2.6.32-23

    if it is there install it.

    the current version of linux-alsa-driver-modules as of me typing is 13 hours old ( -22 and not -23 ) so you need to wait a day or two for the matching version to show up

    https://launchpad.net/~ubuntu-audio-.../ppa/+packages

    you could always

    install "linux-image-2.6.32-22-generic" + "linux-alsa-driver-modules-2.6.32-22"
    and remove linux-image-2.6.32-23-generic until -23 comes out

    hope that helps
    Jaakan

  7. #67
    Join Date
    Feb 2006
    Location
    Maryland, USA
    Beans
    166
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Nvidia GT220 & Audio Device "0be2"

    you will need to create the .conf file

    "sudo gedit /etc/modprobe.d/sound.conf"
    gedit will be easier for you to use than vim

    I use both but mostly vim at work.


    in your case you would add only the following to that file

    Code:
    options snd-hda-intel enable_msi=0 probe_mask=0xffff,0xfff2

  8. #68
    Join Date
    Mar 2009
    Location
    San Diego, CA, USA
    Beans
    13
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Nvidia GT220 & Audio Device "0be2"

    Thanks, jaakan. I have had some mixed results. After creating the sound.conf file, and rebooting, I could then get speaker-test to play sound via HDMI (yeah). I also needed to unmute the HDMI audio device (card 1) in alsamixer. I had to use F6 to select card 1 for it to even show up.

    I still had only analog sound from the system and my applications. I tried to run the System->Preferences->Default Sound Card to select the HDMI audio as my default sound card, but this application no longer runs. It tries to start (shows up for about 10 seconds in the task bar) but then exits. Is this expected?

    A few reboots (days) later, I discovered that HDMI sound was working for some of my applications (vlc, mplayer, movieplayer), but still only analog for the system sounds.

    Today I booted up and no sound at all. I checked alsamixer and the HDMI audio (card 1) was muted again. I unmuted it and rebooted. This restored the HDMI audio for my appliations (vlc, etc.), but still no system sounds (not even analog anymore). Is there a way to get the system sounds to also use HDMI?

  9. #69
    Join Date
    Jun 2009
    Location
    London, United Kingdom
    Beans
    13

    Re: Nvidia GT220 & Audio Device "0be2"

    Quote Originally Posted by jaakan View Post
    you don't need to update alsa to get it working with 10.04.


    https://bugs.launchpad.net/ubuntu/+s...er/+bug/550655

    Here is how I got my gt220 before my motherboard/cpu went up.



    Code:
        
     -- at command line
    
    sudo add-apt-repository ppa:ubuntu-audio-dev/ppa
    
     -- then 
    
    install linux-alsa-driver-modules-2.6.xx-xx( matches your kernel )
    
     -- at command line
    
    sudo vim /etc/modprobe.d/sound.conf
    
    -- add the following for NV GT220 -- "aplay -l" will tell you which of the following to use
    
    options snd-hda-intel enable_msi=0 probe_mask=0xfff2 # if your device is 0,3
    
    or 
    
    options snd-hda-intel enable_msi=0 probe_mask=0xffff,0xfff2 # if your device is 1,3
    
    or
    
    options snd-hda-intel enable_msi=0 probe_mask=0xffff,0xffff,0xfff2 # if your device is 2,3
    
    
    -- save and reboot
    
    -- then do the following -- I used 1,3 because I used 2 audio outout devices at the time, you might need to use 0,3 or 2,3 etc...
    
    aplay -D plughw:1,3 /usr/share/sounds/alsa/Noise.wav
    speaker-test -Dhdmi:NVidia_1 -c6
    Hi Mate,

    You make me SAY YEAH!!!! you are simply fantastic!!!

    Many thanks for your brief and meaningful post. it helps straight away. it works specularly.

    Best Regard,
    hth0923
    Last edited by hth0923; July 31st, 2010 at 01:04 AM.

  10. #70
    Join Date
    Aug 2010
    Beans
    1

    Re: Nvidia GT220 & Audio Device "0be2"

    Quote Originally Posted by jay214128 View Post
    Thanks, jaakan. I have had some mixed results. After creating the sound.conf file, and rebooting, I could then get speaker-test to play sound via HDMI (yeah). I also needed to unmute the HDMI audio device (card 1) in alsamixer. I had to use F6 to select card 1 for it to even show up.

    I still had only analog sound from the system and my applications. I tried to run the System->Preferences->Default Sound Card to select the HDMI audio as my default sound card, but this application no longer runs. It tries to start (shows up for about 10 seconds in the task bar) but then exits. Is this expected?

    A few reboots (days) later, I discovered that HDMI sound was working for some of my applications (vlc, mplayer, movieplayer), but still only analog for the system sounds.

    Today I booted up and no sound at all. I checked alsamixer and the HDMI audio (card 1) was muted again. I unmuted it and rebooted. This restored the HDMI audio for my appliations (vlc, etc.), but still no system sounds (not even analog anymore). Is there a way to get the system sounds to also use HDMI?

    I'm almost in the same boat with this, sound works on vlc , mplayer etc but no sound when i try to run boxee, xbmc or browse youtube ,google vidoes etc ... can anyone help me with this please?

    Thanks

Page 7 of 7 FirstFirst ... 567

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •