Page 6 of 7 FirstFirst ... 4567 LastLast
Results 51 to 60 of 70

Thread: Nvidia GT220 & Audio Device "0be2"

  1. #51
    Join Date
    Feb 2010
    Beans
    218

    Re: Nvidia GT220 & Audio Device "0be2"

    i managed to get sound over my hdmi of my gt220 too BUT neither flash videos within browser nor the xbmc menu sounds get over it.

    so i have sound from every source over the hdmi except flash videos movie sounds in ff and the xbmc menu sounds. especially the one with flash is very anoying.

    additionally i observed a strange thing: if i disable the onbord sound (i have onbord + the gt220) i dont get any sound at all. but the pulseaudio controls tell me i have sound. everything plays and tells me that i should here something but it is nothing to hear. only if i activated also the onbord sound in the bios.

    but if i have both activated the module for the onbord sound seems to crash everytime i try to use the onbord sound - not that i want it, but i tried it.

    anybody have sound ober the gt220 hdmi AND have sound in firefox from flash movies?

  2. #52
    Join Date
    Dec 2007
    Location
    Shakopee, MN USA
    Beans
    211
    Distro
    Xubuntu 12.04 Precise Pangolin

    Re: Nvidia GT220 & Audio Device "0be2"

    Quote Originally Posted by a-user View Post
    i managed to get sound over my hdmi of my gt220 too BUT neither flash videos within browser nor the xbmc menu sounds get over it.

    so i have sound from every source over the hdmi except flash videos movie sounds in ff and the xbmc menu sounds. especially the one with flash is very anoying.

    additionally i observed a strange thing: if i disable the onbord sound (i have onbord + the gt220) i dont get any sound at all. but the pulseaudio controls tell me i have sound. everything plays and tells me that i should here something but it is nothing to hear. only if i activated also the onbord sound in the bios.

    but if i have both activated the module for the onbord sound seems to crash everytime i try to use the onbord sound - not that i want it, but i tried it.

    anybody have sound ober the gt220 hdmi AND have sound in firefox from flash movies?
    I believe you need to do the following:

    Navigate to System > Preferences > Sound

    In the hardware tab choose HDMI out for the hardware profile.

  3. #53
    Join Date
    Feb 2010
    Beans
    218

    Re: Nvidia GT220 & Audio Device "0be2"

    ofcourse i already did that or otherwise i wouldn't had system sounds and sound rfom other application as i already said.

    edit: oh and when i disabled the onbord sound i repeated the settings but dont have anysound although the system tools tell me it is being played over hdmi.

  4. #54
    Join Date
    Apr 2006
    Beans
    Hidden!

    Re: Nvidia GT220 & Audio Device "0be2"

    CONFIRMED WORKING

    I have just successfully got HDMI audio working on my 0be4 video card.

    I used the newly released Alsa 1.0.23 version

    A caveat is that it did not work over Pulse Audio though even though it showed up as a choice I only ever got random "pops" out of the speakers, and was stereo only.

    My working steps

    Must have video out over HDMI at the same time (cloned output worked for me)
    I used this command to get it working

    mplayer video.mkv -ao alsa:device=plughw=1.3

    Second test
    speaker-test -c2 -D plughw:1,3
    Running Linux From Scratch for over 7 and a half years on my desktop
    Running Ubuntu on my laptop since I bought it

  5. #55
    Join Date
    Apr 2006
    Beans
    Hidden!

    Re: Nvidia GT220 & Audio Device "0be2"

    I did a little more testing and came across a bug. I recommend using 1,9 instead of 1,3 it turns out you have to use 1,9 first after every boot to initialize the others (1,3 + 1,7 + 1,8)

    It would be easier to just always use 1,9 then trying to do it first then switch to another.

    I have found no difference between the four devices other then that.
    Running Linux From Scratch for over 7 and a half years on my desktop
    Running Ubuntu on my laptop since I bought it

  6. #56
    Join Date
    Apr 2006
    Beans
    Hidden!

    Re: Nvidia GT220 & Audio Device "0be2"

    One more update:
    Pulse Audio does work if you use mplayer to start 1,9 first (after every boot)
    I am trying to find a way to force Pulse to just default to 1,9

    Also good news I got full 5.1 surround when using ac3/dts passthrough (which is 99% of the time you need it anyway)

    So the best command for movies with mplayer now is
    mplayer -ao alsa:device=plughw=1.9 -afm hwac3 video.mkv
    Running Linux From Scratch for over 7 and a half years on my desktop
    Running Ubuntu on my laptop since I bought it

  7. #57
    Join Date
    Dec 2007
    Location
    Shakopee, MN USA
    Beans
    211
    Distro
    Xubuntu 12.04 Precise Pangolin

    Re: Nvidia GT220 & Audio Device "0be2"

    Quote Originally Posted by darkshadow View Post
    One more update:
    Pulse Audio does work if you use mplayer to start 1,9 first (after every boot)
    I am trying to find a way to force Pulse to just default to 1,9

    Also good news I got full 5.1 surround when using ac3/dts passthrough (which is 99% of the time you need it anyway)

    So the best command for movies with mplayer now is
    mplayer -ao alsa:device=plughw=1.9 -afm hwac3 video.mkv
    To enable pulse audio on boot, try doing these instructions:

    XBMC Pulse Audio Link

  8. #58
    Join Date
    Feb 2008
    Beans
    4
    Distro
    Xubuntu 9.10 Karmic Koala

    Re: Nvidia GT220 & Audio Device "0be2"

    I got GeForce 210 working with Karmic Koala 9.10. Both video and audio works over HDMI. See my response here:

    http://ubuntuforums.org/showthread.p...82#post9257882

  9. #59
    Join Date
    Feb 2007
    Beans
    12

    Re: Nvidia GT220 & Audio Device "0be2"

    x
    Last edited by Marktrix; May 25th, 2010 at 09:07 PM. Reason: @admin: Delete my Post

  10. #60
    Join Date
    Mar 2009
    Location
    San Diego, CA, USA
    Beans
    13
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Nvidia GT220 & Audio Device "0be2"

    Quote Originally Posted by novellahub View Post
    I believe you need to do the following:

    Navigate to System > Preferences > Sound

    In the hardware tab choose HDMI out for the hardware profile.
    When I do that, I don't get an HDMI choice to select. Only the motherboard analog and digital devices (IEC958). How do I get the GT220 HDMI audio device to show up? This is with a new install of 10.04 LTS.
    Last edited by jay214128; May 31st, 2010 at 06:25 AM. Reason: Add OS version

Page 6 of 7 FirstFirst ... 4567 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •