Page 3 of 7 FirstFirst 12345 ... LastLast
Results 21 to 30 of 70

Thread: Nvidia GT220 & Audio Device "0be2"

  1. #21
    Join Date
    Apr 2006
    Beans
    Hidden!

    Re: Nvidia GT220 & Audio Device "0be2"

    I gave it another try but got the same results. It is strange that it broke my built in that worked before.


    $ sudo lshw -C multimedia -numeric
    *-multimedia
    description: Audio device
    product: nVidia Corporation [10DE:BE4]
    vendor: nVidia Corporation [10DE]
    physical id: 0.1
    bus info: pci@0000:01:00.1
    version: a1
    width: 32 bits
    clock: 33MHz
    capabilities: pm msi pciexpress bus_master cap_list
    configuration: driver=HDA Intel latency=0
    resources: irq:38 memory:cdefc000-cdefffff
    *-multimedia
    description: Audio device
    product: 5 Series/3400 Series Chipset High Definition Audio [8086:3B56]
    vendor: Intel Corporation [8086]
    physical id: 1b
    bus info: pci@0000:00:1b.0
    version: 05
    width: 64 bits
    clock: 33MHz
    capabilities: pm msi pciexpress bus_master cap_list
    configuration: driver=HDA Intel latency=0
    resources: irq:36 memory:f0800000-f0803fff
    $ cat /proc/asound/version
    Advanced Linux Sound Architecture Driver Version 1.0.22.
    Compiled on Dec 18 2009 for kernel 2.6.31-17-generic (SMP).
    $ aplay -l
    **** List of PLAYBACK Hardware Devices ****
    $
    Running Linux From Scratch for over 7 and a half years on my desktop
    Running Ubuntu on my laptop since I bought it

  2. #22
    Join Date
    Dec 2009
    Beans
    2

    Re: Nvidia GT220 & Audio Device "0be2"

    sorry i like only ati chip it is the best

  3. #23
    Join Date
    May 2009
    Beans
    13

    Re: Nvidia GT220 & Audio Device "0be2"

    Quote Originally Posted by moonshine2b1 View Post
    sorry i like only ati chip it is the best
    How's that VDPAU and CUDA running on ATI chips? I heard ATI finally got their crap out for Linux but

    -

    Showing up as a device now under lspci, but not aplay.

    PHP Code:
    03:00.0 VGA compatible controllernVidia Corporation GT200 [GeForce GT 220] (rev a2) (prog-if 00 [VGA controller])
        
    SubsystemnVidia Corporation Device 069a
        Control
    I/OMemBusMasterSpecCycleMemWINVVGASnoopParErrSteppingSERRFastB2BDisINTx-
        
    StatusCap66MHzUDFFastB2BParErrDEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERRINTx-
        
    Latency0
        Interrupt
    pin A routed to IRQ 16
        Region 0
    Memory at f9000000 (32-bitnon-prefetchable) [size=16M]
        
    Region 1Memory at b0000000 (64-bitprefetchable) [size=256M]
        
    Region 3Memory at ce000000 (64-bitprefetchable) [size=32M]
        
    Region 5I/O ports at cc00 [size=128]
        [
    virtualExpansion ROM at c0000000 [disabled] [size=512K]
        
    Capabilities: <access denied>
        
    Kernel driver in use: nvidia

    03
    :00.1 Audio devicenVidia Corporation High Definition Audio Controller (rev a1)
        
    SubsystemnVidia Corporation Device 069a
        Control
    I/OMemBusMasterSpecCycleMemWINVVGASnoopParErrSteppingSERRFastB2BDisINTx-
        
    StatusCap66MHzUDFFastB2BParErrDEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERRINTx-
        
    Latency0Cache Line Size32 bytes
        Interrupt
    pin A routed to IRQ 5
        Region 0
    Memory at faffc000 (32-bitnon-prefetchable) [size=16K]
        
    Capabilities: <access denied

  4. #24
    Join Date
    Apr 2006
    Beans
    Hidden!

    Re: Nvidia GT220 & Audio Device "0be2"

    I got mine to show up in aplay using the following patch on the source. It ended up showing and alsamixer has a control for it. (just spdif) but I could not get any sound to come out from my receiver. Sound preferences only give me a stereo output option for it.

    I still can't get my built in to work, which uses the same module so they must of broke something generic.

    http://article.gmane.org/gmane.linux.alsa.devel/69250
    Running Linux From Scratch for over 7 and a half years on my desktop
    Running Ubuntu on my laptop since I bought it

  5. #25
    Join Date
    Jun 2007
    Beans
    49

    Re: Nvidia GT220 & Audio Device "0be2"

    I've compiled ALSA 1.0.22 using: http://monespaceperso.org/blog-en/20...ic-koala-9-10/

    Don't hear a peep in MythTV though. Tried it to ALSA:hdmi and ALSA:Default as sound output device.

    Also, `aplay -L` only shows the null device (no sound)

    My hardware:
    Code:
    01:00.0 VGA compatible controller: nVidia Corporation GT200 [GeForce GT 220] (rev a2)
    01:00.1 Audio device: nVidia Corporation Device 0be2 (rev a1)
    After re-enabling onboard sound even that doesn't show up after alsaconf configured it, and alsamixer doesn't show any controls for both cards. Back to 1.0.20 we go.

    After installing linux-backports-modules-alsa-2.6.31-16-generic & linux-backports-modules-alsa-karmic-generic sound seems to work again with the card on my motherboard. Except still no sound in MythTV.

    Trying if `sudo aptitude reinstall linux-image-2.6.31-16-generic` fixes the problem.

    Oh joy, my TV suppresses analog audio when the card supplies audio over HDMI or DVI. Just tested it with music on my iPhone.
    Last edited by Henk Poley; December 24th, 2009 at 04:40 PM.

  6. #26
    Join Date
    Jun 2006
    Beans
    14

    Re: Nvidia GT220 & Audio Device "0be2"

    Quote Originally Posted by Henk Poley View Post
    Oh joy, my TV suppresses analog audio when the card supplies audio over HDMI or DVI. Just tested it with music on my iPhone.
    I had the same problem with I tried using a DVI cable with analog audio. The TV would ignore the analog audio and try to use the (dead) audio signal. To get around this I created a custom EDID file to tell Nvidia the TV doesn't support audio, which in turn prevents the driver from sending a signal.

    Do a google search, there's a couple of How-To's out there. If you get stuck let me know and I can help you out. The basic approach is:

    1. Use nvidia-settings to grab your current EDID.
    2. Hexedit out the advanced config blocks.
    3. Recalculate the checksum, and update the hex file with it.
    4. Reference the custom EDID from xorg.conf (eg. Option "CustomEDID" "DFP-0:/etc/X11/samsung71f.bin")

  7. #27
    Join Date
    Jun 2007
    Beans
    49

    Re: Nvidia GT220 & Audio Device "0be2"

    I'll try your hack soon jstapels. For the moment -pss, it's christmas eve- I run over VGA @ 1360x768@60Hz, but with VDPAU

    Edit: also tried the most recent ALSA snapshot, still both my onboard and GT220 audio are not recognised.

  8. #28
    Join Date
    Apr 2006
    Beans
    Hidden!

    Re: Nvidia GT220 & Audio Device "0be2"

    You can get the latest snapshot to work? Whenever I try it I get a error about the snd module loading a duplicate symbol (gcd) that is already owned by the kernel.

    It is driving me crazy since I really need hdmi audio for Christmas day or I will have to use Windows which is not setup with a lot of other stuff I need.
    Running Linux From Scratch for over 7 and a half years on my desktop
    Running Ubuntu on my laptop since I bought it

  9. #29
    Join Date
    Nov 2007
    Beans
    20

    Re: Nvidia GT220 & Audio Device "0be2"

    Howdy,

    This is hopefully the right thread for this.

    This afternoon I bought a GeForce GT 220 after being unable to get WoW running on my old ATI card. Everything seemed to be working when I realized that my sound was no longer playing at all. I looked at the default sound controller in the panel and there was no hardware present. The output was set to "Dummy Output". I did a an lspci | grep Audio and the results are below:

    lspci -v | grep Audio
    02:00.1 Audio device: nVidia Corporation Device 0be2 (rev a1)
    Note that the on-board HDA device is no longer listed. An aplay -l reveals that no devices are found at all. When I go to alsamixer, however, it seems to see my HDA device:

    Card: HDA NVidia
    I ran a script to update to ALSA 1.0.22 and it seems to have worked successfully:

    cat /proc/asound/version
    Advanced Linux Sound Architecture Driver Version 1.0.22.
    Compiled on Dec 24 2009 for kernel 2.6.31-16-generic (SMP).
    When I run sudo alsaconfig it sees my new video card but not the HDA device as far as I can see. I have tried various things to troubleshoot the issue, including uninstalling the video drivers and booting into the 2.6.31-14 kernel, but the HDA device will simply not show up in the lspci. I am at a complete loss as to how to get my audio back.

  10. #30
    Join Date
    Apr 2006
    Beans
    Hidden!

    Re: Nvidia GT220 & Audio Device "0be2"

    I have the same problem with 1.0.22 both my hdmi and built-in don't work.

    Going back to 1.0.21 fixes the built-in (no support for the hdmi) since they seem to of totally broke snd-hda-intel in the latest release.

    A easy way is to reinstall all the alsa packages and linux-image which will give you 1.0.20

    Or just install linux-backports-modules-alsa-karmic-generic which installs 1.0.21 to a separate place that get priority when loading modules if it exists.
    Running Linux From Scratch for over 7 and a half years on my desktop
    Running Ubuntu on my laptop since I bought it

Page 3 of 7 FirstFirst 12345 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •