Results 1 to 6 of 6

Thread: CUPS problem after 9.10 upgrade

  1. #1
    Join Date
    Mar 2009
    Location
    New York
    Beans
    53
    Distro
    Ubuntu 9.10 Karmic Koala

    CUPS problem after 9.10 upgrade

    Hello,

    I am having a few problems with my CUPS ubuntu 9.10 print server. Firstly, it was working fine all along with 9.04, but then cups was upgraded in 9.10 to 1.4.1 which is when my issues started.

    What happens now, if I try to print a test page from the cups web interface to my networked printer, it just sits there forever processing and never prints.

    In the error log, all I see are these errors!

    Code:
    E [04/Nov/2009:12:21:50 -0500] cupsdAuthorize: Empty Basic password!
    E [04/Nov/2009:12:23:09 -0500] SSL shutdown failed: Error in the push function.
    E [04/Nov/2009:12:23:19 -0500] SSL shutdown failed: Error in the push function.
    E [04/Nov/2009:12:25:22 -0500] SSL shutdown failed: Error in the push function.
    E [04/Nov/2009:12:25:22 -0500] SSL shutdown failed: Error in the push function.
    E [04/Nov/2009:12:25:22 -0500] SSL shutdown failed: Error in the push function.
    E [04/Nov/2009:12:25:22 -0500] SSL shutdown failed: Error in the push function.
    E [04/Nov/2009:12:25:22 -0500] SSL shutdown failed: Error in the push function.
    E [04/Nov/2009:12:25:29 -0500] SSL shutdown failed: Error in the push function.
    E [04/Nov/2009:12:26:42 -0500] SSL shutdown failed: Error in the push function.
    E [04/Nov/2009:12:27:02 -0500] SSL shutdown failed: Error in the push function.
    E [04/Nov/2009:12:27:38 -0500] SSL shutdown failed: Error in the push function.
    E [04/Nov/2009:12:27:38 -0500] SSL shutdown failed: Error in the push function.
    E [04/Nov/2009:12:27:38 -0500] SSL shutdown failed: Error in the push function.
    E [04/Nov/2009:12:27:38 -0500] SSL shutdown failed: Error in the push function.
    E [04/Nov/2009:12:27:38 -0500] SSL shutdown failed: Error in the push function.
    E [04/Nov/2009:12:27:46 -0500] SSL shutdown failed: Error in the push function.
    E [04/Nov/2009:12:28:34 -0500] cupsdAuthorize: Empty Basic password!
    E [04/Nov/2009:12:29:38 -0500] SSL shutdown failed: Error in the push function.
    E [04/Nov/2009:12:30:03 -0500] SSL shutdown failed: Error in the push function.
    E [04/Nov/2009:12:32:11 -0500] SSL shutdown failed: Error in the push function.
    E [04/Nov/2009:12:32:36 -0500] SSL shutdown failed: Error in the push function.
    E [04/Nov/2009:12:35:37 -0500] SSL shutdown failed: Error in the push function.
    E [04/Nov/2009:12:35:37 -0500] SSL shutdown failed: Error in the push function.
    E [04/Nov/2009:12:35:37 -0500] SSL shutdown failed: Error in the push function.
    E [04/Nov/2009:12:35:37 -0500] SSL shutdown failed: Error in the push function.
    E [04/Nov/2009:12:36:02 -0500] SSL shutdown failed: Error in the push function.
    E [04/Nov/2009:12:37:06 -0500] SSL shutdown failed: Error in the push function.
    E [04/Nov/2009:12:37:06 -0500] SSL shutdown failed: Error in the push function.
    E [04/Nov/2009:12:37:06 -0500] SSL shutdown failed: Error in the push function.
    E [04/Nov/2009:12:37:06 -0500] SSL shutdown failed: Error in the push function.
    E [04/Nov/2009:12:37:06 -0500] SSL shutdown failed: Error in the push function.
    E [04/Nov/2009:12:37:14 -0500] SSL shutdown failed: Error in the push function.
    E [04/Nov/2009:12:39:34 -0500] Unable to remove temporary file "/var/spool/cups/tmp/.hplip" - Is a directory
    E [04/Nov/2009:12:40:45 -0500] Unable to encrypt connection from 10.50.1.7 - A TLS fatal alert has been received.
    E [04/Nov/2009:12:41:14 -0500] SSL shutdown failed: Error in the push function.
    E [04/Nov/2009:13:59:52 -0500] SSL shutdown failed: Error in the push function.
    E [04/Nov/2009:14:01:47 -0500] SSL shutdown failed: Error in the push function.
    E [04/Nov/2009:14:01:47 -0500] SSL shutdown failed: Error in the push function.
    E [04/Nov/2009:14:01:48 -0500] cupsdAuthorize: pam_acct_mgmt() returned 7 (Authentication failure)!
    W [04/Nov/2009:14:01:48 -0500] Too many open files, holding new connections for 30 seconds...
    E [04/Nov/2009:14:01:48 -0500] Unable to accept client connection - Too many open files.
    E [04/Nov/2009:14:01:48 -0500] cupsdAuthorize: pam_start() returned 26 (Critical error - immediate abort)!
    E [04/Nov/2009:14:01:48 -0500] cupsdAuthorize: pam_start() returned 26 (Critical error - immediate abort)!
    E [04/Nov/2009:14:01:48 -0500] cupsdAuthorize: pam_start() returned 26 (Critical error - immediate abort)!
    E [04/Nov/2009:14:01:48 -0500] cupsdAuthorize: pam_start() returned 26 (Critical error - immediate abort)!
    E [04/Nov/2009:14:01:55 -0500] cupsdAuthorize: pam_start() returned 26 (Critical error - immediate abort)!
    E [04/Nov/2009:14:01:55 -0500] [CGI] Unable to create pipe for /usr/lib/cups/cgi-bin/admin.cgi - Too many open files
    E [04/Nov/2009:14:01:56 -0500] cupsdAuthorize: pam_start() returned 26 (Critical error - immediate abort)!
    E [04/Nov/2009:14:01:56 -0500] [CGI] Unable to create pipe for /usr/lib/cups/cgi-bin/admin.cgi - Too many open files
    W [04/Nov/2009:14:02:18 -0500] Too many open files, holding new connections for 30 seconds...
    E [04/Nov/2009:14:02:18 -0500] Unable to accept client connection - Too many open files.
    E [04/Nov/2009:14:02:18 -0500] Unable to encrypt connection from 10.50.1.7 - Could not negotiate a supported cipher suite.
    W [04/Nov/2009:14:02:48 -0500] Too many open files, holding new connections for 30 seconds...
    E [04/Nov/2009:14:02:48 -0500] Unable to accept client connection - Too many open files.
    E [04/Nov/2009:14:02:48 -0500] Unable to encrypt connection from 10.50.1.7 - Could not negotiate a supported cipher suite.
    W [04/Nov/2009:14:03:18 -0500] Too many open files, holding new connections for 30 seconds...
    E [04/Nov/2009:14:03:18 -0500] Unable to accept client connection - Too many open files.
    E [04/Nov/2009:14:03:18 -0500] Unable to encrypt connection from 10.50.1.7 - Could not negotiate a supported cipher suite.
    W [04/Nov/2009:14:03:29 -0500] Too many open files, holding new connections for 30 seconds...
    E [04/Nov/2009:14:03:34 -0500] Unable to remove temporary file "/var/spool/cups/tmp/.fontconfig" - Is a directory
    E [04/Nov/2009:14:03:34 -0500] Unable to remove temporary file "/var/spool/cups/tmp/.hplip" - Is a directory
    W [04/Nov/2009:14:03:18 -0500] Too many open files, holding new connections for 30 seconds...
    E [04/Nov/2009:14:03:18 -0500] Unable to accept client connection - Too many open files.
    E [04/Nov/2009:14:03:18 -0500] Unable to encrypt connection from 10.50.1.7 - Could not negotiate a supported cipher suite.
    W [04/Nov/2009:14:03:29 -0500] Too many open files, holding new connections for 30 seconds...
    E [04/Nov/2009:14:03:34 -0500] Unable to remove temporary file "/var/spool/cups/tmp/.fontconfig" - Is a directory
    E [04/Nov/2009:14:03:34 -0500] Unable to remove temporary file "/var/spool/cups/tmp/.hplip" - Is a directory
    E [04/Nov/2009:14:26:10 -0500] Unable to remove temporary file "/var/spool/cups/tmp/.fontconfig" - Is a directory
    E [04/Nov/2009:14:26:10 -0500] Unable to remove temporary file "/var/spool/cups/tmp/.hplip" - Is a directory
    E [04/Nov/2009:14:26:28 -0500] Unable to encrypt connection from 10.50.1.7 - A TLS packet with unexpected length was received.
    E [04/Nov/2009:14:26:28 -0500] SSL shutdown failed: Error in the push function.
    E [04/Nov/2009:14:26:28 -0500] Unable to encrypt connection from 10.50.1.7 - A TLS packet with unexpected length was received.
    E [04/Nov/2009:14:27:13 -0500] Unable to remove temporary file "/var/spool/cups/tmp/.fontconfig" - Is a directory
    E [04/Nov/2009:14:27:13 -0500] Unable to remove temporary file "/var/spool/cups/tmp/.hplip" - Is a directory
    Please help me...this upgrade has caused so much havoc on my servers!
    Last edited by danooch13; November 4th, 2009 at 08:44 PM.

  2. #2
    Join Date
    Mar 2009
    Location
    New York
    Beans
    53
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: CUPS problem after 9.10 upgrade

    I have a feeling it is the URI in the printers.conf look at it!

    Code:
    DeviceURI dnssd://Photosmart%208400%20series%20(D29CFB)._pdl-datastream._tcp.local/
    It would make sense why it never connects to the printer. Why would 9.10 do this?

    What is it supposed to be?

    Code:
    #
    #
    # Sample configuration file for the CUPS scheduler.  See "man cupsd.conf" for a
    # complete description of this file.
    #
    
    # Log general information in error_log - change "warn" to "debug"
    # for troubleshooting...
    LogLevel warn
    
    # Deactivate CUPS' internal logrotating, as we provide a better one, especially
    # LogLevel debug2 gets usable now
    MaxLogSize 0
    
    # Administrator user group...
    SystemGroup lpadmin
    
    
    # Only listen for connections from the local machine.
    Listen 631
    Listen /var/run/cups/cups.sock
    
    # Show shared printers on the local network.
    Browsing On
    BrowseOrder allow,deny
    BrowseAllow all
    BrowseAddress @LOCAL
    #BrowseLocalProtocols CUPS dnssd
    
    #Added by AP for 426 Upgrade Required error 11/4/09
    DefaultEncryption Never
    
    # Default authentication type, when authentication is required...
    DefaultAuthType Basic
    Last edited by danooch13; November 4th, 2009 at 09:19 PM.

  3. #3
    Join Date
    Mar 2009
    Location
    New York
    Beans
    53
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: CUPS problem after 9.10 upgrade

    Now I used hp-makeuri to make the uri, and I pasted it into the Device URI string in printers.conf.

    When I try to print a test page, I get this now

    Code:
    /usr/lib/cups/backend/hp failed

  4. #4
    Join Date
    Mar 2009
    Location
    New York
    Beans
    53
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: CUPS problem after 9.10 upgrade

    Please close this. It was my dumb a** brothers fault. He had the photo tray engaged and I was not home to see it. That is why nothing was printing.

    All of those errors were caused by me futzing around...

    Sorry

  5. #5
    Join Date
    Oct 2010
    Location
    Finland
    Beans
    18
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: CUPS problem after 9.10 upgrade

    I had a somewhat similar problem on Ubuntu 10.04.

    In my case, I could not see the printer listed on lsusb

    Error -71 was typical.

    Tried various fixes, they didn't help:
    Step 7 here - http://hplipopensource.com/hplip-web...os/ubuntu.html
    Code:
    sudo usermod -a -G lp $USER
    Hotfix here - http://www.novell.com/support/search...eID=DT_TID_1_1
    Code:
    echo -1 > /sys/module/usbcore/parameters/autosuspend
    Then tried the fix in this thread:
    http://ubuntu-ky.ubuntuforums.org/sh....php?p=9790032

    Which is to shut down the computer completely, turn off the power supply for 30mins.

    That worked and lsusb shows the printer again.

  6. #6
    Join Date
    Nov 2008
    Beans
    44
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: CUPS problem after 9.10 upgrade

    I was griefed by "/usr/lib/cups/backend/hp failed" for a long time in Lucid and Maverick. I solved it by installing gs-esp

    Code:
    sudo apt-get install gs-esp

    I found the fix on Debian's forums. It may be an easy solution for those searching.
    Last edited by shrimpy89; February 23rd, 2011 at 03:16 AM. Reason: spellcheck.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •