Page 1 of 3 123 LastLast
Results 1 to 10 of 27

Thread: cups-insecure filter

  1. #1
    Join Date
    Nov 2009
    Beans
    4

    cups-insecure filter

    Hello,

    After Installing my canon mp240 printer in ubuntu 9.10 and trying to print a test page I get this error saying "cups-insecure-filter". Please help! It worked with previous versions of ubuntu.

    Stephanos

  2. #2
    Join Date
    Nov 2009
    Beans
    1

    Re: cups-insecure filter

    I had the same problem after upgrading, for my canon ip1800. Figured it out and registered just to post this. you need to find anything in /usr/lib/cups/filter and /usr/lib/cups/backend not owned by root, and chown and chgrp them to root

    sudo chown root /usr/lib/cups/filter/whatever
    sudo chgrp root /usr/lib/cups/filter/whatever
    sudo chown root /usr/lib/cups/backend/whatever
    sudo chgrp root /usr/lib/cups/backend/whatever

    worked for me...
    Last edited by john_pollard; November 5th, 2009 at 10:31 AM.

  3. #3
    Join Date
    Nov 2009
    Beans
    4

    Re: cups-insecure filter

    I also registered to post this

    There are too many files. How can I make all the contents of these two folders to be owned by root by using the terminal?

  4. #4
    Join Date
    Nov 2009
    Beans
    4

    Re: cups-insecure filter

    thanks a lot mate!

    Got into terminal and after asking it for help for these commands I solved my problem.

    You actually have to type:

    sudo chown -hR /usr/lib/cups/filter
    sudo chown -hR /usr/lib/cups/backend
    sudo chgrp -hR /usr/lib/cups/filter
    sudo chgrp -hR /usr/lib/cups/backend

    SOLVED

  5. #5
    Join Date
    Nov 2009
    Beans
    2

    Re: cups-insecure filter

    Hmm, Terminal tells me that there's a missing operant.

    I suppose the correct commands should rather be:

    sudo chown -hR root /usr/lib/cups/filter
    sudo chown -hR root /usr/lib/cups/backend
    sudo chgrp -hR root /usr/lib/cups/filter
    sudo chgrp -hR root /usr/lib/cups/backend

    Anyway, even with "root" added to the commands, I am still experiencing the cups-insecure-filter message when I try printing from our network printers.

    Removing and reinstalling cups as well as setting up the printers from scratch did not make any difference either.

  6. #6
    Join Date
    Nov 2009
    Beans
    4

    Re: cups-insecure filter

    Yes sorry about the mistake.

    there should be a "root" there you are right.

    Doing this solved my problem.

  7. #7
    Join Date
    Nov 2009
    Beans
    2

    Re: cups-insecure filter

    And hey, I got good news, too: reinstalling the actual printer driver solved the problem in my case. Now our KONICA MINOLTA bizhub 250 is willing to print again =D>

  8. #8
    Join Date
    Nov 2009
    Beans
    7

    Re: cups-insecure filter

    Quote Originally Posted by danmoo View Post
    Hmm, Terminal tells me that there's a missing operant.

    I suppose the correct commands should rather be:

    sudo chown -hR root /usr/lib/cups/filter
    sudo chown -hR root /usr/lib/cups/backend
    sudo chgrp -hR root /usr/lib/cups/filter
    sudo chgrp -hR root /usr/lib/cups/backend

    Anyway, even with "root" added to the commands, I am still experiencing the cups-insecure-filter message when I try printing from our network printers.

    Removing and reinstalling cups as well as setting up the printers from scratch did not make any difference either.
    I've tried all this, but my Brother MFC-3360C is still giving me back the same message. Anybody got any ideas?

    I am very new to Ubuntu (and Linux), so please make the replies apt for chumps

    Thanks

  9. #9
    Join Date
    Jul 2009
    Beans
    28
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: cups-insecure filter

    I have an Epson printer.
    This problem occurred after upgrading to 9.10, the printer worked fine before the upgrade.
    I first tried the commands as described above but it would not work because the user did not have administrator rights.

    Then I tried from another user account and the commands went OK but the printer had the same error message.
    I then deleted and re-installed the printer, which fixed the problem.

    System > administration > printing.
    Inside this menu, delete the icon with your printer name.
    Then (still inside this menu), click "new", or Server > New > Printer
    It will search for printers, will find your printer (if it is connected),
    look for a driver and install it. This worked for me.
    Last edited by beesblaas; November 9th, 2009 at 12:38 AM.

  10. #10
    Join Date
    Nov 2008
    Location
    India
    Beans
    89
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: cups-insecure filter

    Quote Originally Posted by danmoo View Post

    sudo chown -hR root /usr/lib/cups/filter
    sudo chown -hR root /usr/lib/cups/backend
    sudo chgrp -hR root /usr/lib/cups/filter
    sudo chgrp -hR root /usr/lib/cups/backend
    Had the same problem with my canon mp140 series driver

    executing these commands solved the problem .
    Last edited by LequidMetal; November 25th, 2009 at 07:58 AM. Reason: Additional info

Page 1 of 3 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •