Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: How to enable TCP connections to XServer?

Hybrid View

  1. #1
    Join Date
    May 2006
    Location
    /usr/azerbaijan/baku/
    Beans
    31
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Red face How to enable TCP connections to XServer?

    Hello there!

    I need to enable TCP connections to my X server on Ubuntu Karmic, in order to run remote X applications via SSH. On older Ubuntu's I could just unmark "Deny TCP connections to Xserver" and restart GDM. But now, XServer is new, and has new gdmsetup.

    Any help would be appreciated!

    There was file called custom.conf in /etc/gdm, containing following string:

    [security]

    DisallowTCP=false

    Thanks!
    When we speak about free software, we refer to freedom, not price
    -- GNU General Public License

  2. #2
    Join Date
    Nov 2009
    Location
    Bulgaria
    Beans
    2
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: How to enable TCP connections to XServer?

    sudo gedit /etc/gdm/gdm.schemas

    find:

    <schema>
    <key>security/DisallowTCP</key>
    <signature>b</signature>
    <default>true</default>
    </schema>

    shift from true to false:

    <schema>
    <key>security/DisallowTCP</key>
    <signature>b</signature>
    <default>false</default>
    </schema>

    save file gdm.schemas
    restart Ubuntu
    it works for me
    Last edited by b12gold; November 5th, 2009 at 01:31 PM.

  3. #3
    Join Date
    Mar 2006
    Location
    Hermosa Beach, CA, USA
    Beans
    27
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: How to enable TCP connections to XServer?

    This guy talks about this issue here:
    http://www.peppertop.com/blog/?p=671

    He fixes it here:
    http://www.peppertop.com/blog/?p=690

    I don't know if the above works, but these URLs solved my problem.


  4. #4
    Join Date
    May 2006
    Location
    /usr/azerbaijan/baku/
    Beans
    31
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: How to enable TCP connections to XServer?

    Thanks b12gold! That worked for me!

    burgundy, thanks for more information
    When we speak about free software, we refer to freedom, not price
    -- GNU General Public License

  5. #5
    Join Date
    Nov 2009
    Location
    Bulgaria
    Beans
    2
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: How to enable TCP connections to XServer?

    Glad that works for you, you're welcome again

  6. #6
    Join Date
    Dec 2009
    Beans
    1

    Re: How to enable TCP connections to XServer?

    Thanks it works great.

    Regards,

  7. #7
    Join Date
    Jan 2009
    Beans
    13

    Re: How to enable TCP connections to XServer?

    Quote Originally Posted by b12gold View Post
    sudo gedit /etc/gdm/gdm.schemas

    find:

    <schema>
    <key>security/DisallowTCP</key>
    <signature>b</signature>
    <default>true</default>
    </schema>

    shift from true to false:

    <schema>
    <key>security/DisallowTCP</key>
    <signature>b</signature>
    <default>false</default>
    </schema>

    save file gdm.schemas
    restart Ubuntu
    it works for me
    cool .. it works

  8. #8
    Join Date
    Mar 2010
    Beans
    9

    Re: How to enable TCP connections to XServer?

    Hello. I just upgraded from Natty to Oneiric and I can't get this to work. I had it working fine on Natty but now its broken again. Here's what I did:
    1. Went and removed "-nolisten TCP" from /etc/X11/xinit/xserverrrc
    2. Changed True to False for the DisallowTCP in /usr/share/gdm/gdm.schemas (/etc/gdm/gdm.schemas was already set to false)
    3. Did xhost + on my Ubuntu desktop (tried just as myself and also with sudo)

    Still getting the "Can't open display" message.....

    What am I missing??
    Thanks for the tips!
    Last edited by mpenda; October 17th, 2011 at 07:39 PM. Reason: Forgot to mention about /etc/gdm

  9. #9
    Join Date
    Oct 2011
    Beans
    3

    Re: How to enable TCP connections to XServer?

    I was asking myself the same question... The answer ist that on Ubuntu Oneiric Ocelot (11.10) the display manager has changed to LightDM, which doesn't apparently read neither/etc/X11/xinit/xserverrc nor /usr/share/gdm/gdm.schemas.

    To enable TCP connections to the Xserver on Ubuntu Oneiric Ocelot (11.10):
    1) Open /etc/lightdm/lightdm.conf with your favorite editor.

    2) Add the following line to section [SeatDefaults]:
    xserver-allow-tcp=true

    [While you're at it you may want to add as well:
    allow-guest=false
    to prevent unrestricted guest access to your computer, see this for more information (in Spanish) http://hmontoliu.blogspot.com/2011/1...vitado-en.html.

    Your /etc/lightdm/lightdm.conf should look similar to this:
    [SeatDefaults]
    greeter-session=unity-greeter
    user-session=ubuntu
    xserver-allow-tcp=true
    allow-guest=false


    3) Reboot.

    4) Enjoy.
    Last edited by jllarden; October 21st, 2011 at 07:24 AM. Reason: URL to blogspot.com was broken.

  10. #10
    Join Date
    Jul 2007
    Beans
    34

    Unhappy Re: How to enable TCP connections to XServer?

    Quote Originally Posted by mpenda View Post
    Hello. I just upgraded from Natty to Oneiric and I can't get this to work. I had it working fine on Natty but now its broken again. Here's what I did:
    1. Went and removed "-nolisten TCP" from /etc/X11/xinit/xserverrrc
    2. Changed True to False for the DisallowTCP in /usr/share/gdm/gdm.schemas (/etc/gdm/gdm.schemas was already set to false)
    3. Did xhost + on my Ubuntu desktop (tried just as myself and also with sudo)

    Still getting the "Can't open display" message.....

    What am I missing??
    Thanks for the tips!
    I'm running 10.10 and have the same problem. I have also edited the gdm/custom.conf as suggested by a blog. No joy. Really frustrating that Ubuntu has made a basic linux networking function so difficult.

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •