Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Could not download all repository indexes

  1. #1
    Join Date
    Jun 2006
    Location
    81mm mortar range of MS
    Beans
    346

    Question Could not download all repository indexes

    I get errors whenever I try to update my repository info. I'm running 9.10 which I installed from the last beat CD, then upgraded online. (The CD has since been removed from /etc/apt/sources.list).

    The errors are:
    Code:
    Failed to fetch http://archive.ubuntu.com/ubuntu/dists/karmic/Release  Unable to find expected entry  karmic/binary-i386/Packages in Meta-index file (malformed Release file?)
    Failed to fetch http://security.ubuntu.com/ubuntu/dists/karmic-security/Release  Unable to find expected entry  karmic/binary-i386/Packages in Meta-index file (malformed Release file?)
    Failed to fetch http://archive.ubuntu.com/ubuntu/dists/karmic-updates/Release  Unable to find expected entry  karmic/binary-i386/Packages in Meta-index file (malformed Release file?)
    I've tried several different repositories, but no better luck. I found some old bug reports dating back to Intrepid, and lots of suggestions to try:
    Code:
    sudo apt-get update
    which makes no difference.

    Suggestions?

  2. #2
    Join Date
    Nov 2008
    Beans
    36
    Distro
    Ubuntu 9.10 Karmic Koala

    Unhappy Re: Could not download all repository indexes

    I'm a near-newbie and have the same problem. I tried unchecking various boxes in Synaptic/Repositories, as well as the clearing and apt-get suggestions on other threads, to no effect. Hardy had been working, then I did the internal upgrade to karmic, which worked for a couple of days.

    I think I added a bad repository after adding medibuntu 9 days ago, although the medibuntu repository is the only one that seems to work. I also tried changing the repository server from Main to United States, with similar non-effect.

    Here are my error messages:
    Failed to fetch http://us.archive.ubuntu.com/ubuntu/...karmic/Release Unable to find expected entry karmic-updates/binary-i386/Packages in Meta-index file (malformed Release file?)
    Failed to fetch http://security.ubuntu.com/ubuntu/di...curity/Release Unable to find expected entry deb-src/binary-i386/Packages in Meta-index file (malformed Release file?)
    Failed to fetch http://us.archive.ubuntu.com/ubuntu/...pdates/Release Unable to find expected entry karmic-backports/binary-i386/Packages in Meta-index file (malformed Release file?)
    Failed to fetch http://us.archive.ubuntu.com/ubuntu/...kports/Release Unable to find expected entry deb-src/binary-i386/Packages in Meta-index file (malformed Release file?)
    Failed to fetch http://us.archive.ubuntu.com/ubuntu/...oposed/Release Unable to find expected entry deb-src/binary-i386/Packages in Meta-index file (malformed Release file?)
    Some index files failed to download, they have been ignored, or old ones used instead.

    So Update Manager says my computer's not been updated in 9 days, despite my repeated update attempts.

  3. #3
    Join Date
    Jan 2007
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Could not download all repository indexes

    Quote Originally Posted by jweaver28 View Post
    I think I added a bad repository after adding medibuntu 9 days ago, although the medibuntu repository is the only one that seems to work. I also tried changing the repository server from Main to United States, with similar non-effect.
    It looks like your /etc/apt/sources.list has "Releases" in the address that is messing up the file. If you copy the contents of your sources.list file we can help you fix it up.
    GRUB2

    Retired.

  4. #4
    Join Date
    Oct 2009
    Location
    North Carolina US
    Beans
    54
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Could not download all repository indexes

    Has anyone found a answer to this problem?

    I am sort of new to linux. I have been using Ubuntu for two months now. I started out with 9.04 then upgraded to 9.10 almost 2 weeks ago.

    I am now getting an error in my panel saying that my upgrade info is outdated. When I try to update the package info I get an error saying that it could not download all the repository indexes.

    Here are my error messages:
    Failed to fetch http://wine.budgetdedicated.com/apt/...ic/Release.gpg
    Failed to fetch http://wine.budgetdedicated.com/apt/...tion-en_US.bz2
    Failed to fetch http://wine.budgetdedicated.com/apt/...ty/Release.gpg
    Failed to fetch cdrom://Ubuntu 9.04 _Jaunty Jackalope_ - Release i386 (20090420.1)/dists/jaunty/main/binary-i386/Packages.gz Please use apt-cdrom to make this CD-ROM recognized by APT. apt-get update cannot be used to add new CD-ROMs
    Failed to fetch cdrom://Ubuntu 9.04 _Jaunty Jackalope_ - Release i386 (20090420.1)/dists/jaunty/restricted/binary-i386/Packages.gz Please use apt-cdrom to make this CD-ROM recognized by APT. apt-get update cannot be used to add new CD-ROMs
    Failed to fetch http://www.geexbox.org/debian/dists/...86/Packages.gz 404 Not Found
    Failed to fetch http://ubuntu.tribler.org/dists/karm...86/Packages.gz 404 Not Found
    Some index files failed to download, they have been ignored, or old ones used instead.

    Like I said I am still kinda new and have not edited my sources file before. So if someone would be so kind to lend me a hand it would be most appreciated.

  5. #5
    Join Date
    Jan 2007
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Could not download all repository indexes

    Quote Originally Posted by Enlightened Shadow View Post
    I am sort of new to linux. I have been using Ubuntu for two months now. I started out with 9.04 then upgraded to 9.10 almost 2 weeks ago.
    Your sources.list also looks like it has a bunch of problems.

    1. There are still references to Jaunty. If you really are using Karmic, either these lines should be eliminated or the name changed to Karmic.

    2. It still references your Jaunty CD. You should disable this, either by placing a comment symbol (#) in front of the "cd-rom" line or opening Synaptic > Settings > Repositories > Ubuntu Software and unticking the CD-Rom reference in the bottom section. Otherwise you will always be asked to insert it any time you do an update (and since it's Jaunty it wouldn't do you any good anyway).

    3. The wine repositories aren't connecting, but I'm not familiar with how they are structured. You could at least stop the error messages initially by unticking them in Synaptic. They are probably under the Third Party or Other Software tab.

    For general information, if you want to manually edit your sources, in Ubuntu it's done with:
    Code:
    gksu gedit /etc/apt/sources.list
    4. It's not your post, but if you copy the contents here someone would be glad to help you sort it out.

    Here's the community doc with information about repositories and how they are structured:
    https://help.ubuntu.com/community/Repositories/Ubuntu
    Last edited by drs305; November 21st, 2009 at 03:01 AM.
    GRUB2

    Retired.

  6. #6
    Join Date
    Oct 2009
    Location
    Earth
    Beans
    42
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Could not download all repository indexes

    I'm fairly new, using Easy Peasy's jaunty nbr on a brand spankin new HP Mini 1101, and everything seems to work great except this, similar to the others, synaptic doesn't seem to work right, and i certain apt-get commands don't find the packages. if i run $ sudo apt-get update, this is the readout
    Hit http://security.ubuntu.com jaunty-security Release.gpg
    Ign http://security.ubuntu.com jaunty-security/main Translation-en_US
    Get:1 http://us.archive.ubuntu.com jaunty Release.gpg [189B]
    Ign http://us.archive.ubuntu.com jaunty/main Translation-en_US
    Ign http://security.ubuntu.com jaunty-security/restricted Translation-en_US
    Ign http://security.ubuntu.com jaunty-security/universe Translation-en_US
    Ign http://archive.geteasypeasy.com jaunty Release.gpg
    Ign http://security.ubuntu.com jaunty-security/multiverse Translation-en_US
    Hit http://security.ubuntu.com jaunty-security Release
    Ign http://us.archive.ubuntu.com jaunty/restricted Translation-en_US
    Ign http://us.archive.ubuntu.com jaunty/universe Translation-en_US
    Ign http://us.archive.ubuntu.com jaunty/multiverse Translation-en_US
    Hit http://us.archive.ubuntu.com jaunty-updates Release.gpg
    Ign http://us.archive.ubuntu.com jaunty-updates/main Translation-en_US
    Ign http://us.archive.ubuntu.com jaunty-updates/restricted Translation-en_US
    Ign http://us.archive.ubuntu.com jaunty-updates/universe Translation-en_US
    Ign http://us.archive.ubuntu.com jaunty-updates/multiverse Translation-en_US
    Ign http://archive.geteasypeasy.com jaunty/main Translation-en_US
    Hit http://us.archive.ubuntu.com jaunty Release
    Err http://us.archive.ubuntu.com jaunty Release

    Get:2 http://archive.geteasypeasy.com jaunty Release [1245B]
    Hit http://archive.geteasypeasy.com jaunty/main Packages
    Hit http://us.archive.ubuntu.com jaunty-updates Release
    Hit http://ppa.launchpad.net jaunty Release.gpg
    Ign http://ppa.launchpad.net jaunty/main Translation-en_US
    Hit http://security.ubuntu.com jaunty-security/main Packages
    Hit http://us.archive.ubuntu.com jaunty-updates/main Packages
    Hit http://ppa.launchpad.net jaunty Release.gpg
    Ign http://ppa.launchpad.net jaunty/main Translation-en_US
    Hit http://ppa.launchpad.net jaunty Release.gpg
    Ign http://ppa.launchpad.net jaunty/main Translation-en_US
    Hit http://ppa.launchpad.net jaunty Release.gpg
    Ign http://ppa.launchpad.net jaunty/main Translation-en_US
    Hit http://ppa.launchpad.net jaunty Release
    Hit http://security.ubuntu.com jaunty-security/restricted Packages
    Hit http://security.ubuntu.com jaunty-security/main Sources
    Hit http://security.ubuntu.com jaunty-security/restricted Sources
    Hit http://security.ubuntu.com jaunty-security/universe Packages
    Hit http://us.archive.ubuntu.com jaunty-updates/restricted Packages
    Hit http://us.archive.ubuntu.com jaunty-updates/main Sources
    Hit http://us.archive.ubuntu.com jaunty-updates/restricted Sources
    Hit http://us.archive.ubuntu.com jaunty-updates/universe Packages
    Hit http://us.archive.ubuntu.com jaunty-updates/universe Sources
    Hit http://ppa.launchpad.net jaunty Release
    Hit http://ppa.launchpad.net jaunty Release
    Hit http://ppa.launchpad.net jaunty Release
    Hit http://security.ubuntu.com jaunty-security/universe Sources
    Hit http://security.ubuntu.com jaunty-security/multiverse Packages
    Hit http://security.ubuntu.com jaunty-security/multiverse Sources
    Hit http://us.archive.ubuntu.com jaunty-updates/multiverse Packages
    Hit http://us.archive.ubuntu.com jaunty-updates/multiverse Sources
    Hit http://ppa.launchpad.net jaunty/main Packages
    Hit http://ppa.launchpad.net jaunty/main Packages
    Hit http://ppa.launchpad.net jaunty/main Packages
    Hit http://ppa.launchpad.net jaunty/main Packages
    Fetched 190B in 1s (105B/s)
    Reading package lists... Done
    W: A error occurred during the signature verification. The repository is not updated and the previous index files will be used.GPG error: http://us.archive.ubuntu.com jaunty Release: The following signatures were invalid: BADSIG 40976EAF437D05B5 Ubuntu Archive Automatic Signing Key <ftpmaster@ubuntu.com>

    W: Failed to fetch http://us.archive.ubuntu.com/ubuntu/...jaunty/Release

    W: Some index files failed to download, they have been ignored, or old ones used instead.
    W: You may want to run apt-get update to correct these problems






    here's the contents of my sources.list file

    #deb cdrom:[Ubuntu 9.04 _Jaunty Jackalope_ - Release i386 (20090420.1)]/ jaunty main restricted
    # See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
    # newer versions of the distribution.

    deb http://us.archive.ubuntu.com/ubuntu/ jaunty main restricted
    deb-src http://us.archive.ubuntu.com/ubuntu/ jaunty main restricted

    ## Major bug fix updates produced after the final release of the
    ## distribution.
    deb http://us.archive.ubuntu.com/ubuntu/ jaunty-updates main restricted
    deb-src http://us.archive.ubuntu.com/ubuntu/ jaunty-updates main restricted

    ## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
    ## team. Also, please note that software in universe WILL NOT receive any
    ## review or updates from the Easy Peasy security team.
    deb http://us.archive.ubuntu.com/ubuntu/ jaunty universe
    deb-src http://us.archive.ubuntu.com/ubuntu/ jaunty universe
    deb http://us.archive.ubuntu.com/ubuntu/ jaunty-updates universe
    deb-src http://us.archive.ubuntu.com/ubuntu/ jaunty-updates universe

    ## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Easy Peasy
    ## team, and may not be under a free licence. Please satisfy yourself as to
    ## your rights to use the software. Also, please note that software in
    ## multiverse WILL NOT receive any review or updates from the Ubuntu
    ## security team.
    deb http://us.archive.ubuntu.com/ubuntu/ jaunty multiverse
    deb-src http://us.archive.ubuntu.com/ubuntu/ jaunty multiverse
    deb http://us.archive.ubuntu.com/ubuntu/ jaunty-updates multiverse
    deb-src http://us.archive.ubuntu.com/ubuntu/ jaunty-updates multiverse

    ## Uncomment the following two lines to add software from the 'backports'
    ## repository.
    ## N.B. software from this repository may not have been tested as
    ## extensively as that contained in the main release, although it includes
    ## newer versions of some applications which may provide useful features.
    ## Also, please note that software in backports WILL NOT receive any review
    ## or updates from the Easy Peasy security team.
    # deb http://us.archive.ubuntu.com/ubuntu/ jaunty-backports main restricted universe multiverse
    # deb-src http://us.archive.ubuntu.com/ubuntu/ jaunty-backports main restricted universe multiverse

    ## Uncomment the following two lines to add software from Canonical's
    ## 'partner' repository.
    ## This software is not part of Ubuntu, but is offered by Canonical and the
    ## respective vendors as a service to Easy Peasy users.
    # deb http://archive.canonical.com/ubuntu jaunty partner
    # deb-src http://archive.canonical.com/ubuntu jaunty partner

    deb http://security.ubuntu.com/ubuntu jaunty-security main restricted
    deb-src http://security.ubuntu.com/ubuntu jaunty-security main restricted
    deb http://security.ubuntu.com/ubuntu jaunty-security universe
    deb-src http://security.ubuntu.com/ubuntu jaunty-security universe
    deb http://security.ubuntu.com/ubuntu jaunty-security multiverse
    deb-src http://security.ubuntu.com/ubuntu jaunty-security multiverse

  7. #7
    Join Date
    Jan 2007
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Could not download all repository indexes

    Quote Originally Posted by beloved88 View Post
    W: A error occurred during the signature verification. The repository is not updated and the previous index files will be used.GPG error: http://us.archive.ubuntu.com jaunty Release: The following signatures were invalid: BADSIG 40976EAF437D05B5 Ubuntu Archive Automatic Signing Key <ftpmaster@ubuntu.com>
    Update: Actually, I just tried re-importing the key. It appears there is a problem with the server. If it doesn't work, try again later.

    You can try to import the public key with the following:
    Code:
    gpg --keyserver keyserver.ubuntu.com --recv-keys 437D05B5 && gpg --export --armor 437D05B5 | sudo apt-key add -
    If you still get a BADSIG error, open Synaptic, Settings, Repositories: Authentication. Delete the 437D05B5 key, and try running the command again.
    Last edited by drs305; November 21st, 2009 at 03:13 AM.
    GRUB2

    Retired.

  8. #8
    Join Date
    Oct 2009
    Location
    Earth
    Beans
    42
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Could not download all repository indexes

    I still can't seem to do anything, the server must still be down as you said. Is there a way to install new packages and from a USB? I do have desktop running UbuntuStudio Jaunty, is there anything i can do to with that?

  9. #9
    Join Date
    Oct 2009
    Location
    North Carolina US
    Beans
    54
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Could not download all repository indexes

    Hi, I just wanted to give an update on my problem and thank everyone for their support. I was able to get rid of the error message. I didn't realize that once I upgraded that I needed to remove the old repositories from the previous release. Now that I know that I don't think this will be a problem again.

    Thanks, Mike.

    __________________________________________________ __________________________________

    Another day has gone by and I'm glad to say that I'm just a little bit smarter.

  10. #10
    Join Date
    Nov 2005
    Beans
    39

    Re: Could not download all repository indexes

    Greetings

    I was having the same error (malformed?) and found a sources.list here in
    the forums that worked for me::
    (remember to back up first)


    # See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
    # newer versions of the distribution.

    deb http://archive.ubuntu.com/ubuntu/ karmic main universe multiverse restricted
    deb-src http://archive.ubuntu.com/ubuntu/ karmic main universe multiverse restricted

    deb http://archive.ubuntu.com/ubuntu/ karmic-updates main universe multiverse restricted
    deb-src http://archive.ubuntu.com/ubuntu/ karmic-updates main universe multiverse restricted

    # deb http://archive.ubuntu.com/ubuntu/ karmic-backports main restricted universe multiverse
    # deb-src http://archive.ubuntu.com/ubuntu/ karmic-backports main restricted universe multiverse

    deb http://archive.canonical.com/ubuntu karmic partner
    deb-src http://archive.canonical.com/ubuntu karmic partner

    deb http://security.ubuntu.com/ubuntu karmic-security main universe multiverse restricted
    deb-src http://security.ubuntu.com/ubuntu karmic-security main universe multiverse restricted


    that got rid of the errors for me...but I also found a website that makes
    a sources.list from a form

    http://repogen.simplylinux.ch/index.php

    this is the sources.list I am using because it updates pidgin and VLC

    hope this helps

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •