Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: Stop the screen from locking on suspend in 9.10?

  1. #1
    Join Date
    Nov 2009
    Beans
    22

    Stop the screen from locking on suspend in 9.10?

    I want to make it so when I put the computer in standby or hibernate it doesn't lock the screen. I only see the option to do this for the screensaver and for automatic login. How do I do this for standby/hibernate?

  2. #2
    Join Date
    Mar 2009
    Location
    In my head/USA - PA
    Beans
    73
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Stop the screen from locking on suspend in 9.10?

    I'll catch hell for saying this but:
    I kinda like 9.04 better. I have vista, 9.10 and 9.04 and 9.10 gave me lots of problems. I only bring this up because I read your other questions and since you need it fixed for your dad I thought I'd throw that out there.

    Anyway for your problem.

    Go System > Preferences > Screensaver and uncheck the box that says lock when screensaver is active.

    And

    System > Preferences > Power Management
    In there you can find some interesting things.

    Hope this help.
    (I'm currently in 9.04 could be different in 9.10)

    Also after re-reading this and checking i'm not sure if power-management evenn has that option lsited. Try it out...

  3. #3
    Join Date
    Nov 2009
    Beans
    22

    Re: Stop the screen from locking on suspend in 9.10?

    Quote Originally Posted by Johndo1 View Post
    I'll catch hell for saying this but:
    I kinda like 9.04 better. I have vista, 9.10 and 9.04 and 9.10 gave me lots of problems. I only bring this up because I read your other questions and since you need it fixed for your dad I thought I'd throw that out there.
    Well I was having a problem with the video driver in 9.04 that I thought was supposed to be fixed in 9.10 (which it doesn't look like it was) so that's why I upgraded. I want to stick with 9.10 because of the performance, but if I can't get it working I will try openSUSE 11.2 Gnome when it comes out.

    Quote Originally Posted by Johndo1 View Post
    Anyway for your problem.

    Go System > Preferences > Screensaver and uncheck the box that says lock when screensaver is active.
    Already did that.

    Quote Originally Posted by Johndo1 View Post
    And

    System > Preferences > Power Management
    In there you can find some interesting things.

    Hope this help.
    (I'm currently in 9.04 could be different in 9.10)

    Also after re-reading this and checking i'm not sure if power-management evenn has that option lsited. Try it out...
    Yeah, it doesn't have the options there. I read somewhere about gconf-editor but I'm not sure what to do there.

  4. #4
    Join Date
    Mar 2009
    Location
    In my head/USA - PA
    Beans
    73
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Stop the screen from locking on suspend in 9.10?

    Check this thread out:
    http://ubuntuforums.org/showthread.php?t=201256

    Try this: (wich is in the link I provided)
    Code:
    gconftool-2 --type boolean -s /apps/gnome-power-manager/lock_on_blank_screen false
    gconftool-2 --type boolean -s /apps/gnome-power-manager/lock_use_screensaver_settings false
    If this ends up making your screen not go blank when you shut it just do these:

    Code:
    gconftool-2 --type boolean -s /apps/gnome-power-manager/lock_on_blank_screen True
    gconftool-2 --type boolean -s /apps/gnome-power-manager/lock_use_screensaver_settings True
    Last edited by Johndo1; November 2nd, 2009 at 07:13 AM. Reason: Incase of error because of what I said.

  5. #5
    Join Date
    Nov 2009
    Beans
    22

    Re: Stop the screen from locking on suspend in 9.10?

    Quote Originally Posted by Johndo1 View Post
    Check this thread out:
    http://ubuntuforums.org/showthread.php?t=201256

    Try this: (wich is in the link I provided)
    Code:
    gconftool-2 --type boolean -s /apps/gnome-power-manager/lock_on_blank_screen false
    gconftool-2 --type boolean -s /apps/gnome-power-manager/lock_use_screensaver_settings false
    If this ends up making your screen not go blank when you shut it just do these:

    Code:
    gconftool-2 --type boolean -s /apps/gnome-power-manager/lock_on_blank_screen True
    gconftool-2 --type boolean -s /apps/gnome-power-manager/lock_use_screensaver_settings True
    That didn't work. When I try to put the computer in standby, the screen goes black, but the computer doesn't actually go into sleep like with the blinking power indicator like it does in XP. And when I move the mouse, it still asks for my password.

  6. #6
    Join Date
    Dec 2006
    Beans
    24
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Stop the screen from locking on suspend in 9.10?

    I had the same problem. I did two things:

    1.

    • Open the terminal, and type sudo gconf-editor (you'll need to type root password)
    • In the window that comes up go to apps > gnome-power-manager > lock
    • On the right, UNCHECK suspend and hibernate and make sure that the use_screensaver_settings is CHECKED


    2. (I'm not sure if this is necessary - please let me know)

    • In your terminal type sudo gedit /etc/default/acpi-support
    • Go to the line that says LOCK_SCREEN=true and put a # in front of it. So, you'll have a line that reads: #LOCK_SCREEN=true
    • Close, save and try it out.


    It worked for me.

    Too complicated, though. Should be much easier (especially since when you ask to automatically log in during install you assume the same would happen after standby or hibernate).

  7. #7
    Join Date
    Nov 2009
    Beans
    22

    Re: Stop the screen from locking on suspend in 9.10?

    Quote Originally Posted by bigbroantonio View Post
    I had the same problem. I did two things:

    1.

    • Open the terminal, and type sudo gconf-editor (you'll need to type root password)
    • In the window that comes up go to apps > gnome-power-manager > lock
    • On the right, UNCHECK suspend and hibernate and make sure that the use_screensaver_settings is CHECKED


    2. (I'm not sure if this is necessary - please let me know)

    • In your terminal type sudo gedit /etc/default/acpi-support
    • Go to the line that says LOCK_SCREEN=true and put a # in front of it. So, you'll have a line that reads: #LOCK_SCREEN=true
    • Close, save and try it out.


    It worked for me.

    Too complicated, though. Should be much easier (especially since when you ask to automatically log in during install you assume the same would happen after standby or hibernate).
    Even that didn't work. Maybe there were other things you checked or unchecked too?

  8. #8
    Join Date
    Dec 2006
    Beans
    24
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Stop the screen from locking on suspend in 9.10?

    The attachment shows what my gconf-editor setup looks like under apps > gnome-power-manager > lock

    As for editing LOCK_SCREEN in acpi-support, I've pasted my file here:

    http://pastebin.com/d5e82bc91
    Attached Images Attached Images

  9. #9
    Join Date
    Dec 2006
    Beans
    24
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Stop the screen from locking on suspend in 9.10?

    Oh, and one more thing...

    Make sure that in SYSTEM > PREFERENCES > SCREENSAVER the option to lock after the screensaver is UNCHECKED.

  10. #10
    Join Date
    Dec 2005
    Location
    Western Australia
    Beans
    11,337
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Stop the screen from locking on suspend in 9.10?

    What about typing into the terminal:

    Code:
    sudo pm-suspend
    I try to treat the cause, not the symptom. I avoid the terminal in instructions, unless it's easier or necessary. My instructions will work within the Ubuntu system, instead of breaking or subverting it. Those are the three guarantees to the helpee.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •