Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: can't install subclipse

  1. #1
    Join Date
    Jun 2006
    Location
    San Francisco
    Beans
    38
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    can't install subclipse

    Hi,

    I just installed Ubuntu 9.10 (fresh install) and installed Eclipse 3.5.1 (via apt-get). Then, when I tried to install Subclipse (v 1.6), I get a rather odd error message:

    "The artifact file for osgi.bundle,org.eclipse.ant.ui,3.4.1.v20090901_r35 1 was not found."

    And the install fails. Anybody have any ideas?

    Thanks!

  2. #2
    Join Date
    Sep 2009
    Beans
    72

    Re: can't install subclipse

    Is this eclipse - 3.5.1-0ubuntu6 or eclipse - 3.5.1-0ubuntu7 ?

  3. #3
    Join Date
    Jun 2006
    Location
    San Francisco
    Beans
    38
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: can't install subclipse

    How do i tell?

    To install, I did "apt-get install eclipse". The synaptic package manager tells me that the installed version I have "3.5.1+repack~1-0ubuntu1".

  4. #4
    Join Date
    Nov 2007
    Location
    Georgia, United States
    Beans
    465
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: can't install subclipse

    Code:
    apt-cache policy eclipse
    should give you the version number.
    Ubuntu Beginners Team - Development Focus Group Leader
    Ubuntu Georgia Local Team - Website Administrator
    Ubuntu Forums Unanswered Posts Team - Leader

  5. #5
    Join Date
    Jun 2006
    Location
    San Francisco
    Beans
    38
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: can't install subclipse

    Yeah, it's the same version that I noted earlier...


    eclipse:
    Installed: (none)
    Candidate: 3.5.1+repack~1-0ubuntu1
    Version table:
    3.5.1+repack~1-0ubuntu1 0
    500 http://us.archive.ubuntu.com karmic/universe Packages


  6. #6
    Join Date
    Apr 2006
    Location
    Lawrence, KS, USA
    Beans
    53
    Distro
    Ubuntu UNR

    Re: can't install subclipse

    I can't install subclipse either. I get a bunch of errors, "dependency" style errors. The eclipse forums are not much help, so I hope someone will have a suggestion here.

  7. #7
    Join Date
    Aug 2007
    Location
    127.0.0.1
    Beans
    1,800
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: can't install subclipse

    Sounds like a problem with the repository version. Maybe install the version on the website, and add then do it with that? I have all my current setup on eclipse (Eclipse from site + CDT + Pydev + Subclipse) on Jaunty without a trouble.
    "Just in terms of allocation of time resources, religion is not very efficient. There's a lot more I could be doing on a Sunday morning."
    -Bill Gates

  8. #8
    Join Date
    Oct 2009
    Beans
    1

    Re: can't install subclipse

    Quote Originally Posted by brownbat View Post
    I can't install subclipse either. I get a bunch of errors, "dependency" style errors. The eclipse forums are not much help, so I hope someone will have a suggestion here.
    I had a similar problem. It turns out, that the eclipse version from the repository does not come with the ganymede update site.
    So just add
    http://download.eclipse.org/releases/ganymede/
    to your "Available software sites" in preferences->Install/Update, or when calling "install new software". When installing subclipse now, eclipse should be able to find all dependencies on the ganymede update site.

  9. #9
    Join Date
    Jun 2006
    Location
    Columbus, Ohio
    Beans
    123
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: can't install subclipse

    Quote Originally Posted by nwoetzel View Post
    I had a similar problem. It turns out, that the eclipse version from the repository does not come with the ganymede update site.
    So just add
    http://download.eclipse.org/releases/ganymede/
    to your "Available software sites" in preferences->Install/Update, or when calling "install new software". When installing subclipse now, eclipse should be able to find all dependencies on the ganymede update site.
    Thank you, this fixed my particular issue. I just upgraded to Karmic and I guess Eclipse was upgraded with it. Anyway, when I tried to install Subclipse 1.6, the "Finish" button was not clickable after agreeing to the license agreement to install Subclipse. After adding the Ganymede update site, the "Finish" button was enabled and it seems as though Subclipse is installing successfully.

    Thanks again, I wish I could give you 'thanks' like we used to...

    EDIT: I just noticed when Eclipse was restarting that I'm now running Galileo, not Ganymede. I updated my update site to reflect Galileo. Looks like Sublipse works fine even though I used Ganymede when installing Subclipse.
    Last edited by bostonaholic; November 3rd, 2009 at 03:54 PM.

  10. #10
    Join Date
    Jan 2010
    Location
    Nottingham UK
    Beans
    6
    Distro
    Ubuntu 9.10 Karmic Koala

    Smile Re: can't install subclipse

    You would not believe how much and for how long I have struggled trying to figure out why, after the Review Licenses panel, the FINISH button was never enabled.

    Thank you for this excellent advice which fixed the problem and enabled me to complete the installation of Subclipse.

    Kind Regards
    Steve

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •