Page 2 of 13 FirstFirst 123412 ... LastLast
Results 11 to 20 of 128

Thread: Madwifi installation for Atheros card in Karmic koala

  1. #11
    Join Date
    Apr 2009
    Location
    Mangalore India
    Beans
    802
    Distro
    Kubuntu 14.04 Trusty Tahr

    Re: Madwifi installation for Atheros card in Karmic koala

    Quote Originally Posted by Maxepr View Post
    drpjkurian, I've had the same problem as everyone else with 9.10. My wifi is rediculesly slow. 9.04 was excellent. I was just about to go back to 9.04 when I saw the link to this thread. This is the kind of C**P that makes me nervious but I had nothing to lose anyway so I tried it. My internet is noticably faster. I have not tried it away fron home yet but I see no reason that it would be different anywhere else. Thanks for the help. My wifi is near normal now. It still amazes me that 9.10 was released with such a blatent flaw! Internet is the root of using a computer! Whoever released 9.10 too early deserves a kick in the ***! Once again, Thanks.
    Hi
    That was a fine post I ever had in my thread

  2. #12
    Join Date
    Oct 2008
    Beans
    14

    Re: Madwifi installation for Atheros card in Karmic koala

    Quote Originally Posted by Maxepr View Post
    It still amazes me that 9.10 was released with such a blatent flaw! Internet is the root of using a computer! Whoever released 9.10 too early deserves a kick in the ***! Once again, Thanks.
    Actually the problem has nothing to do with Ubuntu but the Linux kernel modules themselves, can't really blame the Ubuntu team on this.

    I tried download the very latest drivers from Linux Wireless site http://linuxwireless.org/en/users/Do...ng_the_tarball, compiled them and still had a problem with the ath9k module (although it did seem to be a little bit better then the one released with 9.10).

    Still, for now, I'm going to go back to Madwifi module. Hopefully Atheros will fix the ath9k code since they are the ones who initially released the code for the ath9k module.

  3. #13
    Join Date
    Nov 2008
    Beans
    26

    Re: Madwifi installation for Atheros card in Karmic koala

    I stand corrected. I am still hoping for a fix soon. I prefer 9.10 over 9.04. I think it has a couple of new features that are worth the upgrade. I will continue to use the madwifi drivers. They are not perfect but they are still pretty good. Since I don't use this particular computer for gaming, I don't mind.

  4. #14
    Join Date
    Oct 2007
    Location
    Dover, NH, USA
    Beans
    53
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Madwifi installation for Atheros card in Karmic koala

    Quote Originally Posted by Prosis View Post
    After doing this, I can't even turn my wireless card on...
    Same thing here. Dr Kurian please help! I can't even turn my wifi on now.

  5. #15
    Join Date
    Oct 2008
    Beans
    14

    Re: Madwifi installation for Atheros card in Karmic koala

    Quote Originally Posted by Maxepr View Post
    I stand corrected. I am still hoping for a fix soon. I prefer 9.10 over 9.04. I think it has a couple of new features that are worth the upgrade. I will continue to use the madwifi drivers. They are not perfect but they are still pretty good. Since I don't use this particular computer for gaming, I don't mind.

    I know it is frustrating, but it's listed as a bug with the Linux Kernel Bug tracker. For those who are interested in seeing the problems you can look at http://bugzilla.kernel.org/buglist.c...cksearch=ath9k

    Also more info can be found at Linux Wireless link http://linuxwireless.org/en/users/Drivers/ath9k/bugs

    I'm actually finding the latest Compat-wireless drivers to work pretty good now, I seem to get almost 25 Mbps of throughput on my wireless G network and I don't seem to be dropping connection anymore!
    Last edited by bac522; November 19th, 2009 at 01:37 AM.

  6. #16
    Join Date
    Oct 2007
    Location
    Dover, NH, USA
    Beans
    53
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Madwifi installation for Atheros card in Karmic koala

    I don't know what I did but this doesn't work. I can't use the external button on my laptop to turn the wireless on. Is there a way i can at least undo what I did before?

  7. #17
    Join Date
    Nov 2009
    Location
    Mexico
    Beans
    25
    Distro
    Ubuntu 9.10 Karmic Koala

    Post Re: Madwifi installation for Atheros card in Karmic koala

    Quote Originally Posted by bac522 View Post
    Actually the problem has nothing to do with Ubuntu but the Linux kernel modules themselves, can't really blame the Ubuntu team on this.

    I tried download the very latest drivers from Linux Wireless site http://linuxwireless.org/en/users/Do...ng_the_tarball, compiled them and still had a problem with the ath9k module (although it did seem to be a little bit better then the one released with 9.10).

    Still, for now, I'm going to go back to Madwifi module. Hopefully Atheros will fix the ath9k code since they are the ones who initially released the code for the ath9k module.
    Did Madwifi actually work for you ? Post your results so people can find solutions to the same problem.

    Thanks,
    X-TBT a.k.a. The Mentor.

  8. #18
    Join Date
    Oct 2008
    Beans
    14

    Re: Madwifi installation for Atheros card in Karmic koala

    Quote Originally Posted by bronxbomberz41 View Post
    I don't know what I did but this doesn't work. I can't use the external button on my laptop to turn the wireless on. Is there a way i can at least undo what I did before?
    Well I'm not 100% sure about this, but I believe that following file /etc/modprobe.d/blacklist-ath_pci.conf might disable your madwifi driver. Make sure this that this file doesn't exist in your /etc/modprobe.d/blacklist-ath_pci.conf. If it does just do a
    sudo mv /etc/modprobe.d/blacklist-ath_pci.conf /etc/modprobe.d/blacklist-ath_pci.conf.bak
    and reboot. See if that fixes the problem.
    Last edited by bac522; November 20th, 2009 at 08:01 PM.

  9. #19
    Join Date
    Oct 2008
    Beans
    14

    Re: Madwifi installation for Atheros card in Karmic koala

    Quote Originally Posted by xtbt View Post
    Did Madwifi actually work for you ? Post your results so people can find solutions to the same problem.

    Thanks,
    X-TBT a.k.a. The Mentor.

    I'm using the the latest version of compact-wireless from http://linuxwireless.org/en/users/Do...ng_the_tarball that I compiled.

    After further use, I've had mixed success. Sometime they work great, sometimes they drop connection.

  10. #20
    Join Date
    Oct 2007
    Location
    Dover, NH, USA
    Beans
    53
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Madwifi installation for Atheros card in Karmic koala

    Quote Originally Posted by bac522 View Post
    Well I'm not 100% sure about this, but I believe that following file /etc/modprobe.d/blacklist-ath_pci.conf might disable your madwifi driver. Make sure this that this file doesn't exist in your /etc/modprobe.d/blacklist-ath_pci.conf. If it does just do a and reboot. See if that fixes the problem.
    Um..I did this but nothing happened. Did you mean "sudo rm" instead of "sudo mv?"

    I was able to open the backup file you mentioned and it says something stopping Madwifi from automatically loading by default using something called Jockey. I'm not sure what Jockey is.

Page 2 of 13 FirstFirst 123412 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •