Page 21 of 39 FirstFirst ... 11192021222331 ... LastLast
Results 201 to 210 of 385

Thread: PulseAudio Equalizer Script

  1. #201
    Join Date
    Nov 2005
    Location
    Ireland
    Beans
    2,605
    Distro
    Ubuntu Development Release

    Re: PulseAudio Equalizer Script

    Quote Originally Posted by MetalMusicAddict View Post
    I'm wondering the future of this since pulseaudio git master has an eq?
    It's hard to tell. The built-in EQ still doesn't have a GTK interface, which may preclude it from being used in Ubuntu Lucid by default.

    Aside from that, my version can be expanded to use different LADSPA plugins (which, as you know, range beyond simple EQ). The interface is already somewhat capable of using other LADSPA plugins, but needs more work.

    The disadvantage of PulseAudio's LADSPA module (used by my interface) is that it's not possible to truly change settings in real-time (which is why you need to click "Apply settings" after each change).
    Last edited by psyke83; February 6th, 2010 at 07:29 PM.

  2. #202
    Join Date
    Sep 2005
    Beans
    113

    Re: PulseAudio Equalizer Script

    Quote Originally Posted by psyke83 View Post
    If you were using v2.5 of the script, it may have written an invalid configuration file. Newer versions won't create this problem, but if the bad configuration is still present, it will cause problems.

    Try:
    Code:
    $ rm ~/.pulse/default.pa*; pkill pulseaudio
    there isnt a file called default.pa in my ~ but there is one in /etc/pulse/
    should I remove it?
    For now i`ve just uninstalled the equalizer, removed anything in .pulse called equalizer* and reinstalled it..see what happens

  3. #203
    Join Date
    Nov 2006
    Location
    near Victoria, BC, Canada
    Beans
    186
    Distro
    Lubuntu 11.10 Oneiric Ocelot

    Re: PulseAudio Equalizer Script

    I skimmed through this thread (and the web) but could not find a fix for my problem...

    I installed the PA eq today on Kubuntu 9.10 - 64-bit (KDE 4.3.5). It appeared that there were no errors and that everything installed correctly. However, the main problem that I have is that the eq has no effect on the tone.

    As well, if I use a preset the eq automatically disables itself. If I don't use the presets everything else appears like it should work (but doesn't).

    EDIT: Further to this, when starting the eq in the terminal I'm given the error message: "cannot access /home/tim/.pulse/presets/*.preset: No such file or directory" When I look in that directory it is empty... no preset file(s).

    Any ideas what may be wrong?
    Last edited by tjk; February 10th, 2010 at 08:30 PM. Reason: new info

  4. #204
    Join Date
    Dec 2008
    Location
    NoCo
    Beans
    Hidden!
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: PulseAudio Equalizer Script

    Thanks for putting this in your ppa psyke! It's much easier to keep it updated that way. Much appreciated.
    Cheers,
    brook
    ...some helpful links for Ubuntu newbies:

  5. #205
    Join Date
    Nov 2008
    Beans
    25

    Re: PulseAudio Equalizer Script

    I had fun and games trying to figure out what PPA was at first then to find psyke83's own PPA.

    So for anyone wanting to add psyke83 ppa its here :-

    https://launchpad.net/~psyke83/+archive/ppa

    excellent work psyke83

    Shame ubuntu doesnt let you post deb files anymore but this way seems to work well, plus everyone gets updates if you update this package.

    Just installed it and reading the first post there should be the equalizer available under Applications >- sound and video

    However this equalizer does not exist.

    This can be ran by -
    ./pulseaudio-equalizer-gtk

    the gui then appears.

    It would appear that if the user does not have a .pulse directory the menu option does not exist or it could be that it does not exist until a reboot is performed.

    How do i change the default frequency bands ?
    is there a way to get this to auto run when logging in (as i have to get this enabled to run).
    Last edited by diddy1234; February 11th, 2010 at 12:21 AM.

  6. #206
    Join Date
    Apr 2006
    Location
    WI
    Beans
    6
    Distro
    Ubuntu Breezy 5.10

    Re: PulseAudio Equalizer Script

    Quote Originally Posted by tjk View Post
    EDIT: Further to this, when starting the eq in the terminal I'm given the error message: "cannot access /home/tim/.pulse/presets/*.preset: No such file or directory" When I look in that directory it is empty... no preset file(s).

    Any ideas what may be wrong?

    I am having this same problem; I can't start the equalizer at all. My presets directory is empty.

    Any suggestions? Could someone post a .preset file?

  7. #207
    Join Date
    Nov 2005
    Location
    Ireland
    Beans
    2,605
    Distro
    Ubuntu Development Release

    Re: PulseAudio Equalizer Script

    Quote Originally Posted by tjk View Post
    I skimmed through this thread (and the web) but could not find a fix for my problem...

    I installed the PA eq today on Kubuntu 9.10 - 64-bit (KDE 4.3.5). It appeared that there were no errors and that everything installed correctly. However, the main problem that I have is that the eq has no effect on the tone.

    As well, if I use a preset the eq automatically disables itself. If I don't use the presets everything else appears like it should work (but doesn't).

    EDIT: Further to this, when starting the eq in the terminal I'm given the error message: "cannot access /home/tim/.pulse/presets/*.preset: No such file or directory" When I look in that directory it is empty... no preset file(s).

    Any ideas what may be wrong?
    The "no such file or directory" message is not really an error - it will show for people who have never saved a custom preset, so it's not related to your problem.

    Please attach the log generated from this command:
    Code:
    $ pulseaudio-equalizer debug

  8. #208
    Join Date
    Nov 2008
    Location
    Manipal,India
    Beans
    23
    Distro
    Ubuntu Studio 10.04 Lucid Lynx

    Re: PulseAudio Equalizer Script

    Hello,
    I am having a problem using the EQ with firefox. Heres what happned:--->
    While playing music from
    http://www.groveshark.com
    The equalizer enables perfectly. But when I try to change the preset firefox stops playing(the song is still playing but no sound). All other applications(eg. vlc ) work fine.
    Please help.

  9. #209
    Join Date
    Nov 2005
    Location
    Ireland
    Beans
    2,605
    Distro
    Ubuntu Development Release

    Re: PulseAudio Equalizer Script

    Quote Originally Posted by necronwarrior View Post
    Hello,
    I am having a problem using the EQ with firefox. Heres what happned:--->
    While playing music from
    http://www.groveshark.com
    The equalizer enables perfectly. But when I try to change the preset firefox stops playing(the song is still playing but no sound). All other applications(eg. vlc ) work fine.
    Please help.
    Switching presets while playing music on that site doesn't give me any problems...

    However, I'm running the Lucid development release, so it may be different for Karmic. Are you using the 32bit or 64bit release?

  10. #210
    Join Date
    May 2005
    Beans
    694

    Re: PulseAudio Equalizer Script

    I tried it and lost my sound. Before enabling it, I had two entries under the tab "output" in the Pulseaudio preferences. One reads

    Code:
    RV620 Audio Device [Radeon HD 34xx Series] Digital Stereo HDMI
    Stereo
    and the other one I don't remember, but had "Analog" in it. The one with analog was the one selected.

    Now I have the digital one and
    Code:
    Lapsda Plugin Multiband EQ on RV620 Audio Device [Radeon HD 34xx Series] Digital Stereo HDMI
    Stereo
    but I lost the analog entry.

    Noone of the two available entries allows me to hear any sound whatsoever.

    What can I do?
    Please, feel free to correct my english, so that I can improve it.

    Click here to join Dropbox. Both you and I get free extra space.

Page 21 of 39 FirstFirst ... 11192021222331 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •