Results 1 to 9 of 9

Thread: Latitude XT2 has no sound in Ubuntu 9.10

  1. #1
    Join Date
    Oct 2009
    Location
    Michigan, USA
    Beans
    15
    Distro
    Ubuntu

    Unhappy Latitude XT2 has no sound in Ubuntu 9.10

    I've been working on this issue for a few days now but nothing seems to be working for me. I'm using Ubuntu 9.10 installed on the Dell Latitude XT2.

    I've tried to change sound settings and tried different output ports with headphones. I also found a thread on changing the /etc/modprobe.d/alsa-base file but I couldn't get it to work. So I find myself asking the Ubuntu community for help.

    Here's a link on the information about my configuration.

    http://www.alsa-project.org/db/?f=e74847c51613285ff6296bef5b8fc20519915d25

    Any help would be appreciated.
    Last edited by EternalLiberty; October 31st, 2009 at 11:22 PM.

  2. #2
    Join Date
    Oct 2009
    Location
    Michigan, USA
    Beans
    15
    Distro
    Ubuntu

    Re: Latitude XT2 has no sound in Ubuntu 9.10

    I found that a lot of people are fixing the issue by using the following commands. This seems to be working for HP computers.

    Open Terminal and type the following

    Code:
    gksu gedit /etc/modprobe.d/alsa-base.conf


    Add the following at the end of the file.

    Code:
    options snd-hda-intel enable_msi=1


    If that didn't fix the issue add this line at the end of the file too.

    Code:
    model=xxx


    Replace the xxx with the sound card manufacturer.
    Last edited by EternalLiberty; October 31st, 2009 at 10:23 PM.

  3. #3
    Join Date
    Oct 2009
    Location
    Michigan, USA
    Beans
    15
    Distro
    Ubuntu

    Re: Latitude XT2 has no sound in Ubuntu 9.10

    I found a solution at the following URL.

    https://bugs.launchpad.net/ubuntu/+s...er/+bug/428555

    All you have to do is open the Alsa configuration file in terminal.

    Code:
    gksu gedit /etc/modprobe.d/alsa-base.conf
    Then add the following code at the end of the file.

    Code:
    options snd-hda-intel model=dell-m4-1
    This worked for my Dell Latitude XT2 running Ubuntu 9.10. Good Luck

  4. #4
    Join Date
    Jul 2009
    Beans
    16

    Re: Latitude XT2 has no sound in Ubuntu 9.10

    it opens a second window then what?

  5. #5
    Join Date
    Oct 2009
    Location
    Michigan, USA
    Beans
    15
    Distro
    Ubuntu

    Re: Latitude XT2 has no sound in Ubuntu 9.10

    It opens a configuration file to which you add a line of code.

  6. #6
    Join Date
    Oct 2009
    Location
    Michigan, USA
    Beans
    15
    Distro
    Ubuntu

    Re: Latitude XT2 has no sound in Ubuntu 9.10

    Please note, if you are using an older version of Ubuntu use the following command to open the configuration file.

    Code:
    gksu gedit /etc/modprobe.d/alsa-base
    The new version adds .conf to the end.

  7. #7
    Join Date
    Jul 2009
    Beans
    16

    Re: Latitude XT2 has no sound in Ubuntu 9.10

    so if i use 9.10 i go into terminal and type
    gksu gedit /etc/modprobe.d/alsa-base.conf

    then in the other window that opens i type in what???? THanks




    Then in the other window that opens i type

  8. #8
    Join Date
    Oct 2009
    Location
    Michigan, USA
    Beans
    15
    Distro
    Ubuntu

    Re: Latitude XT2 has no sound in Ubuntu 9.10

    Make sure the window you are editing is not empty. If it is then you didn't open the correct window. There should be text already in the file you're editing.

    All you have to do is add this line of text to the end of the file.

    Code:
    options snd-hda-intel model=dell-m4-1

  9. #9
    Join Date
    Nov 2008
    Beans
    3

    Re: Latitude XT2 has no sound in Ubuntu 9.10

    Thank you! It worked for me too

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •