Results 1 to 2 of 2

Thread: Black/Ghosting Background with desktop effects - 9.10

Hybrid View

  1. #1
    Join Date
    May 2007
    Beans
    19
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Black/Ghosting Background with desktop effects - 9.10

    Just installed 9.10, fresh, on my laptop. It has an ATI Mobility Radeon 7500 graphics card. I previously ran 9.04 and everything worked perfect.

    When I first started up, it had a black background, not the orange-y one, and moving windows was REALLY slow. I did some researching and had to create and modify the xorg.conf file. It now looks like this.
    Code:
    Section "ServerLayout"
    	Identifier     "X.org Configured"
    	Screen      0  "Screen0" 0 0
    	InputDevice    "Mouse0" "CorePointer"
    	InputDevice    "Keyboard0" "CoreKeyboard"
    	Option	       "AIGLX" "true"
    EndSection
    
    Section "Files"
    	ModulePath   "/usr/lib/xorg/modules"
    	FontPath     "/usr/share/fonts/X11/misc"
    	FontPath     "/usr/share/fonts/X11/cyrillic"
    	FontPath     "/usr/share/fonts/X11/100dpi/:unscaled"
    	FontPath     "/usr/share/fonts/X11/75dpi/:unscaled"
    	FontPath     "/usr/share/fonts/X11/Type1"
    	FontPath     "/usr/share/fonts/X11/100dpi"
    	FontPath     "/usr/share/fonts/X11/75dpi"
    	FontPath     "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
    	FontPath     "built-ins"
    EndSection
    
    Section "Module"
    	Load  "dbe"
    	Load  "dri"
    	Load  "record"
    	Load  "extmod"
    	Load  "glx"
    	Load  "dri2"
    EndSection
    
    Section "InputDevice"
    	Identifier  "Keyboard0"
    	Driver      "kbd"
    EndSection
    
    Section "InputDevice"
    	Identifier  "Mouse0"
    	Driver      "mouse"
    	Option	    "Protocol" "auto"
    	Option	    "Device" "/dev/input/mice"
    	Option	    "ZAxisMapping" "4 5 6 7"
    EndSection
    
    Section "Monitor"
    	#DisplaySize	  300   230	# mm
    	Identifier   "Monitor0"
    	VendorName   "LGP"
    	ModelName    "9f04"
    	Option	    "DPMS"
    EndSection
    
    Section "Device"
            ### Available Driver options are:-
            ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
            ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
            ### [arg]: arg optional
            #Option     "NoAccel"            	# [<bool>]
            #Option     "SWcursor"           	# [<bool>]
            #Option     "Dac6Bit"            	# [<bool>]
            #Option     "Dac8Bit"            	# [<bool>]
            #Option     "BusType"            	# [<str>]
            #Option     "CPPIOMode"          	# [<bool>]
            #Option     "CPusecTimeout"      	# <i>
            #Option     "AGPMode"            	# <i>
            #Option     "AGPFastWrite"       	# [<bool>]
            #Option     "AGPSize"            	# <i>
            #Option     "GARTSize"           	# <i>
            #Option     "RingSize"           	# <i>
            #Option     "BufferSize"         	# <i>
            #Option     "EnableDepthMoves"   	# [<bool>]
            #Option     "EnablePageFlip"     	# [<bool>]
            #Option     "NoBackBuffer"       	# [<bool>]
            #Option     "DMAForXv"           	# [<bool>]
            #Option     "FBTexPercent"       	# <i>
            #Option     "DepthBits"          	# <i>
            #Option     "PCIAPERSize"        	# <i>
            #Option     "AccelDFS"           	# [<bool>]
            #Option     "IgnoreEDID"         	# [<bool>]
            #Option     "DisplayPriority"    	# [<str>]
            #Option     "PanelSize"          	# [<str>]
            #Option     "ForceMinDotClock"   	# <freq>
            #Option     "ColorTiling"        	# [<bool>]
            #Option     "VideoKey"           	# <i>
            #Option     "RageTheatreCrystal" 	# <i>
            #Option     "RageTheatreTunerPort" 	# <i>
            #Option     "RageTheatreCompositePort" 	# <i>
            #Option     "RageTheatreSVideoPort" 	# <i>
            #Option     "TunerType"          	# <i>
            #Option     "RageTheatreMicrocPath" 	# <str>
            #Option     "RageTheatreMicrocType" 	# <str>
            #Option     "ScalerWidth"        	# <i>
            #Option     "RenderAccel"        	# [<bool>]
            #Option     "SubPixelOrder"      	# [<str>]
            #Option     "ShowCache"          	# [<bool>]
            #Option     "ClockGating"        	# [<bool>]
            #Option     "VGAAccess"          	# [<bool>]
            #Option     "ReverseDDC"         	# [<bool>]
            #Option     "LVDSProbePLL"       	# [<bool>]
            #Option     "AccelMethod"        	# <str>
            #Option     "DRI"                	# [<bool>]
            #Option     "ConnectorTable"     	# <str>
            #Option     "DefaultConnectorTable" 	# [<bool>]
            #Option     "DefaultTMDSPLL"     	# [<bool>]
            #Option     "TVDACLoadDetect"    	# [<bool>]
            #Option     "ForceTVOut"         	# [<bool>]
            #Option     "TVStandard"         	# <str>
            #Option     "IgnoreLidStatus"    	# [<bool>]
            #Option     "DefaultTVDACAdj"    	# [<bool>]
            #Option     "Int10"              	# [<bool>]
            #Option     "EXAVSync"           	# [<bool>]
            #Option     "ATOMTVOut"          	# [<bool>]
            #Option     "R4xxATOM"           	# [<bool>]
            #Option     "ForceLowPowerMode"  	# [<bool>]
            #Option     "DynamicPM"          	# [<bool>]
    	Identifier  "Card0"
    	Driver      "radeon"
    	VendorName  "ATI Technologies Inc"
    	BoardName   "Radeon Mobility M7 LW [Radeon Mobility 7500]"
    	BusID       "PCI:1:0:0"
    	Option	    "AccelMethod" "EXA"
    	Option	    "MigrationHeuristic" "greedy"
    	Option	    "AccelDFS" "true"
    	Option	    "EnablePageFlip" "true"
    	Option	    "EnableDepthMoves" "true"
    	Option	    "MergedFB" "off"
    	Option	    "EXANoComposite" "false"
    	Option	    "FBTexPercent" "50"
    	Option	    "DRI" "true"
    	Option	    "RenderAccel" "true"
    	Option	    "AGPMode" "4"
    	Option	    "AGPFastWrite" "true"
    EndSection
    
    Section "Screen"
    	Identifier "Screen0"
    	Device     "Card0"
    	Monitor    "Monitor0"
    	SubSection "Display"
    		Viewport   0 0
    		Depth     1
    	EndSubSection
    	SubSection "Display"
    		Viewport   0 0
    		Depth     4
    	EndSubSection
    	SubSection "Display"
    		Viewport   0 0
    		Depth     8
    	EndSubSection
    	SubSection "Display"
    		Viewport   0 0
    		Depth     15
    	EndSubSection
    	SubSection "Display"
    		Viewport   0 0
    		Depth     16
    	EndSubSection
    	SubSection "Display"
    		Viewport   0 0
    		Depth     24
    	EndSubSection
    EndSection
    
    Section "Extensions"
    	Option	     "Composite" "Enable"
    EndSection
    
    Section "DRI"
    	Mode 0666
    EndSection
    Now when enabling desktop effects, they work very well, better even than in 9.04, but the background is black, and any UI element ghosts on it(Leaves a copy behind). I looked through the Xorg log and found nothing of interest. Does anybody know hoe to fix this? I would really like to stay with 9.10, as I like the speedy start-up, and new features. Thanks in advance

  2. #2
    Join Date
    Sep 2009
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: Black/Ghosting Background with desktop effects - 9.10

    I'm using a ATI Technologies Inc RV350 AP [Radeon 9600] on the box i type this reply from, and I did an upgrade, and still use the default xorg.conf file that ubuntu put in place. I have access to all 3d effects, the cube, openGL screensavers etc. I have not installed any video card drivers, nor do I plan too, as the ones here in 910 work out of the box for this card.

    Here's my xorg.conf file, again, stone stock from the upgrade and everything works:
    # sudo dpkg-reconfigure -phigh xserver-xorg

    Section "Monitor"
    Identifier "Configured Monitor"
    EndSection

    Section "Screen"
    Identifier "Default Screen"
    Monitor "Configured Monitor"
    Device "Configured Video Device"
    DefaultDepth 24
    EndSection

    Section "Module"
    Load "glx"
    EndSection

    Section "Device"
    Identifier "Configured Video Device"
    Driver "ati"
    EndSection

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •