Page 1 of 7 123 ... LastLast
Results 1 to 10 of 61

Thread: Ubuntu 9.10 Desktop All Black at 1280x1024

  1. #1
    Join Date
    Apr 2009
    Beans
    28

    Unhappy Ubuntu 9.10 Desktop All Black at 1280x1024

    Ok I have a weird problem. On a fresh install of Ubuntu 9.10 I started it up to find a blank desktop no background, no icons and newly created files and folders don't show either but the rest of the ui was their and the graphics effects worked. After further experimentation I found that the desktop worked at lower resolutions at 75hz.

    The graphics card is some Radeon 7000 i found lying around in my basement and It handles 1280x1024 fine on Windows.

    Any Idea?

  2. #2
    Join Date
    Feb 2008
    Location
    Omaha, Nebraska
    Beans
    19
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Ubuntu 9.10 Desktop All Black at 1280x1024

    Hi....I have a similar problem. On a fresh install, I get as far as entering my user name and password and then get a message that the screen resolution must be 1280 X 1024. It then locks up and I have to power off to clear. BTW, the screen res already is 1280 X 1024. AMD 64 X2 5200 processor, GeForce 6150SE video card, 4096 MB system memory. From what I've observed so far, there are some real speed bumps in 9.10

  3. #3
    Join Date
    Nov 2008
    Location
    a van down by the river
    Beans
    312
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Ubuntu 9.10 Desktop All Black at 1280x1024

    umaxtu, I'm having the same issue. Mugwump40, your issue sounds like something else and may not be the same solution.

    I also have a Radeon card, it's the 9200. I have a 22" wide screen. The Ubuntu display manager senses the monitor and sets the display to 1680 X 1050 (16:10) by default. That is when I have the issue. If I change to any other available resolution (which are all lower and in 4:3 aspect) then it works fine.

    I noticed that I can still see a tiny part of my background through the transparent panel I have at the bottom. I can tell when I change backgrounds. Other than that little part, the background is all black when I have the display set to 1680 X 1050. This is the only available resolution that 'fills the screen' on my wide screen. The other ones look like crap and I'd really like to get it working on the right setting for my monitor.

    Sorry I don't have a solution to offer but I thought the extra details might help one of the guru's on here figure it out for us
    Q6600 Quad Core @2.4GHz, 1333MHz FSB, 4GB DDR1066 DDR2

  4. #4
    Join Date
    Jul 2006
    Beans
    16

    Re: Ubuntu 9.10 Desktop All Black at 1280x1024

    Well I have the same problem however I did an upgrade from 9.04 to 9.10 and now have the same black screen. I also have one other problem I didn't see mentioned and that is I can't see any window when it is full screen, i.e. firefox when shrunk to about two-thirds the size of the screen I can see it. Stretch it bigger and it is black.

  5. #5
    Join Date
    Jul 2009
    Beans
    28
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Ubuntu 9.10 Desktop All Black at 1280x1024

    I have the same problem after upgrading to 9.10, black screen,
    i.e. I can see the toolbar menu at the top, but where my icons usually are, there are none.
    (they are actually there, but you cant see them, since when I try to create another shortcut
    it says that it already exist)
    Opening applications like Firefox in the black desktop area- the firefox window itself is fine.

    Interestingly, if I log in as another user, the desktop is fine in all aspects!
    The bad desktop is the user from which I upgraded.

    Both users has the same video settings, i.e. 1920 x 1080.

    So it is not this video setting, it is something else.

    OK, SOLUTION: (from another mail in the forum)
    =================================
    Turn visual effects off, it works immediately.
    right-Click on any area on your desktop, get pop-up window, select "change desktop background",
    select "Visual Effects", select "None",
    fixes it!
    Last edited by beesblaas; November 2nd, 2009 at 09:27 AM.

  6. #6
    Join Date
    Feb 2005
    Beans
    425

    Troubleshooting the radeon driver in Ubuntu 9.10

    Make sure you report your issues in the bug tracker. If you have a Radeon card, "ubuntu-bug xserver-xorg-video-ati" is the best way to start filing a bug. Please also report how much video memory you have on your card.

    First, check which acceleration you are using:
    grep XAA /var/log/Xorg.0.log
    grep EXA /var/log/Xorg.0.log
    EXA has now replaced XAA as the default, except for cards with little memory. However there are some issues with XAA, so there are two things to try if your card runs XAA:

    A. Disable RenderAccel, by creating an /etc/X11/xorg.conf with this:

    Code:
    Section "Device"
     Identifier "my-radeon"
     Driver "ati"
     Option "RenderAccel" "off"
    EndSection
    B. Force the use of EXA instead:

    Code:
    Section "Device"
     Identifier "my-radeon"
     Driver "ati"
     Option "AccelMethod" "EXA"
    EndSection
    One other thing to try for low-memory cards is to reduce the virtual screen size to what you are actually using:
    Code:
    Section "Device"
           Identifier "my-radeon"
           Driver "ati"
    EndSection
    
    Section "Screen"
           Identifier "my-screen"
           Device "my-radeon"
           # DefaultColorDepth 16
           SubSection "Display"
                   Virtual 1024 768
           EndSubSection
    EndSection
    Change the Virtual parameters to your screen resolution, of course. Note that by further uncommenting the DefaultColorDepth line you will get fewer colors but even less memory is needed (depth 24 is default).

    On the other hand, for AGP cards with decent amounts of video RAM, increasing the AGPSize might help. Run grep "GART aperture" /var/log/Xorg.0.log to see the default value.
    Code:
    Section "Device"
     Identifier "my-radeon"
     Driver "ati"
     Option "AGPSize" "128"
    EndSection
    The number "128" has to be tuned for your hardware, try 16, 32, 64, 128 up to the amount of video RAM that you have. Higher numbers will reserve more system memory, so just set it as high as you need.

    Finally, one can try KMS (Kernel mode-setting) which enables a video memory manager and DRI2 (for 3D rendering). This will be default in future releases, so this is where most development is focused. See https://wiki.ubuntu.com/X/RadeonKMS for how to try it.
    Last edited by tormod; November 7th, 2009 at 10:13 AM. Reason: Add AGPSize section
    Please use launchpad to search for/report bugs and problems: https://help.ubuntu.com/community/ReportingBugs

  7. #7
    Join Date
    Sep 2007
    Location
    Glasgow UK
    Beans
    15
    Distro
    Ubuntu 7.04 Feisty Fawn

    Re: Ubuntu 9.10 Desktop All Black at 1280x1024

    Brilliant solution - works a treat. Many Thanks.

  8. #8
    Join Date
    Nov 2008
    Location
    a van down by the river
    Beans
    312
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Troubleshooting the radeon driver in Ubuntu 9.10

    tormod, could you explain how to use the code you provided? I'm new to Linux. I know how to use the terminal but I think you're talking about something else and I don't know how/where to use it.

    Thanks
    Q6600 Quad Core @2.4GHz, 1333MHz FSB, 4GB DDR1066 DDR2

  9. #9
    Join Date
    Sep 2007
    Location
    Glasgow UK
    Beans
    15
    Distro
    Ubuntu 7.04 Feisty Fawn

    Re: Troubleshooting the radeon driver in Ubuntu 9.10

    Quote Originally Posted by Kill Vista View Post
    tormod, could you explain how to use the code you provided? I'm new to Linux. I know how to use the terminal but I think you're talking about something else and I don't know how/where to use it.

    Thanks
    The solution is easy - don't need to use terminal.

    Turn visual effects off, it works immediately.
    right-Click on any area on your desktop, get pop-up window, select "change desktop background",
    select "Visual Effects", select "None",
    fixes it!

  10. #10
    Join Date
    Nov 2008
    Location
    a van down by the river
    Beans
    312
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Troubleshooting the radeon driver in Ubuntu 9.10

    Quote Originally Posted by philferrar View Post
    The solution is easy - don't need to use terminal.

    Turn visual effects off, it works immediately.
    right-Click on any area on your desktop, get pop-up window, select "change desktop background",
    select "Visual Effects", select "None",
    fixes it!

    yes, but I want to keep visual effects enabled. I don't want the problem to go away because I turned off the feature that's not working. I want to fix that feature and keep using it.
    Q6600 Quad Core @2.4GHz, 1333MHz FSB, 4GB DDR1066 DDR2

Page 1 of 7 123 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •