Page 4 of 4 FirstFirst ... 234
Results 31 to 38 of 38

Thread: Strange Networking in Karmic

  1. #31
    Join Date
    Feb 2006
    Location
    Hatboro, PA
    Beans
    2,551
    Distro
    Ubuntu Development Release

    Re: Strange Networking in Karmic

    It's still somewhat intermittent, but better. This has to be a wpa_supplicant issue because my work uses WEP and that's fine. I'd switch to that, but have read far too much about the WEP security issues.
    Asus EeePC 1005HA: ElementaryOS Luna | Asus X501A: Windows 8.1 & Ubuntu GNOME 14.10 Utopic Unicorn | Apple iMac G4: Ubuntu 12.04 Precise Pangolin | LG Optimus F3: Stock v7 | Nexus 10 Cyanogenmod 11

  2. #32
    Join Date
    Nov 2009
    Beans
    1
    Distro
    Ubuntu 9.10 Karmic Koala

    Talking Re: Strange Networking in Karmic

    Just like everyone else, my Ubuntu 9.10 internet has suddenly became very unstable. It worked fine for a week and a half and then out of the blue, it got crazy. I finally figured out something that works for me. It might work for you too.

    Here's the wireless card I'm using:
    Realtek RTL8187B Wireless 802.11g 54Mbps Network Adapter

    So what I did was manually set my DNS server settings. Using Wicd, I went into:

    Preferences > General Settings

    I checked the box 'Use global DNS servers.' Then I manually put in the DNS servers as they were listed in my wireless router. Under External Programs Tab, everything is set to Automatic. Under Advanced Settings, my WPA Supplicant Driver is wext and my Backend is set to external.

    Then, I went back and refreshed the local networks. I went into the properties for the network I'm connecting to. 'Use Static DNS' is checked. 'Use global DNS servers' is checked. 'Use Encryption' is checked and I have my network password entered.

    Once I did this and connected, everything started working perfectly. I hope it keeps working. If you're at the end of your rope you might give it a try.

    ---

    Specifically what my internet was doing:

    I could ping, wget, download ubuntu updates, and use the sofware center, but I couldn't use my browser. I tried firefox and seamonkey - both wouldn't work. Some websites would occasionally work. It seems like I could always go to getbrushes.com, but I could never make it to facebook, hotmail, or google. The browser would just keep trying to connect or transfer data but would never finish.
    Last edited by harvestall; November 21st, 2009 at 03:51 AM.

  3. #33
    Join Date
    Nov 2009
    Location
    Mexico
    Beans
    25
    Distro
    Ubuntu 9.10 Karmic Koala

    Post Re: Strange Networking in Karmic

    Unfortunately, this is not my case. My problem is very different. I can do everything that has to do with the internet but suddenly gets disconnected.

    I was playing all day with madwifi with no success. I think this is not my path to follow. I'm gonna give compat-drivers a shot and then I'll post the results.

    Until then,
    X-TBT a.k.a. The Mentor.

  4. #34
    Join Date
    Nov 2009
    Location
    Mexico
    Beans
    25
    Distro
    Ubuntu 9.10 Karmic Koala

    Exclamation Re: Strange Networking in Karmic

    [IMPORTANT UPDATE]
    Well people, I'm very exited because I think I finally [SOLVE] my wireless problem under Ubuntu.

    After doing several things, from changing the encryption scheme of both of my AP's, to blacklisting the ath*k drivers originally installed and installing Madwifi, I lead to a thread that gave me the solution.

    I'm going to divide the post in four parts, my equipment, the initial problem, everything I did to try to fix it, and the final solution.

    <EQUIPMENT>
    Laptop: ACER ASPIRE 5536
    Wireless Adapter: Atheros AR928X
    Wireless AP 1: 2Wire HT-2701 (DSL Wireless Router)
    Wireless AP 2: Netgear CG814GCMR (Cable Wireless Router)

    <INITIAL PROBLEM>

    Everything started since I fresh-installed Ubuntu 9.10 x64 in my laptop (After fresh-installing Win7).
    *NOTE1: Both of my AP's had WEP (I was too lazy to change the default).
    *NOTE2: No problems at all with Win7 when I was configuring it/installing the software, updating it, downloading things, watching youtube, etc, etc.
    Since the first boot into Ubuntu, I started to notice some strange behaviour with my wireless connections, the signal went crazy sometimes going down from 85% to 10% with no reason, and then going back to 80%, and after an hour or so it suddenly disconnected ... no matter how far I was from the AP. Sometimes I couldn't even reconnect, like if I just turned off the adapter, giving me the only option of restarting the system. Sometimes, network manager kept asking me for the WEP key.

    <EVERY TEST I TRIED>
    After following the suggestions of some users of this glorious forum, I did the following:

    1) Change auth/enc from WEP to WPA:
    I did it on both of my AP's (from now on AP1 and AP2, look under <EQUIPMENT>). I set AP1 to WPA and AP2 to WPA2. I notice a difference in AP1, as I could stay connected a whole night without a single problem, but, I had to stay no more than 20 meters away. The speed was even better using WAP on AP1, even in Win7. I didn't see any difference in AP2, things were just the same like when it was WEP (good in Win7, bad in Ubuntu). So, since the results where unacceptable I changed AP2 to WAP too and see if I could stay connected several hours like with AP1, but no success.

    *NOTE: I have to mention that I notice a gain of speed on both wireless when I changed them from WEP to WPA. You should give it a try if you still have WEP. Also take in mind that WEP is less secure.

    2) Replace Network-Manager with Wicd:
    I didn't see any difference by doing this, but I have to say that Wicd has better interface and also, has better network management. It's even more organized so I really recommend it. As I say, it didn't solve anything for my wireless problem but at least I found a better choice.

    * EDIT: Before leading to the final solution described at the end, I was trying to connect to my wired network using Network-Manager (I had to switch back from Wicd to Network-Manager to make some tests) and I had some troubles to make it recognize my network. I connected the cable and nothing happened, like if my Ethernet was turned off, very odd. So I really recommend that you give Wicd a try.

    3) Replace the ath9k drivers with the Madwifi-ng drivers:
    No luck at all, the wireless adapter was not even detected. I tried to read the Madwifi documentation to see the compatibility list but they were having some server problems (a lot of 404 errors). I check and recheck my installation, the modules were loaded like they had to, so my bet is that my adapter is not yet supported by Madwifi, period. I even went back to Network-Manager (just to see if miracles exist ) but no luck at all. I had to revert changes and reload ath9k drivers.

    4) Again, replace Network-Manager because of some problems with my wired network, like I wrote in the edit before.

    <FINAL SOLUTION>
    Reading some other threads I had two more things to do. Try the compat-wireless drivers or go back to Intrepid. But suddenly I saw a post where someone said to just install linux-backports-modules-karmic and that would fix the problem. So, I gave it a try, anyway, I had nothing to loose.

    I went to Synaptics and installed linux-backports-modules-karmic, restarted the system and ... let me see where's the difference ... same modules, Wicd is acting normal, no error messages, no difference at all so I connected to my AP2 (The more problematic one) and started to watch some videos on Youtube. The signal seems a little more weak than before but surprisingly it is stable as hell (30 mts away and 41%-48%, it's pretty good considering the signal has to travel through some doors, some walls, go outside, get up some stairs, another door and then my lap). I decided to make a final test, leave it connected while I sleep.

    Well, I left it at 10pm of yesterday. I woke up now, at 5am to go to the bathroom, raise the lid and WHALA!!! it's still connected. You can't imagine how good I feel. Now I'm going to have sweet dreams.

    Sorry if it was so long but I did it so I can help someone else with the same problem. I hope this post helps some souls out there and please, always post your result no matter the problem, no matter the method, so we can all help each other.

    Sorry for the long post but I had to,
    Sincerely,
    X-TBT a.k.a. The Mentor.

  5. #35
    Join Date
    Feb 2006
    Location
    Hatboro, PA
    Beans
    2,551
    Distro
    Ubuntu Development Release

    Re: Strange Networking in Karmic

    XTBT: That's great! Unfortunately, for me, nothing I do can solve the problem; everything's only a stop-gap measure. For example if I do the following my network is minorly more stable, but still suffers intermittent drops:

    1. install linux-backports-modules-karmic
    2. install bind9 and set the line nameserver 127.0.0.1 in /etc/resolv.conf
    3. change router to WPA-TKIP rather than WPA2-PSK (AES)
    4. statically set ip
    5. uninstall couchdb (according to some of the other conversations I was in it seemed to be causing some kind of problem
    6. make all necessary changes to /etc/nsswitch.conf dealing with mdns4_minimal and mdns4

    Not quite sure how Karmic's a "release candidate" if these problems still persist. A quick perusal of Launchpad shows many similar issues, so it's not "just us."
    Asus EeePC 1005HA: ElementaryOS Luna | Asus X501A: Windows 8.1 & Ubuntu GNOME 14.10 Utopic Unicorn | Apple iMac G4: Ubuntu 12.04 Precise Pangolin | LG Optimus F3: Stock v7 | Nexus 10 Cyanogenmod 11

  6. #36
    Join Date
    Nov 2009
    Location
    Mexico
    Beans
    25
    Distro
    Ubuntu 9.10 Karmic Koala

    Question Re: Strange Networking in Karmic

    Quote Originally Posted by moore.bryan View Post
    XTBT: That's great! Unfortunately, for me, nothing I do can solve the problem; everything's only a stop-gap measure. For example if I do the following my network is minorly more stable, but still suffers intermittent drops:

    1. install linux-backports-modules-karmic
    2. install bind9 and set the line nameserver 127.0.0.1 in /etc/resolv.conf
    3. change router to WPA-TKIP rather than WPA2-PSK (AES)
    4. statically set ip
    5. uninstall couchdb (according to some of the other conversations I was in it seemed to be causing some kind of problem
    6. make all necessary changes to /etc/nsswitch.conf dealing with mdns4_minimal and mdns4

    Not quite sure how Karmic's a "release candidate" if these problems still persist. A quick perusal of Launchpad shows many similar issues, so it's not "just us."
    moore.bryan: Did you already try the new Madwifi drivers ??? In my case those didn't help maybe because of some kind of incompatibility but you might as well have good luck with them. What's the Adapter you're having trouble with?

  7. #37
    Join Date
    Feb 2006
    Location
    Hatboro, PA
    Beans
    2,551
    Distro
    Ubuntu Development Release

    Re: Strange Networking in Karmic

    Quote Originally Posted by xtbt View Post
    moore.bryan: Did you already try the new Madwifi drivers ??? In my case those didn't help maybe because of some kind of incompatibility but you might as well have good luck with them. What's the Adapter you're having trouble with?
    Yeah, already tried them without success. In Madwifi's defense, though, the Thinkpad I use never liked those drivers.
    Asus EeePC 1005HA: ElementaryOS Luna | Asus X501A: Windows 8.1 & Ubuntu GNOME 14.10 Utopic Unicorn | Apple iMac G4: Ubuntu 12.04 Precise Pangolin | LG Optimus F3: Stock v7 | Nexus 10 Cyanogenmod 11

  8. #38

    Smile Re: Strange Networking in Karmic

    Quote Originally Posted by lokutus25 View Post
    My situation is eeePC 1101HA with a fresh install of Karmic. The WiFi Adapter is Atheros AR9285 and my problem is the same as yours...very slow network speed.
    I read about an IPV6 problem...is there a useful thread?
    Well I also have an EEE 1101 HA. Had the same problem. The problem has not come back after I installed Wicd according to this article:

    http://ricardocabello.com/blog/post/679

    Nalle Berg
    ./nalle.

Page 4 of 4 FirstFirst ... 234

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •