Page 8 of 33 FirstFirst ... 67891018 ... LastLast
Results 71 to 80 of 328

Thread: Howto: Utilise the svn MPlayer to Improve Karmic Koala's 'mplayer-nogui' Package

  1. #71
    Join Date
    Mar 2007
    Location
    Seoul, South Korea
    Beans
    8
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Howto: Utilise the svn MPlayer to Improve Karmic Koala's 'mplayer-nogui' Package

    This dosn't work for me:

    Code:
    $ sudo apt-get install ladspa-sdk libaa1-dev libasound2-dev libatk1.0-dev \
    libaudio-dev libaudio2 libaudiofile-dev libavahi-client-dev libavahi-common-dev \
    libcaca-dev libcairo2-dev libcdparanoia-dev libcelt0 libdbus-1-dev libdc1394-22 \
    libdca-dev libdca0 libdirectfb-dev libdirectfb-extra libdts-dev libesd0-dev \
    libexpat1-dev  libffado1 libfontconfig1-dev libfreebob0 libfreetype6-dev \
    libfribidi-dev libgif-dev libgl1-mesa-dev libglib2.0-dev libglu1-mesa-dev \
    libgsm1 libgtk2.0-dev libice-dev libjack-dev libjack0 libjpeg62-dev liblzo2-2 \
    liblzo2-dev libmail-sendmail-perl libncurses5-dev libogg-dev liboil0.3-dev \
    libopenal-dev libopenal1 libpango1.0-dev libpixman-1-dev libpng12-dev \
    libpthread-stubs0 libpthread-stubs0-dev libpulse-dev libruby1.8 \
    libschroedinger-dev libsdl1.2-dev libslang2-dev libsm-dev libsmbclient-dev \
    libspeex-dev libsvga1 libsvga1-dev libsys-hostname-long-perl libsysfs-dev \
    libtheora-dev libvorbis-dev libvorbisidec-dev libvorbisidec1 libx11-dev libxau-dev \
    libxcb-render-util0-dev libxcb-render0-dev libxcb1-dev libxcomposite-dev \
    libxcursor-dev libxdamage-dev libxdmcp-dev libxext-dev libxfixes-dev libxft-dev \
    libxi-dev libxinerama-dev libxml++2.6-2 libxrandr-dev libxrender-dev libxt-dev \
    libxv-dev libxvidcore4 libxvidcore4-dev libxvmc-dev libxxf86dga-dev libxxf86vm-dev \
    mesa-common-dev vstream-client-dev x11proto-composite-dev x11proto-core-dev \
    x11proto-damage-dev x11proto-fixes-dev x11proto-input-dev x11proto-kb-dev \
    x11proto-randr-dev x11proto-render-dev x11proto-video-dev x11proto-xext-dev \
    x11proto-xf86dga-dev x11proto-xf86vidmode-dev x11proto-xinerama-dev xtrans-dev \
    zlib1g-dev libopencore-amrwb-dev libopencore-amrnb-dev
    It just outputs:
    Code:
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:
    
    The following packages have unmet dependencies:
      libgl1-mesa-dev: Depends: libgl1-mesa-glx (= 7.6.0-1ubuntu4) but 7.6.1~git20091107.9348ac03-0ubuntu0~xup~1 is to be installed
      libglu1-mesa-dev: Depends: libglu1-mesa (= 7.6.0-1ubuntu4) but 7.6.1~git20091107.9348ac03-0ubuntu0~xup~1 is to be installed
    E: Broken packages
    How can I get around this? I'm running x64, btw.

  2. #72
    Join Date
    Jan 2007
    Beans
    Hidden!

    Re: Howto: Utilise the svn MPlayer to Improve Karmic Koala's 'mplayer-nogui' Package

    Quote Originally Posted by zanadou View Post
    This dosn't work for me:

    Code:
    $ sudo apt-get install ladspa-sdk libaa1-dev libasound2-dev libatk1.0-dev \
    libaudio-dev libaudio2 libaudiofile-dev libavahi-client-dev libavahi-common-dev \
    libcaca-dev libcairo2-dev libcdparanoia-dev libcelt0 libdbus-1-dev libdc1394-22 \
    libdca-dev libdca0 libdirectfb-dev libdirectfb-extra libdts-dev libesd0-dev \
    libexpat1-dev  libffado1 libfontconfig1-dev libfreebob0 libfreetype6-dev \
    libfribidi-dev libgif-dev libgl1-mesa-dev libglib2.0-dev libglu1-mesa-dev \
    libgsm1 libgtk2.0-dev libice-dev libjack-dev libjack0 libjpeg62-dev liblzo2-2 \
    liblzo2-dev libmail-sendmail-perl libncurses5-dev libogg-dev liboil0.3-dev \
    libopenal-dev libopenal1 libpango1.0-dev libpixman-1-dev libpng12-dev \
    libpthread-stubs0 libpthread-stubs0-dev libpulse-dev libruby1.8 \
    libschroedinger-dev libsdl1.2-dev libslang2-dev libsm-dev libsmbclient-dev \
    libspeex-dev libsvga1 libsvga1-dev libsys-hostname-long-perl libsysfs-dev \
    libtheora-dev libvorbis-dev libvorbisidec-dev libvorbisidec1 libx11-dev libxau-dev \
    libxcb-render-util0-dev libxcb-render0-dev libxcb1-dev libxcomposite-dev \
    libxcursor-dev libxdamage-dev libxdmcp-dev libxext-dev libxfixes-dev libxft-dev \
    libxi-dev libxinerama-dev libxml++2.6-2 libxrandr-dev libxrender-dev libxt-dev \
    libxv-dev libxvidcore4 libxvidcore4-dev libxvmc-dev libxxf86dga-dev libxxf86vm-dev \
    mesa-common-dev vstream-client-dev x11proto-composite-dev x11proto-core-dev \
    x11proto-damage-dev x11proto-fixes-dev x11proto-input-dev x11proto-kb-dev \
    x11proto-randr-dev x11proto-render-dev x11proto-video-dev x11proto-xext-dev \
    x11proto-xf86dga-dev x11proto-xf86vidmode-dev x11proto-xinerama-dev xtrans-dev \
    zlib1g-dev libopencore-amrwb-dev libopencore-amrnb-dev
    It just outputs:
    Code:
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:
    
    The following packages have unmet dependencies:
      libgl1-mesa-dev: Depends: libgl1-mesa-glx (= 7.6.0-1ubuntu4) but 7.6.1~git20091107.9348ac03-0ubuntu0~xup~1 is to be installed
      libglu1-mesa-dev: Depends: libglu1-mesa (= 7.6.0-1ubuntu4) but 7.6.1~git20091107.9348ac03-0ubuntu0~xup~1 is to be installed
    E: Broken packages
    How can I get around this? I'm running x64, btw.
    Enable medibuntu repos and check all the repos in synaptic.

  3. #73
    Join Date
    Mar 2007
    Location
    Seoul, South Korea
    Beans
    8
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Howto: Utilise the svn MPlayer to Improve Karmic Koala's 'mplayer-nogui' Package

    Quote Originally Posted by Arup View Post
    Enable medibuntu repos and check all the repos in synaptic.
    Hmm, I have "deb http://packages.medibuntu.org/ karmic free non-free" in my sources.list, I've updated and it still gives the same error. From Synaptic, when I go to install "libgl1-mesa-dev", it gives me a similar error:
    Code:
    libgl1-mesa-dev:
      Depends: libgl1-mesa-glx (=7.6.0-1ubuntu4) but 7.6.1~git20091107.9348ac03-0ubuntu0~xup~1 is to be installed
    Why the hell is it talking about a git version??

  4. #74
    Join Date
    Jun 2007
    Beans
    13,481

    Re: Howto: Utilise the svn MPlayer to Improve Karmic Koala's 'mplayer-nogui' Package

    Why the hell is it talking about a git version??
    You apparently have updated those libs past the karmic versions, most likely thru a ppa and then removed/disabled the source.

    (and not that long ago, look at the date

    Your best bet, considering the libs involved, is to re-enable the source, update and then proceed.

    This seems like a possible ppa where you may have got the updated mesa libs

    https://launchpad.net/~ubuntu-x-swat...ates/+packages

  5. #75
    Join Date
    Dec 2006
    Beans
    7,107

    Re: Howto: Utilise the svn MPlayer to Improve Karmic Koala's 'mplayer-nogui' Package

    Hi viking_maniac,

    Quote Originally Posted by viking_maniac View Post
    I've decided to try this guide out!

    I have one question though: when you are about to compile this, is it possible to make your own deb or any sort of package that makes is easier to install again later? Or do you need to enter all these commands each time you install?
    I hope you have fun with the guide, it is a fascinating exercise to build a program like this from source . The guide uses checkinstall to create a debian package that you can save if you wish for reinstallation later but it is often a better idea to return to the MPlayer source every week or so and issue the command svn up and then recompile to gain improvements and new functionality.

    All the best,

    Andrew
    You think that's air you're breathing now?

  6. #76
    Join Date
    Nov 2009
    Beans
    5

    Question Re: Howto: Utilise the svn MPlayer to Improve Karmic Koala's 'mplayer-nogui' Package

    Hi Andrew a couple of questions if I may

    I was wondering why Gecko rather than the mplayer mozilla plugin ?
    From what I can see in mozilla's plugins they both seam to serve the same media types.

    On a slightly different tack why mplayer rather than VLC ?
    I have no real preference so long as it works .....

    Would appreciate your guidance so I dont mess my system up again. PM would be fine if you prefer so as not to fill up the forum.

    Thanks

  7. #77
    Join Date
    Dec 2006
    Beans
    7,107

    Re: Howto: Utilise the svn MPlayer to Improve Karmic Koala's 'mplayer-nogui' Package

    Hi drew,

    Quote Originally Posted by drewlong View Post
    I was wondering why Gecko rather than the mplayer mozilla plugin ? From what I can see in mozilla's plugins they both seam to serve the same media types.
    The same man created both plugins. The MPlayer plugin was last released on June 24th 2008 while the gecko-mediaplayer was last released on September of this year. So or me this was an easy choice .

    On a slightly different tack why mplayer rather than VLC ?
    I have no real preference so long as it works .....
    They are certainly 2 sides of the same coin but attract a subtly different clientele. Perhaps try vlc first before launching into MPlayer, it may very well meet all of your needs without the pain of compiling . The version in the Ubuntu repositories is more than reasonable...

    Would appreciate your guidance so I dont mess my system up again.
    I still mess my own system from time to time so perhaps you are talking to the wrong person .

    Andrew
    You think that's air you're breathing now?

  8. #78
    Join Date
    Nov 2005
    Location
    Bordeaux, France
    Beans
    11,297
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Howto: Utilise the svn MPlayer to Improve Karmic Koala's 'mplayer-nogui' Package

    Quote Originally Posted by drewlong View Post
    On a slightly different tack why mplayer rather than VLC ?
    I have no real preference so long as it works .....
    VLC is much more complicated to compile than MPlayer, so if you want the latest codecs, MPlayer is a better choice. However, if you don't feel the need to compile, both are pretty much equivalent, the only differences I can remember being that VLC doesn't support VDPAU (yet), and MPlayer does not support playing a DVD directly from an ISO, and has also very poor support for some MKV features like subchapters (though on this, both are quite poor and don't support the most advanced of them, like ordered chaptering and editions).
    「明後日の夕方には帰ってるからね。」


  9. #79
    Join Date
    Jan 2007
    Beans
    Hidden!

    Re: Howto: Utilise the svn MPlayer to Improve Karmic Koala's 'mplayer-nogui' Package

    Plus for nvidia users, there is no vdpau support in VLC yet so it makes sense to use mplayer.

  10. #80
    Join Date
    Nov 2009
    Beans
    5

    Re: Howto: Utilise the svn MPlayer to Improve Karmic Koala's 'mplayer-nogui' Package

    thanks guys

Page 8 of 33 FirstFirst ... 67891018 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •