Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 22

Thread: USB and external HD not mounting

  1. #11
    Join Date
    Jan 2008
    Location
    Coventry, England
    Beans
    484
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: USB and external HD not mounting

    I think some people are missing the point, but I know exactly what the OP is talking about as I have the same issue with my WD "My Passport" external hard drive.

    Yes; it is powered through the USB. And yes; some USBs don't provide enough juice to power them. But My WD hard drive has worked on my laptop ever since I got it in both Windows and Jaunty. I upgraded from Jaunty to Karmic earlier on this week and the WD passport hard drive no longer automagically mounts.

    The drive is connected though as I can see it when I type lsusb into the command line, and I have written an alias to mount it to the same location that it would normally be mounted. But the point is that it is strange that Karmic no longer does what older versions of Ubuntu did!

    To make matters more complicated, I have two different computers using Ubuntu - my home desktop and my personal work-related laptop. I upgraded both from Jaunty to Karmic on the same day but the WD passport auto mounts on my desktop but not my laptop and I cannot fathom what the difference is. (At the expense of labouring the point, I feel I have to reiterate that the WD drive would automount under Jaunty but not Karmic so laptop hardware is not the issue.)


    As an addendum, as the OP has already said, these WD external drives do make a slight "clicky" sound when they are first connected. This seems quite normal and they do it from day one; an imminent hard drive fail is not the issue.


    EDIT: I forgot to mention that this is actually problem I have generally in Karmic with *ALL* external storage devices, including USB flash drives and external hard drives, but again only seems to affect the laptop, not desktop.
    Last edited by Lateralis; October 31st, 2009 at 03:20 PM. Reason: Added something at the end of post

  2. #12
    Join Date
    Feb 2008
    Location
    Lancashire, UK
    Beans
    Hidden!
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: USB and external HD not mounting

    Quote Originally Posted by Lateralis View Post
    I think some people are missing the point, but I know exactly what the OP is talking about as I have the same issue with my WD "My Passport" external hard drive.
    Yes; it is powered through the USB. And yes; some USBs don't provide enough juice to power them. But My WD hard drive has worked on my laptop ever since I got it in both Windows and Jaunty. I upgraded from Jaunty to Karmic earlier on this week and the WD passport hard drive no longer automagically mounts.
    It would seem that you have a different problem, but I fail to see how that means "the point" has been "missed" when the OP reported that lack of power was indeed the problem in his case and all is now well. It's his thread, his problem, and it is now solved - and he made no mention of it being related to Karmic, which is a different issue altogether.

  3. #13
    Join Date
    Nov 2007
    Beans
    1

    Re: USB and external HD not mounting

    Quote Originally Posted by Lateralis View Post
    I think some people are missing the point, but I know exactly what the OP is talking about as I have the same issue with my WD "My Passport" external hard drive.

    Yes; it is powered through the USB. And yes; some USBs don't provide enough juice to power them. But My WD hard drive has worked on my laptop ever since I got it in both Windows and Jaunty. I upgraded from Jaunty to Karmic earlier on this week and the WD passport hard drive no longer automagically mounts.

    The drive is connected though as I can see it when I type lsusb into the command line, and I have written an alias to mount it to the same location that it would normally be mounted. But the point is that it is strange that Karmic no longer does what older versions of Ubuntu did!
    I am also unable to mount my WD passport drive since installing Karmic. Worked fine in Jaunty and also mounts OK in Windows on same PC. I can mount powered external HDs.

    How do you create an alias to mount the drive please?

  4. #14
    Join Date
    Nov 2009
    Beans
    1

    Unhappy Re: USB and external HD not mounting

    I think I experience the same problem: I cannot mount my "WD MyBook Premium" usb drive after updating from 9.04 to 9.10. Its not a bus powered model.

    The drive doesn't show up in the Palimpsest Disk tool.

    Please help me solv ethe problem as I am quite new to Linux.

  5. #15
    Join Date
    Jan 2008
    Location
    Coventry, England
    Beans
    484
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: USB and external HD not mounting

    Quote Originally Posted by John Bean View Post
    It would seem that you have a different problem, but I fail to see how that means "the point" has been "missed" when the OP reported that lack of power was indeed the problem in his case and all is now well. It's his thread, his problem, and it is now solved - and he made no mention of it being related to Karmic, which is a different issue altogether.
    Ah, my apologies... I know this is no excuse, but I had read the thread in a bit of a rush as I was getting ready to leave the house and managed to miss yodal's post saying he had solved the problem by using a powered USB. After reading yodal's first post I assumed our issues were related and thus other people's suggestions were missing the point. I now see that is not the case so I offer my sincerest apologies for my rashness and the tone of the message. My intention was never to cause offence.

    But, that being said, it does look like there is a problem with some Karmic upgrades as I am apparently not alone. I did in fact create a thread about this last week after I upgraded but no one seemed interested at the time, although other threads seem to have garnered some attention.

  6. #16
    Join Date
    Feb 2008
    Location
    Lancashire, UK
    Beans
    Hidden!
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: USB and external HD not mounting

    Quote Originally Posted by Lateralis View Post
    Ah, my apologies...
    Not needed, but appreciated none the less

    But, that being said, it does look like there is a problem with some Karmic upgrades as I am apparently not alone.
    I agree. I have tried Karmic and abandoned it; it has IMO far too many major changes in a single release leading to incompatibilities, new bugs and apparent resurfacing of old bugs whose work-arounds no longer work compounded by insufficient knowledge about the new internals for the average desktop user to get a handle on where to even start looking.

    I'm sure there are many new users who will love it but for existing users it's got to be the most troublesome update of Ubuntu so far. I'll stay with Jaunty until at least next April...

  7. #17
    Join Date
    Jan 2009
    Beans
    20

    Re: USB and external HD not mounting

    Hi guys,
    I v been on the post since yesterday trying everything that has been said so but I am stuck, I cannot mount my pendrive at all, they all used to work on 9.04 but not anymore.
    I have 2 external hard drive, with external power, automount fine, one of them has limited transfer speed, only 1Mo/s when the other work as usual. I have a few usb sticks that are all working on windows/ubuntu 9.04 but absolutely nothing on 9.10.I cannot see them.
    My keyboard/usb are fine, wifi dongle ok, bluetooh dongle perfect, my nokia 5800 no problem at all.
    I am really confused....
    Please help.

  8. #18
    Join Date
    Jan 2009
    Beans
    20

    Re: USB and external HD not mounting

    Hi guys,
    I v been on the post since yesterday trying everything that has been said so but I am stuck, I cannot mount my pendrive at all, they all used to work on 9.04 but not anymore.
    I have 2 external hard drive, with external power, automount fine, one of them has limited transfer speed, only 1Mo/s when the other work as usual. I have a few usb sticks that are all working on windows/ubuntu 9.04 but absolutely nothing on 9.10.I cannot see them.
    My keyboard/usb are fine, wifi dongle ok, bluetooh dongle perfect, my nokia 5800 no problem at all.
    I am really confused....
    Please help.

  9. #19
    Join Date
    Jan 2008
    Location
    Coventry, England
    Beans
    484
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: USB and external HD not mounting

    Quote Originally Posted by John Bean View Post
    I agree. I have tried Karmic and abandoned it; it has IMO far too many major changes in a single release leading to incompatibilities, new bugs and apparent resurfacing of old bugs whose work-arounds no longer work compounded by insufficient knowledge about the new internals for the average desktop user to get a handle on where to even start looking.

    I'm sure there are many new users who will love it but for existing users it's got to be the most troublesome update of Ubuntu so far. I'll stay with Jaunty until at least next April...
    Yeah, I quite agree with that. I'm not saying that Canonical and the Ubuntu team shouldn't set ambitious targets, but I think they've done a bit of a Microsoft job with this update. In particular, I did a fresh install of Karmic on my mother's PC over the weekend and I couldn't find some of the GUI options and things that I was used to in every other edition of Ubuntu.

    I'm sure new people will love it, but for seasoned users it feels like a step backwards rather than forwards. =(

    I will persevere with it as I fancy the challenge! But I am quite disappointed and I don't blame you for changing back to Jaunty; I have considered it!

  10. #20
    Join Date
    Jun 2008
    Beans
    2

    Re: USB and external HD not mounting

    Quote Originally Posted by Lateralis View Post
    Yeah, I quite agree with that. I'm not saying that Canonical and the Ubuntu team shouldn't set ambitious targets, but I think they've done a bit of a Microsoft job with this update. In particular, I did a fresh install of Karmic on my mother's PC over the weekend and I couldn't find some of the GUI options and things that I was used to in every other edition of Ubuntu.

    I'm sure new people will love it, but for seasoned users it feels like a step backwards rather than forwards. =(

    I will persevere with it as I fancy the challenge! But I am quite disappointed and I don't blame you for changing back to Jaunty; I have considered it!
    I am glad you said that, and that it isn't just me. I had Hardy Heron and upgraded through 8.10 to Karmic, and I'm finding it very disappointing - a bit of a lame duck. Shame. Would Jaunty Jackalope allow me to see these drives? Thank you for your advice.
    Last edited by maldonsailor; December 9th, 2009 at 01:49 AM. Reason: typos

Page 2 of 3 FirstFirst 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •