Results 1 to 8 of 8

Thread: 9.10 Installation Graphics Problem (Intel)

Hybrid View

  1. #1
    Join Date
    Oct 2009
    Beans
    30

    9.10 Installation Graphics Problem (Intel)

    Hello.

    RESUME:
    To make ubuntu installer shows up in intel graphics: add "nomodeset" to parameters (F6).
    To make ubuntu shows up after install, add "nomodeset" in /boot/grub/grub.conf like this:
    linux /boot/vmlinuz-2.6.31-14-generic nomodeset root=UUID=f2fbc756-0f16-434b-90b1-9a740040b6e3 ro quiet splash
    To make ubuntu identify the correct graphic card, edit /etc/X11/xorg.conf like this:
    Driver "intel"

    THE WHOLE HISTORY:

    I'm installing ubuntu 9.10 desktop amd64.
    The new version of ubuntu installer did not recognized my graphics card, which is Intel GMA 4500MHD. The CD booter shows up, but I could not pass to test the disk, or to test ubuntu with no install nither installer was not showing up (but it was loading).
    What happen is that a strange thing splashes in the screen, and then all gets black, and still black. EVEN WITH SAFE GRAPHICS MODE.
    I got EXACTLY the same problem installing FEDORA 11 x86_64 (anaconda) (didn't tryed other versions). So I will explain how I did in fedora, and how I did in ubuntu.

    To workaround this problem in Fedora there are two alternatives:
    The first one is to use the safe graphics mode. By this way, the installers shows up with the basic driver and the video all unconfigured. The instaled OS gets in the same way, but to correct it is easy, just change the file /etc/X11/xorg.conf in the driver line from "vesa" to "intel". Restart the xorg and all working.
    The secod option is to add the following to the installer parameters: "nomodeset --xdriver=intel". This options forces anaconda to use the intel at xorg. The OS installed cames all configured, with no need to correct the problem in xorg.conf, like using safre graphics mode.

    IN UBUNTU you can do this also, since I was without a computer I added the parameters "nomodeset xdriver=intel" (without the --), becouse of this I can tell right now if it will work, but adding nomodeset make it work the installer, now it shows up... BUT when the OS is installed, IT ALSO DID NOT SHOWS UP, we need to boot in live cd (with "nomodeset") and edit the /boot/grub.cfg in the line that says "linux ...", adding the nomodeset there... Also go change in the file /etc/X11/xorg.conf from "vesa" to "intel", if you dont do it, you will need to do it later to make ubuntu use the correct driver for the video card.

  2. #2
    Join Date
    Oct 2009
    Beans
    30

    Re: 9.10 Installation Graphics Problem (Intel)

    No one experiencing the same problem?

  3. #3
    Join Date
    Sep 2009
    Beans
    3

    Re: 9.10 Installation Graphics Problem (Intel)

    I'm having issues with the same graphics card. My issues were outlined here:

    http://www.uluga.ubuntuforums.org/sh....php?t=1306935

    I ran an 'X -configure' and booted off of the xorg.conf, which correctly identified the card as "intel," but still am unable to get a display on the actual laptop screen.

    I've also re-installed the drivers directly from http://intellinuxgraphics.org/ to no avail.

  4. #4
    Join Date
    Oct 2009
    Beans
    30

    Re: 9.10 Installation Graphics Problem (Intel)

    Quote Originally Posted by deosculate View Post
    I'm having issues with the same graphics card. My issues were outlined here:

    http://www.uluga.ubuntuforums.org/sh....php?t=1306935

    I ran an 'X -configure' and booted off of the xorg.conf, which correctly identified the card as "intel," but still am unable to get a display on the actual laptop screen.

    I've also re-installed the drivers directly from http://intellinuxgraphics.org/ to no avail.
    Did you tryed editing the file /etc/X11/xorg.conf ?
    Changing from "vesa" to "intel"?
    (You can do that by live-cd, just add the following to the livecd boot parameters: "nomodeset --xdriver=intel" and should work (works for me)

  5. #5
    Join Date
    Aug 2007
    Location
    Canada
    Beans
    55
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Cool Re: 9.10 Installation Graphics Problem (Intel)

    I've bookmarked this page and will come back to it in 2 months when I give 9.10 another try. I have lost patience to deal with this upgrade. I had high hopes for this upgrade but 9.04 is working fine even with my Intel chipset. I don't any more time to spend on 9.10.

  6. #6
    Join Date
    Nov 2009
    Beans
    14

    Re: 9.10 Installation Graphics Problem (Intel)

    Quote Originally Posted by 3esmit View Post
    Hello.

    RESUME:
    To make ubuntu installer shows up in intel graphics: add "nomodeset" to parameters (F6).
    To make ubuntu shows up after install, add "nomodeset" in /boot/grub/grub.conf like this:
    linux /boot/vmlinuz-2.6.31-14-generic nomodeset root=UUID=f2fbc756-0f16-434b-90b1-9a740040b6e3 ro quiet splash
    To make ubuntu identify the correct graphic card, edit /etc/X11/xorg.conf like this:
    Driver "intel"

    THE WHOLE HISTORY:

    I'm installing ubuntu 9.10 desktop amd64.
    The new version of ubuntu installer did not recognized my graphics card, which is Intel GMA 4500MHD. The CD booter shows up, but I could not pass to test the disk, or to test ubuntu with no install nither installer was not showing up (but it was loading).
    What happen is that a strange thing splashes in the screen, and then all gets black, and still black. EVEN WITH SAFE GRAPHICS MODE.
    I got EXACTLY the same problem installing FEDORA 11 x86_64 (anaconda) (didn't tryed other versions). So I will explain how I did in fedora, and how I did in ubuntu.

    To workaround this problem in Fedora there are two alternatives:
    The first one is to use the safe graphics mode. By this way, the installers shows up with the basic driver and the video all unconfigured. The instaled OS gets in the same way, but to correct it is easy, just change the file /etc/X11/xorg.conf in the driver line from "vesa" to "intel". Restart the xorg and all working.
    The secod option is to add the following to the installer parameters: "nomodeset --xdriver=intel". This options forces anaconda to use the intel at xorg. The OS installed cames all configured, with no need to correct the problem in xorg.conf, like using safre graphics mode.

    IN UBUNTU you can do this also, since I was without a computer I added the parameters "nomodeset xdriver=intel" (without the --), becouse of this I can tell right now if it will work, but adding nomodeset make it work the installer, now it shows up... BUT when the OS is installed, IT ALSO DID NOT SHOWS UP, we need to boot in live cd (with "nomodeset") and edit the /boot/grub.cfg in the line that says "linux ...", adding the nomodeset there... Also go change in the file /etc/X11/xorg.conf from "vesa" to "intel", if you dont do it, you will need to do it later to make ubuntu use the correct driver for the video card.

    nomodeset made my day, but I don't have these 2 files grub.cfg and xorg.conf.
    Can I generate them from the Termial?

    No Wireless enabled also

    Working on these...

  7. #7
    Join Date
    Apr 2009
    Location
    Portsmouth, UK
    Beans
    6
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: 9.10 Installation Graphics Problem (Intel)

    perfect! Even though i didn't have an xorg.conf (apparently not needed in Karmic) , i created it with just what it said in 3esmit's post in the link in deosculate's post.

  8. #8
    Join Date
    Feb 2010
    Beans
    1

    Re: 9.10 Installation Graphics Problem (Intel)

    Same problem on a lenovo Y710, with card identified as intel GM965/GM960 and an ubuntu updated to 9.10 all the way from 8.04.
    No way to have X come up unless the nomodesetting option was added to the kernel boot config...

    ps: for the adventurous: when x did not start, it was possible for me to still log in by entering commands on vconsole 1 (where nothing was displayed, I just blind-typed) and looking at the results on vconsole 7. It went like:
    username + [enter] + password + [enter]
    ctrl+alt+f7 : look if we are logged in
    ctrl+alt+f1, dmesg
    ctrl+alt+f7 : read output
    ctrl+alt+f1, another command
    etc...
    Last edited by ggiunta; February 12th, 2010 at 06:39 PM.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •