Results 1 to 5 of 5

Thread: HOWTO: Automount in karmic

  1. #1
    Join Date
    Apr 2008
    Beans
    131

    HOWTO: Automount in karmic

    I really like the new release, its GR8 in everyway especially that im an intel graphics user so i LOVE how everything works right now its never been better.

    i had a few minor issues and 1 of them was automount on startup.

    Since "Hal" is being deprecated, and ubuntu moved to devicekit-disks, i had a hard time figuring out how to set my drives to autmount on startup like i used to do with editing /etc/hal/fdi/policy/preferences.fdi and setting automount to ture.

    i just found a solution for it, thanks to this

    do this
    Code:
    sudo gedit /lib/udev/rules.d/95-devkit-disks.rules

    at the end BEFORE
    Code:
    LABEL="devkit_disks_end"
    just add
    Code:
    RUN+="/bin/mount -t auto /dev/sda6 /media/Programs"
    of course replace /dev/sda6 with ur drive number and /media/Programs with the mount point u like. repeat for every drive and ur done

    i also added this rule, dunno if its needed, it was supposed to set me as the owner but i still have to enter my pass if i wana unmount and remount a drive again but i dont care...

    Code:
    KERNEL=="/dev/sda[0-9]", OWNER="user"
    FINALLY! found a solution for this it has been bugging me like hell!

    Enjoy

  2. #2
    Join Date
    Sep 2007
    Beans
    31

    Re: HOWTO: Automount in karmic

    Elcid247, thank you very much, works like a charm here.

  3. #3
    Join Date
    Apr 2009
    Beans
    25

    Re: HOWTO: Automount in karmic

    Quote Originally Posted by Elcid247 View Post
    I really like the new release, its GR8 in everyway especially that im an intel graphics user so i LOVE how everything works right now its never been better.

    i had a few minor issues and 1 of them was automount on startup.

    Since "Hal" is being deprecated, and ubuntu moved to devicekit-disks, i had a hard time figuring out how to set my drives to autmount on startup like i used to do with editing /etc/hal/fdi/policy/preferences.fdi and setting automount to ture.

    i just found a solution for it, thanks to this

    do this
    Code:
    sudo gedit /lib/udev/rules.d/95-devkit-disks.rules

    at the end BEFORE
    Code:
    LABEL="devkit_disks_end"
    just add
    Code:
    RUN+="/bin/mount -t auto /dev/sda6 /media/Programs"
    of course replace /dev/sda6 with ur drive number and /media/Programs with the mount point u like. repeat for every drive and ur done

    i also added this rule, dunno if its needed, it was supposed to set me as the owner but i still have to enter my pass if i wana unmount and remount a drive again but i dont care...

    Code:
    KERNEL=="/dev/sda[0-9]", OWNER="user"
    FINALLY! found a solution for this it has been bugging me like hell!

    Enjoy
    Thanks! But I just noticed that 95-devkit-disks.rules says don't edit this file since it will be changed with every update...

  4. #4
    Join Date
    Apr 2008
    Beans
    131

    Re: HOWTO: Automount in karmic

    Quote Originally Posted by OobNosferatu View Post
    Thanks! But I just noticed that 95-devkit-disks.rules says don't edit this file since it will be changed with every update...
    Well a better way turned up, see this


    thanks Alot joeb454!!!!

  5. #5
    Join Date
    Jan 2008
    Beans
    735
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: HOWTO: Automount in karmic

    I am running Lucid, why don't i have this file?

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •