I seem to have a problem with crontab....

when I issue the command
Code:
crontab -e
it opens up the cron file in nano, I have tried both export and setting EDITOR=vim in my .bashrc file and neither is actually making any difference