Page 5 of 6 FirstFirst ... 3456 LastLast
Results 41 to 50 of 53

Thread: Grub 2 - 5 Common Tasks

  1. #41
    Join Date
    Aug 2008
    Location
    South East Montana
    Beans
    6,153

    Re: Grub 2 - 5 Common Tasks

    LucianoP
    What is the path to the image that you want to use? What type of image is it (.png, jpg, etc)? What is the resolution of the image?
    Dell 480 XPS 3G ram Quad Core 2.40GHz, Radeon HD 2400 PRO, Audigy1, 3x320G HDD, 320G External, Debian Testing for use, Debian Squeeze for secure use, Debian Sid for FUN

  2. #42
    Join Date
    Nov 2009
    Location
    São Paulo, Brazil
    Beans
    9
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Grub 2 - 5 Common Tasks

    Quote Originally Posted by ranch hand View Post
    LucianoP
    What is the path to the image that you want to use? What type of image is it (.png, jpg, etc)? What is the resolution of the image?
    hey Ranch
    this is the image I want to use /usr/share/images/grub/Plasma-lamp.tga
    a standard 640x480 pic
    I have reviewed the /etc/grub.d/05_debian_theme but everything looks ok

  3. #43
    Join Date
    Aug 2008
    Location
    South East Montana
    Beans
    6,153

    Re: Grub 2 - 5 Common Tasks

    Try putting it is /usr/share/images/desktop-base and change the path to that folder. I would change the type to .png too. If you do that after putting it in the folder you will have both there and as long as debian-theme is calling for either you should pick it up.

    Run both "update-grub" and "grub-mkconfig" after doing those things.

    I have had a couple installs that didn't seem to like the "grub" images folder. The other is the default.
    Dell 480 XPS 3G ram Quad Core 2.40GHz, Radeon HD 2400 PRO, Audigy1, 3x320G HDD, 320G External, Debian Testing for use, Debian Squeeze for secure use, Debian Sid for FUN

  4. #44
    Join Date
    Nov 2009
    Location
    São Paulo, Brazil
    Beans
    9
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Grub 2 - 5 Common Tasks

    Quote Originally Posted by ranch hand View Post
    Try putting it is /usr/share/images/desktop-base and change the path to that folder. I would change the type to .png too. If you do that after putting it in the folder you will have both there and as long as debian-theme is calling for either you should pick it up.
    None worked
    I also tried to reinstall both grub-pc and grub2-splashimages
    via Synaptic.

    is_path_readable_by_grub: not found is really strange

  5. #45
    Join Date
    Aug 2008
    Location
    South East Montana
    Beans
    6,153

    Re: Grub 2 - 5 Common Tasks

    Quote Originally Posted by LucianoP View Post
    None worked
    I also tried to reinstall both grub-pc and grub2-splashimages
    via Synaptic.

    is_path_readable_by_grub: not found is really strange
    I have only gone that route once as I do not like their images. When you have Gimp you can size and edit just about any image you want to put in there.

    Just for fun copy the file below and paste it to gedit. Save the sucker in your /etc/grub.d directory as 05_debian-theme.new. That is what it is in my box from some upgrade lately.
    #!/bin/bash -e

    source /usr/lib/grub/grub-mkconfig_lib

    # this allows desktop-base to override our settings
    f=/usr/share/desktop-base/grub_background.sh
    if test -e ${f} ; then
    source ${f}
    else
    WALLPAPER="/usr/share/images/desktop-base/menu.png"
    COLOR_NORMAL="white/black"
    COLOR_HIGHLIGHT="red/black"
    fi

    set_mono_theme()
    {
    cat << EOF
    set menu_color_normal=white/black
    set menu_color_highlight=black/white
    EOF
    }

    # check for usable backgrounds
    use_bg=false
    if [ "$GRUB_TERMINAL_OUTPUT" = "gfxterm" ] ; then
    for i in /boot/grub/`basename ${WALLPAPER}` ${WALLPAPER} ; do
    if is_path_readable_by_grub $i ; then
    bg=$i
    case ${bg} in
    *.png) reader=png ;;
    *.tga) reader=tga ;;
    *.jpg|*.jpeg) reader=jpeg ;;
    esac
    if test -e /boot/grub/${reader}.mod ; then
    echo "Found background image: `basename ${bg}`" >&2
    use_bg=true
    break
    fi
    fi
    done
    fi

    # set the background if possible
    if ${use_bg} ; then
    prepare_grub_to_access_device `${grub_probe} --target=device ${bg}`
    cat << EOF
    insmod ${reader}
    if background_image `make_system_path_relative_to_its_root ${bg}` ; then
    set color_normal=${COLOR_NORMAL}
    set color_highlight=${COLOR_HIGHLIGHT}
    else
    EOF
    fi

    # otherwise, set a monochromatic theme for Ubuntu
    if ${use_bg} ; then
    set_mono_theme | sed -e "s/^/ /g"
    echo "fi"
    else
    set_mono_theme
    fi
    Make sure that it is executable and disable all other 005_debian-theme files no matter how they are labeled.

    You will have to edit the image name.

    Update your grub.

    Try that.
    Dell 480 XPS 3G ram Quad Core 2.40GHz, Radeon HD 2400 PRO, Audigy1, 3x320G HDD, 320G External, Debian Testing for use, Debian Squeeze for secure use, Debian Sid for FUN

  6. #46
    Join Date
    Nov 2009
    Location
    São Paulo, Brazil
    Beans
    9
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Grub 2 - 5 Common Tasks

    Hi Ranch,
    Thanks for the tip!
    Now it worked fine


    I noticed these lines were missing in my original 05_debian_theme
    if test -e ${f} ; then
    source ${f}
    else
    WALLPAPER="/usr/share/images/desktop-base/menu.png"
    COLOR_NORMAL="white/black"
    COLOR_HIGHLIGHT="red/black"

  7. #47
    Join Date
    Aug 2008
    Location
    South East Montana
    Beans
    6,153

    Re: Grub 2 - 5 Common Tasks

    Every once in a while grub-common does things like that. Probably because it is supporting both grub and grub-pc (grub-legacy and grub1.9x - I have grub1.96, 1.97beta4, 1.98 and 0.97 on this box).

    The images that you can download are fine but they install another folder in /etc/share/images (grub) and as you can see the default folder is already there.

    With gimp it is easy to resize any image to fit the menu so I just do it that way. The default colors are actually;
    Normal="black/black"
    Highlight="magenta/black"
    but that does not work well for my background on whichever of my installs I swiped that from. I think it is nice to be able to read the menu.

    It is really neat that the image is that easy to change and can be a good image too. Grub0.97 is kind of a pain to put a back ground into and is also limited to 8(!) colors so the image must be pretty simple to render at all.
    Dell 480 XPS 3G ram Quad Core 2.40GHz, Radeon HD 2400 PRO, Audigy1, 3x320G HDD, 320G External, Debian Testing for use, Debian Squeeze for secure use, Debian Sid for FUN

  8. #48
    Join Date
    Jun 2007
    Beans
    52

    Re: Grub 2 - 5 Common Tasks

    But I want the menu to normally not appear.

    So I have;
    GRUB_DEFAULT=0
    GRUB_HIDDEN_TIMEOUT=0
    GRUB_HIDDEN_TIMEOUT_QUIET=true
    GRUB_TIMEOUT="10"

    But I want the menu to appear if I hold down Esc or Shift or something.

    How?

  9. #49
    Join Date
    Jan 2007
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Grub 2 - 5 Common Tasks

    Quote Originally Posted by uid313 View Post
    But I want the menu to normally not appear.

    So I have;
    GRUB_DEFAULT=0
    GRUB_HIDDEN_TIMEOUT=0
    GRUB_HIDDEN_TIMEOUT_QUIET=true
    GRUB_TIMEOUT="10"

    But I want the menu to appear if I hold down Esc or Shift or something.

    How?
    Holding down the SHIFT key should bring up the menu for you.
    GRUB2

    Retired.

  10. #50
    Join Date
    Dec 2008
    Beans
    106

    Re: Grub 2 - 5 Common Tasks

    I edited my grub.cfg and changed my grub_default to
    Code:
    GRUB_DEFAULT="Microsoft Windows XP Home Edition"
    (Note that this was the same entry I got from the grep "menuentry" /boot/grub/grub.cfg) Next I executed a sudo update-grub and restarted my machine. When the menu appeared my first entry with 'Ubuntu, with Linux 2.6.38-8-generic' was highlighted. So nothing changed.

    Next I tried to change my default OS by executing a
    Code:
    sudo grub-set-default 4
    followed again with a sudo update-grub and a restart. Again with the same result. What am I doing wrong?

    Edit: I performed another reboot, and now XP was highlighted. So I was a tad to early with my question.

    However, might it be possible to change the order in which the different choices are displayed? Like XP first?
    Last edited by Macamba; May 6th, 2011 at 12:21 PM.

Page 5 of 6 FirstFirst ... 3456 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •