Page 2 of 6 FirstFirst 1234 ... LastLast
Results 11 to 20 of 53

Thread: Grub 2 - 5 Common Tasks

  1. #11
    Join Date
    Jan 2007
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Grub 2 - 5 Common Tasks

    Quote Originally Posted by 600WPMPO View Post
    so now how do I correct this? Should I put a # before the "vga=XXX" in your /etc/default/grub file ? Will that work ?
    You simply remove the entry in whatever line it appears. It is probably at the end of one of GRUB_CMDLINE... lines. You will then have to set up the resolution within your OS. For Ubuntu, you can probably do so via System, Preferences, Display.

    I don't see a problem with your splash-image location. Most of the images are for 640x480 and if you have your gfxmode set to something other than that I believe G2 has a problem displaying the image.
    GRUB2

    Retired.

  2. #12
    Join Date
    Nov 2008
    Beans
    42
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Grub 2 - 5 Common Tasks

    Quote Originally Posted by drs305 View Post
    You simply remove the entry in whatever line it appears. It is probably at the end of one of GRUB_CMDLINE... lines. You will then have to set up the resolution within your OS. For Ubuntu, you can probably do so via System, Preferences, Display.
    Yes.. that did it.. Now I dont get that vga=792 is deprecated error..!! Thanks a lot..

    My desktop resolution is 1280x1024, but that doesnt make any difference to the grub resolution, does it?

    So, this means that we can only change the grub menu resolution and not the grub (background) resolution which will stay at 640x480... ?



    Quote Originally Posted by drs305 View Post
    I don't see a problem with your splash-image location. Most of the images are for 640x480 and if you have your gfxmode set to something other than that I believe G2 has a problem displaying the image.
    Ok.this problem is also solved..!!

    Instead of putting the splash images in /usr/share/images/desktop-base, I kept them where they were downloaded i.e. usr/share/images/grub , and copied the file as you mentioned :

    Code:
    for i in {/boot/grub,/usr/share/images/desktop-base,/usr/share/images/grub}/xxxxxxxx. {png,tga} ;do

  3. #13
    Join Date
    Jan 2007
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Grub 2 - 5 Common Tasks

    Quote Originally Posted by 600WPMPO View Post
    My desktop resolution is 1280x1024, but that doesnt make any difference to the grub resolution, does it?

    So, this means that we can only change the grub menu resolution and not the grub (background) resolution which will stay at 640x480... ?
    The screen displaying the grub menu and grub images will display a default resolution of 640x480 unless you change it with the GRUB_GFXMODE setting in /etc/default/grub. The image size should match the resolution - if not it will be distorted or not cover the entire screen. Normally if it's too small (640x480 on a 1280x1024 resolution) the image will anchor to the upper left corner of the screen. You would have to create or alter an image of the proper size to fill the screen. GIMP is a default program that can resize these images.

    For troubleshooting the failure to get a splash image to display, take a look at the terminal while "update-grub" runs. Does it find a Debian theme or is nothing at all mentioned. It is normally about the first message after "Generating grub.cfg" the command starts.

    If it finds the image:
    Generating grub.cfg ...
    Found Debian background: sample.tga

    If it doesn't find sample.tga:
    Generating grub.cfg ...
    Found linux image: /boot/vmlinuz-2.6.31-14-generic
    GRUB2

    Retired.

  4. #14
    Join Date
    Aug 2008
    Location
    South East Montana
    Beans
    6,153

    Re: Grub 2 - 5 Common Tasks

    I do this in a crude way but it does work.

    I take the image and put in the fileit needs to be in, in my case desk-top base, and see what it looks like and adjust from there. It helps if the the resolution is 72,000x72,000 as that is what the images are if you get the official package (including the grub folder). My screen is a Dell at 1440x900 and I find a lot of images "almost" fit so I tweek a lot.
    Dell 480 XPS 3G ram Quad Core 2.40GHz, Radeon HD 2400 PRO, Audigy1, 3x320G HDD, 320G External, Debian Testing for use, Debian Squeeze for secure use, Debian Sid for FUN

  5. #15
    Join Date
    Nov 2008
    Beans
    42
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Grub 2 - 5 Common Tasks

    Quote Originally Posted by drs305 View Post
    The screen displaying the grub menu and grub images will display a default resolution of 640x480 unless you change it with the GRUB_GFXMODE setting in /etc/default/grub. The image size should match the resolution - if not it will be distorted or not cover the entire screen. Normally if it's too small (640x480 on a 1280x1024 resolution) the image will anchor to the upper left corner of the screen. You would have to create or alter an image of the proper size to fill the screen. GIMP is a default program that can resize these images.
    That's very correct..

    I've done it now... here's how I changed the Grub background resolution:

    I downloaded a desktop wallpaper of resolution 1024x768 (see attached image).

    I then converted it to .tga format via GIMP.

    Copied this file to /usr/share/images/grub/ where all my splash images reside.

    Changed grub menu resolution to 1024x768

    Updated Grub

    Success..!!


    p.s. One doubt though:

    I have throughout been unsuccessful in changing Grub menu resolution via editing etc/default/grub # GRUB_GFXMODE=640x480. The Grub menu resoultion always stayed at the default 640x480.

    What works for me is editing /etc/grub.d/00_header, and changing “set
    gfxmode=640x480” to my liking.. be it 800x600 or 1024x768.

    If this doesnt cause any harm, it is okay to edit the header?
    Attached Images Attached Images

  6. #16
    Join Date
    Jan 2007
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Grub 2 - 5 Common Tasks

    Quote Originally Posted by 600WPMPO View Post
    p.s. One doubt though:

    I have throughout been unsuccessful in changing Grub menu resolution via editing etc/default/grub # GRUB_GFXMODE=640x480. The Grub menu resoultion always stayed at the default 640x480.

    What works for me is editing /etc/grub.d/00_header, and changing “set
    gfxmode=640x480” to my liking.. be it 800x600 or 1024x768.

    If this doesnt cause any harm, it is okay to edit the header?
    Nice guide on how you made your graphics work.

    You must remove the comment symbol (#) from the start of the GRUB_GFXMODE line. The # symbol tells the script to disregard the line. Remove it, and the line will work.

    You should probably leave the 00_header file the way it was originally. The resolution in there is a "fallback" setting in case nothing else is found. It will certainly work, as you discovered, but GRUB 2 is written for the user to make changes in the /etc/defualt/grub file.

    Try changing 00_header back to it's original state, remove the # symbol from the GFX line in /etc/default/grub, and finally run "sudo update-grub" to incorporate the changes.
    GRUB2

    Retired.

  7. #17
    Join Date
    Nov 2008
    Beans
    42
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Grub 2 - 5 Common Tasks

    Quote Originally Posted by drs305 View Post
    You must remove the comment symbol (#) from the start of the GRUB_GFXMODE line. The # symbol tells the script to disregard the line. Remove it, and the line will work.

    Try changing 00_header back to it's original state, remove the # symbol from the GFX line in /etc/default/grub, and finally run "sudo update-grub" to incorporate the changes.
    I have always removed the #, but it won't work. Here's my /etc/default/grub file:


    Code:
    # If you change this file, run 'update-grub' afterwards to update
    # /boot/grub/grub.cfg.
    
    GRUB_DEFAULT=2
    #GRUB_HIDDEN_TIMEOUT=0
    GRUB_HIDDEN_TIMEOUT_QUIET=true
    GRUB_TIMEOUT=10
    GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
    #GRUB_CMDLINE_LINUX=" splash vga=773"
    
    # Uncomment to disable graphical terminal (grub-pc only)
    #GRUB_TERMINAL=console
    
    # The resolution used on graphical terminal
    # note that you can use only modes which your graphic card supports via VBE
    # you can see them in real GRUB with the command `vbeinfo'
    GRUB_GFXMODE=800x600
    
    
    # Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
    #GRUB_DISABLE_LINUX_UUID=true
    
    # Uncomment to disable generation of recovery mode menu entrys
    #GRUB_DISABLE_LINUX_RECOVERY="true"
    As you can see, I wanted to change the resolution to 800x600, so I made this change, but the grub menu would still stay at 640x480.

    So. I edited the header to a resolution of 1024x768. It worked. I've kept the /etc/default/grub file still at 800x600,as it is not making any difference to me.

    So, any ideas what's going wrong ?
    Last edited by 600WPMPO; November 6th, 2009 at 12:49 PM.

  8. #18
    Join Date
    Jan 2007
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Grub 2 - 5 Common Tasks

    Quote Originally Posted by 600WPMPO View Post
    So, any ideas what's going wrong ?
    Sorry to take a while to get back to you on this. I discovered that I had the same situation on my laptop dual-boot system. When I run update-grub on this system the gfxmode in grub.cfg (line 23) does not change. When I run it on my single OS desktop the change is made.

    Initially, these are things I checked:
    1. /etc/default/grub, and etc/grub.d files are all executable
    2. the graphic mode selected is compatible with grub 2 (from the boot menu, press "c", then type "vbeinfo" get see the allowable resolutions).
    3. Using the default settings in /etc/grub.d/00_header
    3. run "sudo update-grub"
    4. Check the contents of /boot/grub/grub.cfg to see if the gfxmode changed.

    I could not find a problem. So I then planned to replace /etc/default/grub, /etc/grub.d/00_header and /usr/sbin/grub-mkconfig with known valid copies. On my laptop, it turned out there was a problem with /etc/default/grub (somewhere).

    You can find a "clean" copy of /etc/default/grub in /usr/share/grub/default Try replacing your current one with a copy of the original and see if it works. That fixed the problem for me and now when I change the GRUB_GFXMODE= value and run update-grub the change is made to /boot/grub/grub.cfg.

    I haven't tweaked any of my settings yet to see if there might be a bug connected with a particular setting, but for now the defaults work correctly.
    GRUB2

    Retired.

  9. #19
    Join Date
    Nov 2008
    Beans
    42
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Grub 2 - 5 Common Tasks

    Quote Originally Posted by drs305 View Post
    You can find a "clean" copy of /etc/default/grub in /usr/share/grub/default Try replacing your current one with a copy of the original and see if it works. That fixed the problem for me and now when I change the GRUB_GFXMODE= value and run update-grub the change is made to /boot/grub/grub.cfg.
    Thanks for replying...

    I think we are almost there..

    Can you please tell where can I find a fresh copy of /etc/grub.d/00_header ?

  10. #20
    Join Date
    Dec 2008
    Location
    kolkata
    Beans
    64
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Grub 2 installation in linux superblock not on mbr

    Can anybody write a step by step guide on how to install grub2 in linux superblock not on mbr?

    I am using a IBM 51 laptop which is having a custom IBM specific MBR. I don't want to destroy it.

    Secondly, can anyone tell me how to reinstall grub2 if it is corrupted?
    Something similar to stage1 or stage2 in legacy grub....

Page 2 of 6 FirstFirst 1234 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •