Results 1 to 9 of 9

Thread: Automount rules in karmic

  1. #1
    Join Date
    May 2008
    Beans
    26
    Distro
    Ubuntu Karmic Koala (testing)

    Automount rules in karmic

    Solution:
    I found solution finally.
    Just add
    Code:
    gnome-mount -p Data(change it to your volume label)
    to gnome startup applications. Now drive will be mounted at startup and you will be able to mount/unmount it without any errors.
    Hi,

    By default ubuntu don't mount internal ntfs hard drives automatically.
    Solution with fstab is not working properly, because of conflict with "intelligent" mount system. If i add my hd in fstab and reboot - it will be mounted. But if you go to nautilus, open places panel and click eject button(unmount) and than click on hd again to mount it you will get an error:
    Error mounting: mount exited with exit code 1: helper failed with: Unprivileged user can not mount NTFS block devices using the external FUSE library. Either mount the volume as root, or rebuild NTFS-3G with integrated FUSE support and make it setuid root. Please see more information at http://ntfs-3g.org/support.html#unprivileged
    But options in fstab allow me to mount this drive.

    In 9.04 to solve this problem you need to modify hal rules in /etc/hal/... preferences.fdi in my case i modified it for only one drive.
    Code:
    <device>
    −
    <match key="storage.hotpluggable" bool="false">
    −
    <match key="storage.removable" bool="false">
    <merge key="storage.automount_enabled_hint"  type="bool">false</merge>
    −
    <match key="storage.model" string="ST3250310NS">
    <merge key="storage.automount_enabled_hint" type="bool">true</merge>
    </match>
    </match>
    </match>
    </device>
    But this is not working in 9.10 - devs removed this function from hal to devkit-disk or udev? I don't know.
    Could you please tell me where automount rules stored in 9.10? And how to create new rules, and what program controlls automount in 9.10.
    Last edited by n0_mad; October 29th, 2009 at 02:32 PM.

  2. #2
    Join Date
    Dec 2007
    Location
    Poland
    Beans
    6
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Automount rules in karmic

    I'm looking for a solution too. Do I really need to build NTFS-3G manually?
    Last edited by dulek; October 28th, 2009 at 12:53 AM.

  3. #3
    Join Date
    May 2008
    Beans
    26
    Distro
    Ubuntu Karmic Koala (testing)

    Re: Automount rules in karmic

    Bump. 9.10 is out, so this thread should be moved to general forums again i think.

  4. #4
    Join Date
    Apr 2008
    Beans
    131

    Talking Re: Automount rules in karmic

    Since "Hal" is being deprecated, and ubuntu moved to devicekit-disks, i had a hard time figuring out how to set my drives to autmount on startup like i used to do with editing /etc/hal/fdi/policy/preferences.fdi and setting automount to ture.

    i just found a solution for this, thanks to this

    do this

    Code:
    sudo gedit /lib/udev/rules.d/95-devkit-disks.rules
    at the end BEFORE
    Code:
    LABEL="devkit_disks_end"
    just add

    Code:
    RUN+="/bin/mount -t auto /dev/sda6 /media/Programs"
    of course replace /dev/sda6 with ur drive number and /media/Programs with the mount point u like.

    i also added this rule, dunno if its needed, it was supposed to set me as the owner but i still have to enter my pass if i wana unmount and remount a drive again but i dont care...

    Code:
    KERNEL=="/dev/sda[0-9]", OWNER="user"
    FINALLY! found a solution for this it has been bugging me like hell!
    Last edited by Elcid247; October 29th, 2009 at 06:36 AM.

  5. #5
    dino99's Avatar
    dino99 is offline Ubuntu addict and loving it
    Join Date
    Jun 2006
    Location
    Nux Jam
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Automount rules in karmic

    is there a bug filled ?

  6. #6
    Join Date
    May 2008
    Beans
    26
    Distro
    Ubuntu Karmic Koala (testing)

    Re: Automount rules in karmic

    It is not working.
    After rebooting drive is mounted. I click unmount, enter the password, disk unmounts and mounts again instantly.

  7. #7
    Join Date
    May 2008
    Beans
    26
    Distro
    Ubuntu Karmic Koala (testing)

    Re: Automount rules in karmic

    I found solution finally.
    Just add
    Code:
    gnome-mount -p Data(change it to your volume label)
    to gnome startup applications. Now drive will be mounted at startup and you will be able to mount/unmount it without any errors.
    Last edited by n0_mad; October 29th, 2009 at 02:01 PM.

  8. #8
    Join Date
    Mar 2009
    Location
    Iceland
    Beans
    202
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Re: Automount rules in karmic

    You can get pysdm in synaptic the easy way

  9. #9
    Join Date
    May 2008
    Beans
    26
    Distro
    Ubuntu Karmic Koala (testing)

    Re: Automount rules in karmic

    You did not read first post and thread - fstab based solutions dont work correct. All this gui tools just modify your fstab.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •