I've just had my Dell XPS 15z laptop replaced due to the original machine having a number of faults (long story).

The original machine was an Intel Core i5-2410M based machine with 4GB RAM, inetgrated Intel graphics plus an nVidia 525 based additional GPU (512MB).

I installed Ubuntu 11.10 Desktop AMD64 on this with no problems.

The replacement machine arrived with a number of upgrades (for my troubles with the original machine).

The new machine is Intel Core i7-2640M based, with 8GB RAM, the same intel integrated graphics plus an nVidia 525 based GPU (this time 1GB).

The problem is that I cannot get the 64 bit version of Ubuntu to run on the new machine. The Live CD / Installer fails just after the first boot screen (with the keyboard and mouse logo at the bottom). The csreen goes black with a large flashing cursor, then the cursor shrinks as though the video res has been increased. A few seconds later the CD spins down and nothing ever progresses.

I also tried restoring my Ubuntu backup partition from the old machine (which was installed with the very same CD) and the same thing happened.

Both processors are 64 bit. The new machine is higher spec'd. The GPU is the same type just with more memory...

Why would Ubuntu not even boot on the live CD on the new machine?

Does anyone have any ideas? I've had to install the 32 bit version in the meantime to get me going, but I'd really like to get the 64bit version back on there asap if I can.

(I tried the CD in the old machine again and it still boots no problem - so it's not a problem with the CD)