Results 1 to 9 of 9

Thread: Compiling game-editor... or deb package available?

  1. #1
    Join Date
    Apr 2009
    Beans
    3

    Compiling game-editor... or deb package available?

    Hi, I've recently found out about http://game-editor.com/. A game authoring software that's been recently opensourced ( yay!) and I want to try it.

    Apparently they have only demos for download, so I'm trying to compile it. Their compiling instructions look confusing so before I start on this quest to get it working I wanted to know if someone out there has done it before to get some instructions or if there's a deb package already compiled.

    Thanks for the help.

  2. #2
    Join Date
    Apr 2009
    Beans
    3

    Re: Compiling game-editor... or deb package available?

    Also, the demo didn't work, it needs libstd++5 and that package only exists for jaunty

  3. #3
    Join Date
    Apr 2007
    Location
    Zürich, Switzerland
    Beans
    163
    Distro
    Kubuntu 9.04 Jaunty Jackalope

    Re: Compiling game-editor... or deb package available?

    The compiling instructions seem to have been written with downloading every additional library as a source tarball yourself in mind. And why in the name of jesus christ do you have to get LLVM anyway. And why RakNet? An impossible networking library with an even more retarded license.

    Besides these lines,

    6 Configure the LibStatic project to:
    7 Multi-threaded (/MT or /MTd)
    everything seems pretty obvious to me. So what you do is...

    Code:
    mkdir llvm
    cd llvm
    svn co http://llvm.org/svn/llvm-project/llvm/trunk .
    cd tools
    svn co http://llvm.org/svn/llvm-project/cfe/trunk clang 
    cd ..
    ./configure
    make && sudo make install
    cd tools/clang
    make && sudo make install
    So, what you first do is get llvm from SVN (check if you have installed the package 'subversion'), get the clang tool, too, configure the build process (if any error occurs when building it, post it), compile both and install both.

    Afterwards you should check whether you have 'unzip' from universe installed and

    Code:
    cd ../../../
    wget http://www.jenkinssoftware.com/raknet/downloads/RakNet-3.703.zip
    unzip RakNet-3.703.zip
    cd RakNet-3.703
    ./bootstrap
    ./configure
    make && sudo make install
    I'm not really sure about the actual process above, as I'm not running Linux at the moment so I can't confirm it, and RakNet's confusing.

    Also

    sudo apt-get install libwxbase2.8-dev libwxgtk2.8-dev
    should do install the wxWidgets development files, assuming that they want 2.8.

    Then go to the game-editor directory and type 'make'... that should do it.

    As I said, I'm not running Linux right now so I can't confirm that everything works as planned.

    Cheers

  4. #4
    Join Date
    Apr 2009
    Beans
    3

    Re: Compiling game-editor... or deb package available?

    Wow thanks, will do it right now and post if I succeeded

  5. #5
    Join Date
    Feb 2006
    Location
    Vernon, BC, Canada
    Beans
    23
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Compiling game-editor... or deb package available?

    I'd be interested to see a package of Game-Editor as well. I'm in the process of compiling llvm and it's inflating huuuge (~2GB). Taking a good long time (but what do I know about whether or not that's a long time to compile, I usually rely on .deb).

  6. #6
    Join Date
    May 2007
    Location
    Toronto, Canada
    Beans
    4,508
    Distro
    Ubuntu

    Re: Compiling game-editor... or deb package available?

    I'll see if this can be added to PlayDeb.

  7. #7
    Join Date
    Apr 2007
    Location
    Zürich, Switzerland
    Beans
    163
    Distro
    Kubuntu 9.04 Jaunty Jackalope

    Re: Compiling game-editor... or deb package available?

    I wouldn't put too much faith into a rpg/game maker anyway, those apps are mostly very limiting and often feature obscure program design decisions to make things "easier".

    What the hell do I know though.

    Wow thanks, will do it right now and post if I succeeded
    I'm wet with anticipation

  8. #8
    Join Date
    Sep 2012
    Beans
    1

    Re: Compiling game-editor... or deb package available?

    Quote Originally Posted by Sindwiller View Post
    The compiling instructions seem to have been written with downloading every additional library as a source tarball yourself in mind. And why in the name of jesus christ do you have to get LLVM anyway. And why RakNet? An impossible networking library with an even more retarded license.

    Besides these lines,



    everything seems pretty obvious to me. So what you do is...

    Code:
    mkdir llvm
    cd llvm
    svn co http://llvm.org/svn/llvm-project/llvm/trunk .
    cd tools
    svn co http://llvm.org/svn/llvm-project/cfe/trunk clang 
    cd ..
    ./configure
    make && sudo make install
    cd tools/clang
    make && sudo make install
    So, what you first do is get llvm from SVN (check if you have installed the package 'subversion'), get the clang tool, too, configure the build process (if any error occurs when building it, post it), compile both and install both.

    Afterwards you should check whether you have 'unzip' from universe installed and

    Code:
    cd ../../../
    wget http://www.jenkinssoftware.com/raknet/downloads/RakNet-3.703.zip
    unzip RakNet-3.703.zip
    cd RakNet-3.703
    ./bootstrap
    ./configure
    make && sudo make install
    I'm not really sure about the actual process above, as I'm not running Linux at the moment so I can't confirm it, and RakNet's confusing.

    Also



    should do install the wxWidgets development files, assuming that they want 2.8.

    Then go to the game-editor directory and type 'make'... that should do it.

    As I said, I'm not running Linux right now so I can't confirm that everything works as planned.

    Cheers
    In your 2nd code box the "wget" command line, were you put "http://www.jenkinssoftware.com/raknet/downloads/RakNet-3.703.zip", change it to http://www.jenkinssoftware.com/rakne...kNet-3.732.zip

  9. #9

    Re: Compiling game-editor... or deb package available?

    version numbers change after 3 years :}

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •