Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: How do I disable Graphical boot?

  1. #1
    Join Date
    Dec 2008
    Beans
    26
    Distro
    Ubuntu Karmic Koala (testing)

    How do I disable Graphical boot?

    Hi!

    I'd like to disable all of the GUI boot, so thinking as it was in previous versions of (kx)ubuntu I installed rcconf to disablegdm... but to my surprise both gdm and kdm are disabled! How do I get a GUI-less boot in this new version of ubuntu?

    Thanks!

  2. #2
    Join Date
    Sep 2008
    Beans
    519

    Re: How do I disable Graphical boot?

    sudo nano /etc/defaults/grub

    where it says
    Code:
    quiet splash
    change it to just
    Code:
    quiet

  3. #3
    Join Date
    Dec 2008
    Beans
    26
    Distro
    Ubuntu Karmic Koala (testing)

    Re: How do I disable Graphical boot?

    did that, nothing happened.

    BTW what I want is for ubuntu to show info on everything it's loading at boot time and then drop me into a tty (no GUI) so I can login and manually start X server as I see fit

    Thanks!

  4. #4
    Join Date
    Dec 2008
    Beans
    26
    Distro
    Ubuntu Karmic Koala (testing)

    Re: How do I disable Graphical boot?

    bump

  5. #5
    Join Date
    Mar 2006
    Location
    Williams Lake
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: How do I disable Graphical boot?

    With older versions, all you had to do was disable gdm and usplash eg:

    Code:
    sudo update-rc.d -f gdm remove
    With the changes that have been made to the boot process of a full installation, I'm not sure if it will work any more, but give it a try.

  6. #6
    Join Date
    Dec 2008
    Beans
    88

    Re: How do I disable Graphical boot?

    Quote Originally Posted by renkinjutsu View Post
    sudo nano /etc/defaults/grub

    where it says
    Code:
    quiet splash
    change it to just
    Code:
    quiet
    Don't forget to run "sudo update-grub" after you have made those changes ?

  7. #7
    Join Date
    Sep 2006
    Location
    Southern Indiana, USA
    Beans
    1,644
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: How do I disable Graphical boot?

    It still doesn't actually give the same text-boot as Jaunty, but I understand that is by design and can't be changed.

    However, you will find if you boot from Recovery Menu, that it really does show everything. Only the "X" loading text is obscured. The "Cylon Warrior Throbber Thing" is there regardless, even if ypu remove "quiet splash".
    Last edited by emarkay; October 20th, 2009 at 07:46 PM.
    Ubuntu 12.04 LTS (& Windows XP-SP3 for Flight Sim only) - (1) 3.4 G/3G RAM/NVIDIA GT630, 2048VRAM/SB AudigySE Audio (2) 2.9 G/2G RAM/NVIDIA 9500GT,1024VRAM/SB Audio (3) 2.3 G/2G RAM/NVIDIA FX1500M,256VRAM/Sigmatel Audio

  8. #8
    Join Date
    Dec 2008
    Beans
    88

    Re: How do I disable Graphical boot?

    You can remove the 'cyclone warrior' by removing the package called 'xsplash'. You will still be booting into X at the same time, you will just see a waiting cursor instead.

  9. #9
    Join Date
    Oct 2006
    Beans
    158

    Re: How do I disable Graphical boot?

    You can fix this problem by editing /etc/event.d/rc-default file
    First backup file,

    sudo cp /etc/event.d/rc-default /etc/event.d/rc-default.bakup

    Open /etc/event.d/rc-default

    Find all lines read as - telinit 2 and replace with telinit 3

  10. #10
    Join Date
    Dec 2008
    Beans
    26
    Distro
    Ubuntu Karmic Koala (testing)

    Re: How do I disable Graphical boot?

    wow! a lot of info for a weekend day, I'll try it out monday morning

    Thanks a lot for your feedback!

    Regards

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •