Results 1 to 4 of 4

Thread: refresh rate, xorg.conf, edid.bin

  1. #1
    Join Date
    Mar 2009
    Beans
    25

    Unhappy refresh rate, xorg.conf, edid.bin

    I have this new asus laptop with Nvidia Geforce GTX 260M gpu. My problem is the refresh rate is low with ubuntu 9.04 and 9.10 beta even though I have installed the latest driver from nvidia web site.

    I particularly need some help about why my xorg.conf file does not override the parameters that I set and does anyone know how to locate and modify the related parameters in the edid.bin file.

    My xorg.conf file is below.
    Thanks for the help


    # nvidia-xconfig: X configuration file generated by nvidia-xconfig
    # nvidia-xconfig: version 1.0 (buildmeister@builder63) Wed Sep 2 03:50:51 PDT 2009

    # nvidia-settings: X configuration file generated by nvidia-settings
    # nvidia-settings: version 1.0 (buildmeister@builder63) Wed Sep 2 03:51:49 PDT 2009

    Section "ServerLayout"
    Identifier "Layout0"
    Screen 0 "Screen0" 0 0
    InputDevice "Keyboard0" "CoreKeyboard"
    InputDevice "Mouse0" "CorePointer"
    EndSection

    Section "Files"
    EndSection

    Section "ServerFlags"
    Option "Xinerama" "0"
    EndSection

    Section "InputDevice"

    # generated from default
    Identifier "Mouse0"
    Driver "mouse"
    Option "Protocol" "auto"
    Option "Device" "/dev/psaux"
    Option "Emulate3Buttons" "no"
    Option "ZAxisMapping" "4 5"
    EndSection

    Section "InputDevice"

    # generated from default
    Identifier "Keyboard0"
    Driver "kbd"
    EndSection

    Section "Monitor"

    # 1920x1080 @ 70.00 Hz (GTF) hsync: 78.68 kHz; pclk: 205.20 MHz
    Identifier "Monitor0"
    VendorName "Unknown"
    HorizSync 30.0 - 110.0
    VertRefresh 50.0 - 150.0
    ModeLine "1920x1080@70.00" 205.20 1920 2056 2264 2608 1080 1081 1084 1124 -hsync +vsync
    ModeLine "1920x1080@75.00" 220.64 1920 2056 2264 2608 1080 1081 1084 1128 -hsync +vsync
    Option "DPMS"
    EndSection

    Section "Device"
    Identifier "Device0"
    Driver "nvidia"
    VendorName "NVIDIA Corporation"
    BoardName "GeForce GTX 260M"
    EndSection

    Section "Screen"
    Identifier "Screen0"
    Device "Device0"
    Monitor "Monitor0"
    DefaultDepth 24
    Option "UseEDIDFreqs" "FALSE"
    Option "NoBandWidthTest" "TRUE"
    Option "ExactModeTimingsDVI" "TRUE"
    Option "ModeValidation" "NoEdidModes, NoMaxPClkCheck, NoVertRefreshCheck, NoHorizSyncCheck, NoEdidMaxPClkCheck"
    Option "UseDisplayDevice" "DFP-0"
    SubSection "Display"
    Depth 24
    Modes "1920x1080@70.00" "1920x1080@75.00"
    EndSubSection
    EndSection


  2. #2
    Join Date
    Sep 2006
    Beans
    1,610
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: refresh rate, xorg.conf, edid.bin

    Are you absolutely sure that your monitor supports 70Hz refresh? Laptops usually do 60Hz refresh and any flicker you see from that is not from the refresh rate; it's more likely from disabling sync-on-refresh instead of enabling triple buffering.

    Take a look at /var/log/Xorg.0.log. Did the X server correctly identify the monitor at X startup? If so, there will be no arguing with it because (I think) the nvidia driver will override any monitor timing changes you make. It's all for your own good, ya know.

    Can you change it via nvidia-settings? That's the easy test...

  3. #3
    Join Date
    Mar 2009
    Beans
    25

    Re: refresh rate, xorg.conf, edid.bin

    Thank you very much for the reply.

    I had the same problem with my current HP laptop. Luckily, after overriding the parameters in xorg.conf and disabling nvidia driver it started to refresh at 70Hz. But with ubuntu 9.10 beta even this method did not yield any result.

    Unfortunately, X server does not identify my monitor as you can see in the xorg file the monitor vendor name is "Unknown". I guess this is the reason that the driver does not accept customized values.

    Is there a way to make X server recognize my monitor or give monitor parameters manually?

    As for nvidia overriding my parameters, you are right, xorg.0.log shows that my parameters are not accepted.

    Changing it via nvidia-settings is not an option because it does not show my parameters.

  4. #4
    Join Date
    Sep 2006
    Beans
    1,183
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: refresh rate, xorg.conf, edid.bin

    Hello,

    I would give you a quick advice comparing my xorg.conf file and yours.

    First of take a backup of your original xorg.conf file:
    cd /etc/X11
    sudo cp xorg.conf xorg.conf.backup_last
    then:
    sudo vim xorg.conf

    In the option Identifier of your monitor type:
    Identifier "Generic Monitor"
    and erase the Vendor Name.

    Restart your system and see if this works. If not, then restore your original xorg.conf file:
    sudo cp xorg.conf.backup_last xorg.conf (inside the /etc/X11 directory).

    Regards!

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •