Page 1 of 3 123 LastLast
Results 1 to 10 of 23

Thread: Poor performance in VirtualBox when Intel-VT active

  1. #1
    Join Date
    Jan 2008
    Location
    Poland/Warsaw
    Beans
    269
    Distro
    Ubuntu 11.04 Natty Narwhal

    Unhappy Poor performance in VirtualBox when Intel-VT active

    I have Dell Latitude E6500 with P8600 CPU. When I run my Windows XP guest on VirtualBox OSE without virtualization VT-x option inactive it runs much faster than in the case I turn it on. It is really visible - with VT-x on I even see how screen flickers during the boot process.

    I did Peacekeeper tests in Firefox and I got these results:
    1) VT-x off, 3D support off - 1596
    2) VT-x off, 3D support on - 1679
    3) VT-x on, 3D support off - 900
    4) VT-x on, 3D support on - 1314

    Google Chrome behaves even more strange - with VT-x off it runs faster than Firefox while with VT-x on it runs *VERY* slow but looses no frames in graphic tests and it finally gets sth like 8800 points.

    What could be wrong with my settings? I bought this machine to gain with using VT-x, not to decrease performace this way. ;/

    I use 64-bit Karmic.

    EDIT: I filed a bug report:
    https://bugs.launchpad.net/bugs/455112
    Last edited by mgol; October 19th, 2009 at 03:49 AM.
    Michał Gołębiowski
    Dell Latitude E6500: P8600 | Intel GMA 4500MHD | 15,4'' 1440x900 LED (matte) | 4GiB DDR2 | 233 GiB HDD 7200 rpm (with Free Fall Sensor).
    Jabber ID: mgol /at/ jabster.pl - let me write in within my profile details, please!

  2. #2
    Join Date
    Dec 2008
    Beans
    26

    Re: Poor performance in VirtualBox when Intel-VT active

    Quote Originally Posted by mgol View Post
    I have Dell Latitude E6500 with P8600 CPU. When I run my Windows XP guest on VirtualBox OSE without virtualization VT-x option inactive it runs much faster than in the case I turn it on. It is really visible - with VT-x on I even see how screen flickers during the boot process.

    I did Peacekeeper tests in Firefox and I got these results:
    1) VT-x off, 3D support off - 1596
    2) VT-x off, 3D support on - 1679
    3) VT-x on, 3D support off - 900
    4) VT-x on, 3D support on - 1314

    Google Chrome behaves even more strange - with VT-x off it runs faster than Firefox while with VT-x on it runs *VERY* slow but looses no frames in graphic tests and it finally gets sth like 8800 points.

    What could be wrong with my settings? I bought this machine to gain with using VT-x, not to decrease performace this way. ;/

    I use 64-bit Karmic.

    EDIT: I filed a bug report:
    https://bugs.launchpad.net/bugs/455112
    my problems are quite similar to yours. and to make matters even worse, the sound sounds like an old record player skipping!! lets hope that someone will come to our rescue

  3. #3
    Join Date
    Jan 2008
    Location
    Poland/Warsaw
    Beans
    269
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Poor performance in VirtualBox when Intel-VT active

    Quote Originally Posted by kaboyish View Post
    my problems are quite similar to yours. and to make matters even worse, the sound sounds like an old record player skipping!! lets hope that someone will come to our rescue
    For me sound is so bad not only when VT-x is enabled... Do You share my experiences? I filed a bug report about this:
    https://bugs.launchpad.net/ubuntu/+s...se/+bug/451688
    You can subscribe and/or comment if You have a Launchpad account.
    Michał Gołębiowski
    Dell Latitude E6500: P8600 | Intel GMA 4500MHD | 15,4'' 1440x900 LED (matte) | 4GiB DDR2 | 233 GiB HDD 7200 rpm (with Free Fall Sensor).
    Jabber ID: mgol /at/ jabster.pl - let me write in within my profile details, please!

  4. #4
    Join Date
    Apr 2006
    Location
    Montana
    Beans
    Hidden!
    Distro
    Kubuntu Development Release

    Re: Poor performance in VirtualBox when Intel-VT active

    Just a reminder, Karmic is still in Beta
    There are two mistakes one can make along the road to truth...not going all the way, and not starting.
    --Prince Gautama Siddharta

    #ubuntuforums web interface

  5. #5
    Join Date
    Jan 2008
    Location
    Poland/Warsaw
    Beans
    269
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Poor performance in VirtualBox when Intel-VT active

    Quote Originally Posted by bodhi.zazen View Post
    Just a reminder, Karmic is still in Beta
    Yeah, I know, but in 2 days it will go RC, so it's getting hotter and hotter now.
    Michał Gołębiowski
    Dell Latitude E6500: P8600 | Intel GMA 4500MHD | 15,4'' 1440x900 LED (matte) | 4GiB DDR2 | 233 GiB HDD 7200 rpm (with Free Fall Sensor).
    Jabber ID: mgol /at/ jabster.pl - let me write in within my profile details, please!

  6. #6
    Join Date
    Jan 2008
    Location
    Poland/Warsaw
    Beans
    269
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Poor performance in VirtualBox when Intel-VT active

    Quote Originally Posted by kaboyish View Post
    and to make matters even worse, the sound sounds like an old record player skipping!!
    As for the sound issue (which is different from this one), see:
    https://bugs.launchpad.net/ubuntu/+s...688/comments/2

    It seems very common, at least recently. A lot of apps have sound problems because they default to alsa instead of pulse...
    Michał Gołębiowski
    Dell Latitude E6500: P8600 | Intel GMA 4500MHD | 15,4'' 1440x900 LED (matte) | 4GiB DDR2 | 233 GiB HDD 7200 rpm (with Free Fall Sensor).
    Jabber ID: mgol /at/ jabster.pl - let me write in within my profile details, please!

  7. #7
    Join Date
    May 2005
    Location
    Somewhere south of Milan
    Beans
    216

    Re: Poor performance in VirtualBox when Intel-VT active

    same here, running windows 7 on a karmic host, performance is horrible

  8. #8
    Join Date
    Mar 2008
    Location
    Finland
    Beans
    9

    Re: Poor performance in VirtualBox when Intel-VT active

    I can confirm that I have same problem. Karmic 64-bit is host on my laptop and I run Windows XP 32bit as a guest on VirtualBoX 3.0.8.

    Performance is S L O W with Intel-VT activated. Didn't had problems with 9.04.

  9. #9
    Join Date
    Jan 2008
    Location
    Poland/Warsaw
    Beans
    269
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Poor performance in VirtualBox when Intel-VT active

    Quote Originally Posted by Fale View Post
    Performance is S L O W with Intel-VT activated. Didn't had problems with 9.04.
    Oh, that is interesting. Could You comment about that on the bug I mentioned at the beginning?
    Michał Gołębiowski
    Dell Latitude E6500: P8600 | Intel GMA 4500MHD | 15,4'' 1440x900 LED (matte) | 4GiB DDR2 | 233 GiB HDD 7200 rpm (with Free Fall Sensor).
    Jabber ID: mgol /at/ jabster.pl - let me write in within my profile details, please!

  10. #10
    Join Date
    Mar 2008
    Location
    Finland
    Beans
    9

    Re: Poor performance in VirtualBox when Intel-VT active

    Quote Originally Posted by mgol View Post
    Oh, that is interesting. Could You comment about that on the bug I mentioned at the beginning?
    I have not enough knowledge to comment that one... but clearly seems that many has performance issues when running VirtualBox under Karmic with Intel-VT enabled.

Page 1 of 3 123 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •