Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 23

Thread: Poor performance in VirtualBox when Intel-VT active

  1. #11
    Join Date
    May 2005
    Location
    Somewhere south of Milan
    Beans
    216

    Re: Poor performance in VirtualBox when Intel-VT active

    I found out that enabling only one core helps quite a lot, by the way, disabling intel vt prevents windows 7 from booting (I get a progress bar at boot, like when you boot the win7 install cd... weird).

  2. #12
    Join Date
    Nov 2005
    Beans
    15

    Re: Poor performance in VirtualBox when Intel-VT active

    Quote Originally Posted by garba View Post
    same here, running windows 7 on a karmic host, performance is horrible
    Same with me. Running Win7 64 bit (and 32bit) guests on an AMD Phenom(tm) II X3 710 Processor with 8GB of DDR3 RAM. On Ubuntu 9.04 it was really snappy and fast, while on 9.10 it is really really slow.

    I'm running VirtualBox 3.0.8. (I did run 3.0.3 or something like that on ubuntu 9.04 with good performance)

  3. #13
    Join Date
    May 2005
    Location
    Somewhere south of Milan
    Beans
    216

    Re: Poor performance in VirtualBox when Intel-VT active

    tried disabling nested paging, it helps some

  4. #14
    Join Date
    Jan 2008
    Location
    Poland/Warsaw
    Beans
    269
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Poor performance in VirtualBox when Intel-VT active

    Quote Originally Posted by garba View Post
    tried disabling nested paging, it helps some
    Really? Not for me. BTW, nested paging is not present in all but Core i7 Intel CPUs (it is present in most AMD ones, though). VirtualBox knows that and it doesn't enable this feature if not present. It would be really weird if disabling something that VBox disables itself worked.

    Maybe it just seemed to work a bit faster one time? It can happen but it still means nothing.
    Michał Gołębiowski
    Dell Latitude E6500: P8600 | Intel GMA 4500MHD | 15,4'' 1440x900 LED (matte) | 4GiB DDR2 | 233 GiB HDD 7200 rpm (with Free Fall Sensor).
    Jabber ID: mgol /at/ jabster.pl - let me write in within my profile details, please!

  5. #15
    Join Date
    Aug 2007
    Location
    Victoria, Australia
    Beans
    63

    Re: Poor performance in VirtualBox when Intel-VT active

    I had the same problem with performance on Vista and W7.

    I found the solution to the problem increasing the VM memory to 960mb respectively. That drastically improved stability and usability for me. However I suspect that as more applications are installed in the vm it will need even more memory on these systems.

  6. #16
    Join Date
    Jan 2008
    Location
    Poland/Warsaw
    Beans
    269
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Poor performance in VirtualBox when Intel-VT active

    Quote Originally Posted by joewski View Post
    I found the solution to the problem increasing the VM memory to 960mb respectively.
    I gave it 1024 MB at the beginning and efficiency sucks.
    Michał Gołębiowski
    Dell Latitude E6500: P8600 | Intel GMA 4500MHD | 15,4'' 1440x900 LED (matte) | 4GiB DDR2 | 233 GiB HDD 7200 rpm (with Free Fall Sensor).
    Jabber ID: mgol /at/ jabster.pl - let me write in within my profile details, please!

  7. #17
    Join Date
    Nov 2006
    Location
    Conn., United States
    Beans
    1,644

    Re: Poor performance in VirtualBox when Intel-VT active

    Quote Originally Posted by joewski View Post
    I found the solution to the problem increasing the VM memory to 960mb respectively.
    Quote Originally Posted by mgol View Post
    I gave it 1024 MB at the beginning and efficiency sucks.
    I've given my VM (WinXP) 1792 MB -- I have 4G on my system -- and I still have issues when defining 2 CPU's. With VT-x enabled and only 1 CPU defined, performance is fine. Just as with Fale, I did not have this problem with Jaunty.
    "When you dual-boot Windows, Windows exists along side of Linux. When you use VirtualBox, Windows exists at the pleasure of Linux." -- ThomasAaron @ System76

  8. #18
    Join Date
    Nov 2006
    Location
    Conn., United States
    Beans
    1,644

    Re: Poor performance in VirtualBox when Intel-VT active

    Quote Originally Posted by bodhi.zazen View Post
    Just a reminder, Karmic is still in Beta
    The problem persists in the final release and with VirtualBox 3.0.10 (PUEL)
    "When you dual-boot Windows, Windows exists along side of Linux. When you use VirtualBox, Windows exists at the pleasure of Linux." -- ThomasAaron @ System76

  9. #19
    Join Date
    Apr 2006
    Location
    Montana
    Beans
    Hidden!
    Distro
    Kubuntu Development Release

    Re: Poor performance in VirtualBox when Intel-VT active

    I hope you find a solution and fast =)

    Two general comments :

    1. Keep in mind , VBox is a third party application, try teh VirtualBox forums and the PUEL will lag a bit behind the Karmic release.

    2. Personally I have been using KVM for the last few months. I understand it to has limitations, but it does what I need and with less problems then VBox or VMWare.

    I run KVM from the command line =)
    There are two mistakes one can make along the road to truth...not going all the way, and not starting.
    --Prince Gautama Siddharta

    #ubuntuforums web interface

  10. #20
    Join Date
    Oct 2009
    Beans
    4

    Re: Poor performance in VirtualBox when Intel-VT active

    Similar problem for me:

    Host Info :
    OS : Windows XP SP3 x86,
    PRO : AMD64 4200+ X2
    RAM : 2 GB DDR2 800
    GRA : Radeon HD2600 PRO 512 MB

    Virtual Machines :
    APP : VirtualBox 2.2.4
    OS : Kubuntu 9.04 (Upgraded from 8.04 and changed to Gnome)
    3D : Enabled
    PRO : 1
    RAM : 1024
    RESULT : Everything went well, i could activate compiz at least

    APP : VMWare 6.5
    OS : Pardus 2008.2
    3D : Enabled
    PRO : 2
    RAM : 1024
    RESULT : Works Fine

    Virtual Machines :
    APP : VirtualBox 3.0.8 (Also upgraded to 3.0.10 but nothing changed)
    OS : Ubuntu 9.10 (Clean install)
    3D : Enabled
    PRO : 1
    RAM : 1024
    RESULT : Performance is really poor, disabled compiz but every login i have to reload metacity, still apps lags and when activate compiz, for example when dropdown a menu, it has a yellowish color, mouseover fixes the color issue. When click to an item, menu does not disappear, stays there with app. %40 alpha. When click on screen, then it disappears.


    Note : I tried to use Vmware with ubuntu 9.10, enabled 3D but could not activate desktop effects, so deleted.

    Sorry for poor English...
    Last edited by sevketcaba; October 31st, 2009 at 02:18 PM.

Page 2 of 3 FirstFirst 123 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •