Page 7 of 9 FirstFirst ... 56789 LastLast
Results 61 to 70 of 84

Thread: Using PVR150 IR Blaster In Mythbuntu 9.10b

  1. #61
    Join Date
    Dec 2007
    Beans
    51

    Re: Using PVR150 IR Blaster In Mythbuntu 9.10b

    UPDATE: I've given up and went with a Phillips/Microsoft USBMCE remote. Works great without any tweaking.

  2. #62
    Join Date
    Feb 2008
    Location
    Chicago, IL
    Beans
    112
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Re: Using PVR150 IR Blaster In Mythbuntu 9.10b

    Quote Originally Posted by TrevorBradley View Post
    UPDATE: I've given up and went with a Phillips/Microsoft USBMCE remote. Works great without any tweaking.
    I actually just stopped using 9.10 and stayed with 9.04.

  3. #63
    Join Date
    Apr 2007
    Beans
    4
    Distro
    Kubuntu 9.10 Karmic Koala

    Re: Using PVR150 IR Blaster In Mythbuntu 9.10b

    Quote Originally Posted by TrevorBradley View Post
    UPDATE: I've given up and went with a Phillips/Microsoft USBMCE remote. Works great without any tweaking.
    Does it come with a blaster? If so, do you know where I can get one?

  4. #64
    Join Date
    Aug 2007
    Beans
    33
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: Using PVR150 IR Blaster In Mythbuntu 9.10b

    I updated the zilog.diff patch to work in 10.04, its just a copy of the old diff with the changes from Jarod's lirc kernel driver git tree, but with the includes from the old patch

    Code:
    sudo apt-get install lirc-modules-source
    cd /usr/src/lirc-0.8.6/
    sudo patch -p0 < ~/zilog.diff
    sudo dpkg-reconfigure lirc-modules-source
    Last edited by mrplow; August 29th, 2010 at 02:40 AM. Reason: typo, double sudo

  5. #65
    Join Date
    Nov 2006
    Beans
    137

    Re: Using PVR150 IR Blaster In Mythbuntu 9.10b

    I try your patch. i did the command + sudo modprobe lirc_zilog

    Everything look good

    lsmod |grep lirc
    lirc_zilog 13245 0
    lirc_i2c 5845 1
    lirc_dev 8890 4 lirc_zilog,lirc_i2c

    ls -l lirc*
    crw-rw---- 1 root root 61, 0 2010-05-02 10:43 lirc0
    lrwxrwxrwx 1 root root 19 2010-05-02 10:43 lircd -> /var/run/lirc/lircd
    lrwxrwxrwx 1 root root 20 2010-05-02 10:43 lircd1 -> /var/run/lirc/lircd1


    I still have this error:

    irsend: command failed: SEND_ONCE blaster 1
    irsend: hardware does not support sending

    Do you know the problem? is it hardware.conf, lircd.conf or something else?

  6. #66
    Join Date
    Aug 2007
    Beans
    33
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: Using PVR150 IR Blaster In Mythbuntu 9.10b

    Quote Originally Posted by Kheops_74 View Post
    ...
    I still have this error:

    irsend: command failed: SEND_ONCE blaster 1
    irsend: hardware does not support sending

    Do you know the problem? is it hardware.conf, lircd.conf or something else?
    I could be your hardware.conf or lirc_zilog isn't working properly. Check which devices are created after you load lirc_zilog as well.
    Code:
    ls /dev/lirc*
    If you load zilog with debug=1 what is your syslog output? Using the original patch I would get lirc_zilog: no device found messages.

    Code:
    tail -f /var/log/syslog
    open a second terminal
    Code:
    sudo rmmod lirc_zilog
    sudo modprobe lirc_zilog debug=1
    relevant part of my hardware.conf
    Code:
    TRANSMITTER_MODULES="lirc_zilog"
    TRANSMITTER_DEVICE="/dev/lirc0"
    I only use lirc for blasting so I don't have lirc_i2c loaded

  7. #67
    Join Date
    Nov 2006
    Beans
    137

    Re: Using PVR150 IR Blaster In Mythbuntu 9.10b

    Ok. i unload lirc_i2c (sudo rmmod lirc_i2c) and modify the hardware.conf to remove lirc_i2c. I rebooted and it seems to work.

    What is the use of lirc_i2c?

    Thanks MrPlow

  8. #68
    Join Date
    Nov 2006
    Beans
    137

    Re: Using PVR150 IR Blaster In Mythbuntu 9.10b

    Lirc was updated tonight. Guess what, it doesn't work anymore I hate this soooo much.

    I think the patch for lirc-zilog is not up to date for the new version. MrPlow, can you confirm???

    When i did sudo dpkg-reconfigure lirc-modules-source i receive an error (bad something)

    Thanks

  9. #69
    Join Date
    Jun 2008
    Location
    Minneapolis, MN
    Beans
    21
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Using PVR150 IR Blaster In Mythbuntu 9.10b

    Same here, something was updated and it no longer works for me either.

  10. #70
    Join Date
    Aug 2007
    Beans
    33
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: Using PVR150 IR Blaster In Mythbuntu 9.10b

    ya mine broke yesturday as well, on my other machine as well which doesn't have zilog but that was a slightly different reason.

    I had to remove the lirc source
    sudo sudo apt-get install lirc-modules-source
    sudo rm -rf /usr/src/lirc-0.8.6/

    then reinstall it and apply the patch like before, the patch needed no changes

Page 7 of 9 FirstFirst ... 56789 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •