Page 2 of 9 FirstFirst 1234 ... LastLast
Results 11 to 20 of 84

Thread: Using PVR150 IR Blaster In Mythbuntu 9.10b

  1. #11
    Join Date
    Nov 2006
    Beans
    17

    Re: Using PVR150 IR Blaster In Mythbuntu 9.10b

    Someone filed a bug against this:

    https://bugs.launchpad.net/ubuntu/+s...rc/+bug/454843

    So it seems like pvr150 will not compile against the 2.6.31 (which I confirmed). I emailed the original pvr150 driver author, but am not holding my breath for an answer.

    I am going to continue procrastinating and try to get it working, but I do not have high hopes.

  2. #12
    Join Date
    Nov 2006
    Beans
    11

    Re: Using PVR150 IR Blaster In Mythbuntu 9.10b

    Quote Originally Posted by jimmybondo View Post
    Someone filed a bug against this:

    https://bugs.launchpad.net/ubuntu/+s...rc/+bug/454843

    So it seems like pvr150 will not compile against the 2.6.31 (which I confirmed). I emailed the original pvr150 driver author, but am not holding my breath for an answer.

    I am going to continue procrastinating and try to get it working, but I do not have high hopes.
    Thanks!

    Interesting...

    If it helps at all, I was able to determine that "lirc_pvr150" was re-released as "lirc_zilog", and Jarod Wilson created a kernel patch for .31 that apparently gets it working. (Sorry, don't have the links handy ATM.)

    I haven't tried it, but it might be something to look at.

  3. #13
    Join Date
    Aug 2006
    Beans
    10

    Re: Using PVR150 IR Blaster In Mythbuntu 9.10b

    Im having the same issue using ubuntu 9.10 RC1. Ive always installed lirc then put the haup-ir-blaster.bin file in /lib/firmware then modprobed lirc_dev and lirc_pvr150...but now im getting the error of

    FATAL: Module lirc_pvr150 not found.

    or if i try to load what sentinel23 suggested

    FATAL: Module lirc_zilog not found.


    I *really* need to get my blaster working as soon as possible. If anyone has any other ideas please jump in....as if this is not resolved ill have to revert back to 9.04 until the corrections are made to fix this.

  4. #14
    Join Date
    Nov 2006
    Beans
    17

    Re: Using PVR150 IR Blaster In Mythbuntu 9.10b

    It looks like lirc_zilog would work. However, I cannot figure out how to compile it and get it working on Ubuntu. All mentions of the module only reference a kernel patch that I cannot figure out how to apply.

    Any suggestions?
    Thanks,
    Jim

  5. #15
    Join Date
    Nov 2006
    Beans
    137

    Re: Using PVR150 IR Blaster In Mythbuntu 9.10b

    Just upgrade to 9.10. Same here the IR blaster is not working on my pvr150. Is somebody find a way to get it work?

    About lirc_zilog, is it work? What are the steps?

    Thanks

  6. #16
    Join Date
    Nov 2006
    Beans
    137

    Re: Using PVR150 IR Blaster In Mythbuntu 9.10b

    I tried to compile the driver here (http://www.blushingpenguin.com/mark/blog/?p=24). I get an error when i try to do make && make install.

    Some people think that this is the solution but i can't make it work

  7. #17
    Join Date
    Oct 2007
    Beans
    13

    Re: Using PVR150 IR Blaster In Mythbuntu 9.10b

    I patched lirc-modules-sorce and got it to compile and install but I have not upgraded my backend yet so cannot test it. Patch is at http://www.skynet.ie/~shabba/zilog.diff

    Let me know if this works. I think Mario is going to create a PPA of it or include it in lirc-modules-source

    D.

  8. #18
    Join Date
    Nov 2006
    Beans
    137

    Re: Using PVR150 IR Blaster In Mythbuntu 9.10b

    Maybe you can put the steps to patch lirc-module-source here. I will try to figure it out.

    Thanks

  9. #19
    Join Date
    Feb 2008
    Beans
    5

    Re: Using PVR150 IR Blaster In Mythbuntu 9.10b

    I am a long time user of the PVR150 (for just IR Blasting).. It would be nice to get this fixed, as I may not live out the week cuz, myth can't change channels...

    Dave

  10. #20
    Join Date
    Nov 2006
    Beans
    17

    Re: Using PVR150 IR Blaster In Mythbuntu 9.10b

    The patch fails to apply correctly:

    /usr/src/lirc-0.8.4a$ sudo patch -p0 < ~/Downloads/zilog.diff
    patching file lirc-modules-source.conf
    Hunk #1 FAILED at 2.
    1 out of 1 hunk FAILED -- saving rejects to file lirc-modules-source.conf.rej
    patching file dkms.conf
    Hunk #1 FAILED at 63.
    1 out of 1 hunk FAILED -- saving rejects to file dkms.conf.rej
    patching file Makefile
    Hunk #1 FAILED at 28.
    Hunk #2 succeeded at 555 with fuzz 2 (offset 431 lines).
    1 out of 2 hunks FAILED -- saving rejects to file Makefile.rej
    patching file drivers/lirc_zilog/.deps/lirc_zilog.Po
    patching file drivers/lirc_zilog/Makefile
    patching file drivers/lirc_zilog/lirc_zilog.c
    patching file drivers/Makefile
    Hunk #1 FAILED at 136.
    1 out of 1 hunk FAILED -- saving rejects to file drivers/Makefile.rej

    Any ideas?
    Jim

Page 2 of 9 FirstFirst 1234 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •