Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Atheros wifi worked in Karmic alpha-2 but not after that.

  1. #1
    Join Date
    Jan 2006
    Location
    Grønland,Oslo
    Beans
    618

    Smile SOLVED: Atheros wifi worked in Karmic alpha-2 but not after that.

    Hello,

    I have Fujitsu Siemens AMILO Li 1718 laptop with Atheros AR5001 wireless network adapter. It worked very well and out-of-the-box (first time ever !) in Karmic 9.10 alpha-2, but stopped working after subsequent upgrades.

    The network-manager's "Enable Wireless" option is disabled and the wireless list is completely empty.

    See this bug report.
    https://bugs.launchpad.net/ubuntu/+s...ux/+bug/395565
    ---

    System information:
    $ uname -a
    Linux karmic32 2.6.31-14-generic #47-Ubuntu SMP Thu Oct 15 02:08:08 UTC 2009 i686 GNU/Linux
    --

    $ lsb_release -a
    Distributor ID: Ubuntu
    Description: Ubuntu karmic (development branch)
    Release: 9.10
    Codename: karmic
    --

    $ lspci -vnvn
    02:00.0 Ethernet controller [0200]: Atheros Communications Inc. AR5001 Wireless Network Adapter [168c:001c] (rev 01)
    Subsystem: Atheros Communications Inc. Device [168c:3067]
    Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
    Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
    Latency: 0, Cache Line Size: 32 bytes
    Interrupt: pin A routed to IRQ 16
    Region 0: Memory at c0000000 (64-bit, non-prefetchable) [size=64K]
    Capabilities: <access denied>
    Kernel driver in use: ath5k
    Kernel modules: ath5k
    --
    Other information:
    $ lspci -vnvn
    http://www.edbl.no/tmp/karmic/lspci.txt

    $ uname -a
    http://www.edbl.no/tmp/karmic/uname.txt

    $ dmesg
    http://www.edbl.no/tmp/karmic/dmesg.txt

    $ lsmod
    http://www.edbl.no/tmp/karmic/lsmod.txt
    Last edited by moma; October 20th, 2009 at 03:02 PM. Reason: SOLVED

  2. #2
    Join Date
    Apr 2008
    Location
    Norwich CT
    Beans
    1,483
    Distro
    Kubuntu 12.04 Precise Pangolin

    Re: Atheros wifi worked in Karmic alpha-2 but not after that.

    I just installed from disk and updated, and got my Atheros wifi working after that. Before, I was getting an error when I tried to config the connection properties.


  3. #3
    Join Date
    Aug 2006
    Beans
    567

    Re: Atheros wifi worked in Karmic alpha-2 but not after that.

    AFAIK, Karmic defaults to "WiFi OFF" at first boot.
    If you have a hardware switch on your laptop for wifi, try it?
    i5 2500K / Corsair H50-1 / Asus P8P67-M Pro / 16GB Corsair Vengeance / EVGA GTX260 SSC / HP BDRW / 120GB Crucial M4 SSD /
    OCZ Modstream 780W / CoolerMaster 590 case / Dell E248WFP / Saitek Eclipse II / Logitech G9 / Ubuntu 12.10-64

  4. #4
    Join Date
    Jan 2006
    Location
    Grønland,Oslo
    Beans
    618

    Re: Atheros wifi worked in Karmic alpha-2 but not after that.

    Hello and thanks for your input,

    I will make a new fresh installation and try with that.

    Yes, this laptop has a hotkey/button to switch the wireless on/off. It has also a green led indicator that shows the status. Unfortunately the button and led-light do not work in Karmic as is.

    In jaunty, I had to install acerhk.ko software driver that manages the button and led-light. I used this guide in Jaunty: http://futuredesktop.org/jaunty/amil...s_in_linux.txt. Some Fujitsu Siemens AMILO laptops use the acer's keyboard circuitry, therefore the the driver works on them too.

    My preliminary test shows that the guide will not work in Karmic. Compiling the acerhk driver (if it is needed?) may also be a challenge.

    The question is how to switch the wifi on.

    See also:
    1) http://www.amilo-forum.com/topic,275...untu-9-10.html
    2) https://bugs.launchpad.net/ubuntu/+s...ux/+bug/425620
    ---
    Anyway, I'll be back after fresh installment.
    Last edited by moma; October 19th, 2009 at 05:56 PM.

  5. #5
    Join Date
    Jan 2006
    Location
    Grønland,Oslo
    Beans
    618

    SOLVED: Atheros wifi worked in Karmic alpha-2 but not after that.

    Re-hello,

    Ok, I got it working.
    The WLAN-driver itself is loaded and well, but it (the driver or hardware) is simply switched off.

    So I downloaded source code for the acerhk... hotkey driver and managed, after some hackery, to compile it on Karmic. Now the hotkey (function key) Fn + ((o)) works and allows me to switch the WLAN on. The led turns green and wifi access points appear in the network manager.

    Picture:


    I will later release patched source code for the acerhk hotkey-driver so other people may also use it. It will be available here.

    EDIT: The following bug report in Debian concerns the compilation problem of acerhk.
    http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=533341

    EDIT: Very good news. Debian's people has already fixed and patched the acerhk-0.5.35.tgz source so it should now compile in Karmic. And the source is in the Ubuntu's repository.
    $ apt-cache search acerhk-source

    EDIT: Bad news.
    The source code from Ubuntu's repo does not compile!
    See bug report: https://bugs.launchpad.net/ubuntu/+s...hk/+bug/456123

    The solution: Here is a temporary solution and guide
    http://www.edbl.no/karmic/amilo_1718...buntu_9.10.txt

    -- case closed --
    Last edited by moma; October 20th, 2009 at 03:02 PM. Reason: SOLVED

  6. #6
    Join Date
    Sep 2007
    Beans
    45

    Smile Re: Atheros wifi worked in Karmic alpha-2 but not after that.

    Moma,

    Thanks so much for this, the guide worked like a charm!

  7. #7
    Join Date
    Nov 2007
    Location
    Hungary - Budapest
    Beans
    33
    Distro
    Ubuntu 10.04 Lucid Lynx

    Angry Re: SOLVED: Atheros wifi worked in Karmic alpha-2 but not after that.

    Quote Originally Posted by moma View Post
    The solution: Here is a temporary solution and guide
    http://www.edbl.no/karmic/amilo_1718...buntu_9.10.txt

    -- case closed --
    Hi!
    I still can't get this working... at the

    "$ sudo /sbin/modprobe --ignore-install acerhk force_series=6805 autowlan=1"

    part it says

    "WARNING: All config files need .conf: /etc/modprobe.d/options, it will be ignored in a future release.
    FATAL: Error inserting acerhk (/lib/modules/2.6.31-14-generic/extra/acerhk.ko): Unknown symbol in module, or unknown parameter (see dmesg)"

    In the /etc/modprobe.d/ directory there aren't any options.conf, only options, so I tried copying it to options.conf, but still the same error message I don't know what to do...

    dmesg | egrep -i "acer" says acerhk: Unknown parameter 'force'
    Last edited by karesz; October 23rd, 2009 at 01:55 PM.

  8. #8
    Join Date
    Jan 2006
    Location
    Grønland,Oslo
    Beans
    618

    Re: Atheros wifi worked in Karmic alpha-2 but not after that.

    What type of AMILO laptop do you have?

    In steps 3) and 4) you test the module loading and usage manually.
    Many AMILO models do not understand or match the "force_series=6805" option. Try without it.

    $ sudo /sbin/modprobe acerhk autowlan=1
    ---

    Tell me what options work in your laptop model. I will then update the document.

  9. #9
    Join Date
    Nov 2007
    Location
    Hungary - Budapest
    Beans
    33
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Atheros wifi worked in Karmic alpha-2 but not after that.

    I've got an Amilo Li1718, Model: MS2212

    I have already tried modprobe acerhk autowlan=1, and the modprobe acerhk, both give back the same error
    Still no action... Are there any way to switch the wlan on by software?

  10. #10
    Join Date
    Jan 2006
    Location
    Grønland,Oslo
    Beans
    618

    Re: Atheros wifi worked in Karmic alpha-2 but not after that.

    Hello,

    Ok, check the /etc/modprobe.d/ directory. Maybe you have erroneous, old files there. Delete them. What is this /etc/modprobe.d/options file? I think it is remnant of Jaunty Jackalope?

    I have Fujitsu Siemens AMILO Li 1718 with Ubuntu 9.10 (karmic) and /etc/modprobe.d/ has these files.
    $ ls -l /etc/modprobe.d/

    Code:
    -rw-r--r-- 1 root root   47 2009-10-20 15:14 acerhk.conf
    -rw-r--r-- 1 root root 2497 2009-10-12 00:07 alsa-base.conf
    -rw-r--r-- 1 root root  325 2009-09-15 23:46 blacklist-ath_pci.conf
    -rw-r--r-- 1 root root 1603 2009-09-15 23:46 blacklist.conf
    -rw-r--r-- 1 root root  213 2009-09-15 23:46 blacklist-firewire.conf
    -rw-r--r-- 1 root root  662 2009-09-15 23:46 blacklist-framebuffer.conf
    -rw-r--r-- 1 root root  156 2009-05-26 23:02 blacklist-modem.conf
    lrwxrwxrwx 1 root root   41 2009-10-19 20:28 blacklist-oss.conf -> /lib/linux-sound-base/noOSS.modprobe.conf
    -rw-r--r-- 1 root root 1077 2009-09-15 23:46 blacklist-watchdog.conf
    -rw-r--r-- 1 root root   16 2009-08-26 11:49 libpisock9.conf
    And /etc/modprobe.d/acerhk.conf contains one line:
    $ cat /etc/modprobe.d/acerhk.conf

    Code:
    options acerhk force_series=6805 autowlan=1
    And /etc/modules file has this
    $ cat /etc/modules
    Code:
    # /etc/modules: kernel modules to load at boot time.
    #
    # This file contains the names of kernel modules that should be loaded
    # at boot time, one per line. Lines beginning with "#" are ignored.
    
    loop
    lp
    acerhk
    And of course, the acerhk.ko driver must be in /lib/modules/$(uname -r)/extra/

    My recommendation is
    Do a ny fresh installation. Do not upgrade from Jaunty.

    I hope to have upgraded this http://www.futuredesktop.org guide till Karmic is out.
    Last edited by moma; October 24th, 2009 at 06:47 PM.

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •