Page 2 of 2 FirstFirst 12
Results 11 to 20 of 20

Thread: How do I disable Graphical boot?

  1. #11
    Join Date
    Dec 2008
    Beans
    26
    Distro
    Ubuntu Karmic Koala (testing)

    Re: How do I disable Graphical boot?

    ok...

    so I couldn't wait until monday...

    after update-grub the splash screen is finally out of the picture, but ubuntu still boots X.

    @wnelson I can't modify the file you mention 'cause it doesn't exist on my pc. In fact, /etc/event.d/ doesn't exist on my pc... any Ideas?

    Thanks!

  2. #12
    Join Date
    Oct 2009
    Beans
    3

    Re: How do I disable Graphical boot?

    Try to move the file /etc/init/gdm.conf elsewhere and reboot. Don't remove it since you may need it back in the future. I didn't try this but theoretically I think this should work
    Last edited by SheVa77; October 18th, 2009 at 02:06 PM.

  3. #13
    Join Date
    Oct 2009
    Beans
    3

    Re: How do I disable Graphical boot?

    Tried it - works. Removing 'quiet splash' from the /etc/default/grub and moving the gdm.conf out of the /etc/init brings the pure command line. startx will bring gnome up.
    I'm not sure that everything will work in the gnome since maybe there are other services that are dependent on the 'gdm' and not started.

  4. #14
    Join Date
    Dec 2008
    Beans
    26
    Distro
    Ubuntu Karmic Koala (testing)

    Re: How do I disable Graphical boot?

    thanks! I'll try it out and see if something comes up during the week

    Regards!

  5. #15
    Join Date
    Sep 2009
    Beans
    21

    Re: How do I disable Graphical boot?

    If your looking for an all verbose boot as debian has, I did it by editing /boot/grub/menu.lst Just remove quiet and splash from the first kernel listed, or all of them if you wish.

    from...
    title Ubuntu 9.04, kernel 2.6.28-15-generic
    uuid 3c58d45d-ae5a-4a4f-9b44-9bfbd1ccca4c
    kernel /boot/vmlinuz-2.6.28-15-generic root=UUID=3c58d45d-ae5a-4a4f-9b44-9bfbd1ccca4c ro quiet splash
    initrd /boot/initrd.img-2.6.28-15-generic

    to...
    title Ubuntu 9.04, kernel 2.6.28-15-generic
    uuid 3c58d45d-ae5a-4a4f-9b44-9bfbd1ccca4c
    kernel /boot/vmlinuz-2.6.28-15-generic root=UUID=3c58d45d-ae5a-4a4f-9b44-9bfbd1ccca4c ro
    initrd /boot/initrd.img-2.6.28-15-generic

  6. #16
    Join Date
    Nov 2008
    Location
    New Hampshire
    Beans
    395
    Distro
    Ubuntu Development Release

    Re: How do I disable Graphical boot?

    Quote Originally Posted by fluxbuntu View Post
    If your looking for an all verbose boot as debian has, I did it by editing /boot/grub/menu.lst Just remove quiet and splash from the first kernel listed, or all of them if you wish.

    from...
    title Ubuntu 9.04, kernel 2.6.28-15-generic
    uuid 3c58d45d-ae5a-4a4f-9b44-9bfbd1ccca4c
    kernel /boot/vmlinuz-2.6.28-15-generic root=UUID=3c58d45d-ae5a-4a4f-9b44-9bfbd1ccca4c ro quiet splash
    initrd /boot/initrd.img-2.6.28-15-generic

    to...
    title Ubuntu 9.04, kernel 2.6.28-15-generic
    uuid 3c58d45d-ae5a-4a4f-9b44-9bfbd1ccca4c
    kernel /boot/vmlinuz-2.6.28-15-generic root=UUID=3c58d45d-ae5a-4a4f-9b44-9bfbd1ccca4c ro
    initrd /boot/initrd.img-2.6.28-15-generic
    We are in the karmic forum. This is no longer the way to achive a verbose text-only boot. Did you read any previous posts in this thread?

  7. #17
    Join Date
    Oct 2009
    Beans
    3

    Re: How do I disable Graphical boot?

    Forgot to mention, however it was said before by others, that after editing the /etc/default/grub you have to run:
    sudo update-grub2

  8. #18
    Join Date
    Dec 2008
    Beans
    26
    Distro
    Ubuntu Karmic Koala (testing)

    Re: How do I disable Graphical boot?

    yep! moved that gdm config file and now I get a textmode boot

    Thanks! =D

  9. #19
    Join Date
    Dec 2008
    Beans
    26
    Distro
    Ubuntu Karmic Koala (testing)

    Re: How do I disable Graphical boot?

    ok so after following the last tip it worked but some functions stopped working properly (like any app that requires elevated privileges must be explicitly started from a terminal instead of prompting for the password on start). So I took a look inside the config file.

    the last 2 line announce gdm is starting and then start it (or that's what I inferred) so I commented them out, renamed the file back so it would load on startup and viola! I now have terminal boot with the gdm script in place. maybe not starting gdm itself won't make the problems mentioned go away, but at least the rest of the file is loading, and that's (I guess) better than no file at all.

    Regards!

  10. #20
    Join Date
    Dec 2008
    Beans
    26
    Distro
    Ubuntu Karmic Koala (testing)

    Re: How do I disable Graphical boot?

    I uncommented the second to last line and am still booting into a terminal. now whenever I want to start X, I use "sudo gdm-binary" and boot into gnome with my account and everything just as if I were booting using gdm in the first place.

    Regards!

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •