Results 1 to 9 of 9

Thread: VMware {Player Ubuntu 9.10 Mouse Integration

  1. #1
    Join Date
    Feb 2009
    Location
    Queensland, Australia
    Beans
    3
    Distro
    Ubuntu Karmic Koala (testing)

    VMware {Player Ubuntu 9.10 Mouse Integration

    Just wondering if anyone is running VMware Player with a ubuntu 9.10 host and Windows XP machine with VMware tools installed successfully?

    I just upgraded to ubuntu 9.10 and have found that the mouse integration is not working properly. It seems to jump in and out towards the edges of the window therefore preventing things from being clicked e.g. windows start button as the first click grabs the VM window (then it falls out). So the second mouse click simply grabs the window again.

    This problem is in console mode. When in unity mode it seems to work ok.

    I am using:

    VMware Player 2.5.3 build-185404
    ubuntu release 9.10 (karmic) (64bit)
    kernel linux 2.6.31-13-generic
    GNOME 2.28.0

    Does anyone have any ideas of how to get around this or at least identify if its ubuntu or VMware that has the issue?

    Cheers.

  2. #2
    Join Date
    Oct 2009
    Beans
    1

    Unhappy Re: VMware {Player Ubuntu 9.10 Mouse Integration

    I have the same problem with same versions.

  3. #3
    Join Date
    Oct 2009
    Location
    Norway
    Beans
    Hidden!
    Distro
    Ubuntu Karmic Koala (testing)

    Re: VMware {Player Ubuntu 9.10 Mouse Integration

    I had the same problem and found this solution which worked for me:
    http://www.rootloot.de/blog/vmware_in_ubuntu_karmic

    Put this statement

    export VMWARE_USE_SHIPPED_GTK=yes

    into /etc/vmware/bootstrap

    Cheers,
    Arne Hanssen

  4. #4
    Join Date
    Jan 2007
    Beans
    3,202

    Re: VMware {Player Ubuntu 9.10 Mouse Integration

    ... and be aware that VMware won't build correctly on the next kernel you install. You will need to first comment out that line in /etc/vmware/bootstrap, then run VMware and let it build the modules and open your VM, then close it all, and go back into /etc/vmware/bootstrap and uncomment the line. Then it will run correctly once again.
    Intel Core i7-950 / Asus P6X58D-E / Nvidia GTX480 / siduction 64-bit on OCZ Revodrive SSD / KDE4.10.2/ Kubuntu 13.04

  5. #5
    Join Date
    May 2005
    Location
    North Carolina
    Beans
    87
    Distro
    Ubuntu Development Release

    Re: VMware {Player Ubuntu 9.10 Mouse Integration

    There's also a beta verion of Player(VMware-Player-3.0.0-197124.i386.bundle) that fixes it.

  6. #6
    Join Date
    Dec 2006
    Beans
    Hidden!

    Re: VMware {Player Ubuntu 9.10 Mouse Integration

    nasty problem but easy to work around
    this fixes the problem for me vmware server 2.0.1
    mouse is now working!

    create this file using the bin/bash text.
    give it a name like VMlaunch.sh
    make it executable
    run it and it loads the VMware machine
    #!/bin/bash
    ################################################## ##############################
    # Call VMWare Server's Remote Console in a clean GTK setup.
    ################################################## ##############################

    # Clean GTK setup for VMWare
    export VMWARE_USE_SHIPPED_GTK=yes

    # Find console executable in Firefox plugins.
    vmrc="$(find "$HOME/.mozilla/firefox" -name vmware-vmrc -type f -perm -111 | tail -1)"
    [ -x "$vmrc" ] || exit 1

    set -x
    cd "$(dirname "$vmrc")" && "$vmrc" -h 127.0.0.1:8333



    http://shellack.de/info/content/vmwa...onsole-failure
    It should also be possible to run Firefox by VMWARE_USE_SHIPPED_GTK=yes firefox in your Linux command line to fix the GTK issue.
    sdowney717 wrote 2 seconds ago: #6

  7. #7
    Join Date
    Dec 2006
    Beans
    Hidden!

    Re: VMware {Player Ubuntu 9.10 Mouse Integration

    interesting, if you run the script and the virtual machine is powered off, it will power it on. so once you have the machine configured, the script simply acts as a player.

    how about the sound, it says it is not compatable.

  8. #8
    Join Date
    Mar 2008
    Beans
    2

    Re: VMware {Player Ubuntu 9.10 Mouse Integration

    Quote Originally Posted by gungne View Post
    I had the same problem and found this solution which worked for me:
    http://www.rootloot.de/blog/vmware_in_ubuntu_karmic

    Put this statement

    export VMWARE_USE_SHIPPED_GTK=yes

    into /etc/vmware/bootstrap

    Cheers,
    Arne Hanssen
    This worked for me too. Thanks

  9. #9
    Join Date
    Nov 2004
    Location
    Seattle, WA
    Beans
    93
    Distro
    Xubuntu 9.10 Karmic Koala

    Re: VMware {Player Ubuntu 9.10 Mouse Integration

    Quote Originally Posted by gungne View Post
    I had the same problem and found this export VMWARE_USE_SHIPPED_GTK=yes
    Interestingly enough, this fix fails rather unimpressively under xubuntu/x86_64/vmware-server 2.0.1:

    brendan@scylla:[snip]$ VMWARE_USE_SHIPPED_GTK=yes ./vmware-vmrc -h 127.0.0.1:8333

    (vmware-vmrc:19752): Gtk-WARNING **: GModule initialization check failed: Gtk+ version too old (micro mismatch)

    (vmware-vmrc:19752): Gtk-WARNING **: GModule initialization check failed: Gtk+ version too old (micro mismatch)
    ** (vmware-vmrc:19752): DEBUG: This Gtk+ version doesn't have the GtkSettings::gtk-enable-input-feedback-sounds property.
    ./bin/vmware-vmrc: symbol lookup error: /usr/lib/gtk-2.0/modules/libcanberra-gtk-module.so: undefined symbol: gdk_threads_add_idle_full

    I don't quite grok the different values for this variable, but setting it to "force" instead of "yes" in my setup caused things to function correctly.

    I.e. try:

    VMWARE_USE_SHIPPED_GTK=force
    If you're still having issues.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •