Page 4 of 4 FirstFirst ... 234
Results 31 to 38 of 38

Thread: HOWTO: Booting LiveCD ISOs from USB flash drive with Grub2

  1. #31
    Join Date
    Oct 2009
    Beans
    8

    Re: HOWTO: Booting LiveCD ISOs from USB flash drive with Grub2

    Ok here's what I did. I recreated the grub.cfg file and pasted the ubuntu configuration. Then I deleted both of the .lua files since I asume they're no longer required. After that I went into the isos directory, and renamed the ubuntu9.1 image to ubuntu.iso. When I booted off the USB flash drive, it gave me a menu. However when I pressed enter, since I only have one usb image, it just said something like, press a key to continue. Then it returned me back to the same menu. Am I missing anything else here? Do you think I need a menu.lst file? The post doesn't mention it though. or maybe I shouldn't rename the ubuntu file. Thanks for all the help!

  2. #32
    Join Date
    Oct 2009
    Beans
    19
    Distro
    Ubuntu Development Release

    Re: HOWTO: Booting LiveCD ISOs from USB flash drive with Grub2

    Quote Originally Posted by lprazdnik View Post
    Am I missing anything else here? Do you think I need a menu.lst file? The post doesn't mention it though. or maybe I shouldn't rename the ubuntu file. Thanks for all the help!
    As far as I can tell, you have done everything right. A menu.lst file is not needed because Grub2 uses the grub.cfg file instead and the renaming of the ISO file is also not a problem. Does it really prompts you just the "press a key to continue" text or is there also an error text like "error: file not found" or "error: you need to load the kernel first"? You could also test which command fails if you press "c" when you see the Grub menu to go to the command mode and then execute the commands that are inside the menuentry part.

  3. #33
    Join Date
    Oct 2009
    Beans
    8

    Re: HOWTO: Booting LiveCD ISOs from USB flash drive with Grub2

    yup sorry you're right. it says command not found (loop)/casper/initrd

  4. #34
    Join Date
    Oct 2009
    Beans
    19
    Distro
    Ubuntu Development Release

    Re: HOWTO: Booting LiveCD ISOs from USB flash drive with Grub2

    Quote Originally Posted by lprazdnik View Post
    yup sorry you're right. it says command not found (loop)/casper/initrd
    Whoops! I'm sorry the Ubuntu menu entries were wrong. They must of course look like this:

    Code:
    menuentry "Ubuntu" {
        set isofile="/boot/isos/ubuntu.iso"
     
        loopback loop $isofile 
        linux (loop)/casper/vmlinuz boot=casper iso-scan/filename=$isofile quiet splash noprompt --
        initrd (loop)/casper/initrd.lz
    }

  5. #35
    Join Date
    Oct 2009
    Beans
    8

    Re: HOWTO: Booting LiveCD ISOs from USB flash drive with Grub2

    It works! Thanks! This is a much better alternative than to make a startup disk for each distro.

  6. #36
    Join Date
    Oct 2009
    Beans
    8

    Re: HOWTO: Booting LiveCD ISOs from USB flash drive with Grub2

    Ok I have a bit of a problem. Usually, when I boot off a live cd, I press f5 to get to the accessibility menu, and enable the features. However the usb version doesn't do anything when I press f5. I'm sure I can find a way around it all but does anyone know of agood solution to fixing this? Other than that, the usb boots up fine. Thanks!

  7. #37
    Join Date
    Jun 2008
    Location
    Colombia
    Beans
    443

    Re: HOWTO: Booting LiveCD ISOs from USB flash drive with Grub2

    Quote Originally Posted by lprazdnik View Post
    Ok I have a bit of a problem. Usually, when I boot off a live cd, I press f5 to get to the accessibility menu, and enable the features. However the usb version doesn't do anything when I press f5. I'm sure I can find a way around it all but does anyone know of agood solution to fixing this? Other than that, the usb boots up fine. Thanks!
    In the menu, go to System -> Preferences -> Assistive technologies

  8. #38
    Join Date
    Oct 2009
    Beans
    8

    Re: HOWTO: Booting LiveCD ISOs from USB flash drive with Grub2

    Yeah but it would be helpful if orca would start automatically, since I need speech feedback. I mean usually when ubuntu would load, I would just press alt f2, type orca and press enter. Then I would go through the configuration. The problem is after the configuration I need to log out and back in again. When I do that, since the 9.1 release, orca doesn't speak at all. So that's why I found it helpful to turn it on at the boot prompt. I don't know if this will be resolved after the 9.1 official release.

Page 4 of 4 FirstFirst ... 234

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •