Page 6 of 24 FirstFirst ... 4567816 ... LastLast
Results 51 to 60 of 236

Thread: Grub 2 Title Tweaks Thread

  1. #51
    Join Date
    Jan 2007
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Grub 2 Title Tweaks Thread

    jmine83,

    After you restored the original Grub 2 files to the /etc/grub.d folder, rename /etc/grub.d/30_os-prober file:

    Code:
    sudo mv /etc/grub.d/30_os-prober  /etc/grub.d/30_os-prober.original
    If the attached archive is on your Desktop, you can run these commands to extract the files, copy 30_os-prober to /etc/grub.d and make sure it is executable. A copy of the original will remain on your desktop.
    Code:
    sudo tar -x 30_os-prober.tar.bz2 
    sudo cp ~/Desktop/30_os-prober /etc/grub.d/
    sudo chmod +x /etc/grub.d/30_os-prober
    The lines added to 30_os-prober are lines 96-100. They will prevent any detected OS/kernel/etc on "sda1" from appearing in your Grub 2 menu.
    Attached Files Attached Files
    GRUB2

    Retired.

  2. #52
    Join Date
    Apr 2008
    Beans
    3,317
    Distro
    Kubuntu 9.10 Karmic Koala

    Re: Grub 2 Title Tweaks Thread

    not found/30_os-prober: 217: continue
    Did you edit 10_os-prober from Windows?

    I downloaded your 10_os-prober file, placed in my "/etc/grub.d" and run "update-grub". I got the same error message. I then opened "10_os-prober" in emacs and noticed a "^M" at the end of the "continue" statement. "^M" is a Dos style line break. I removed the "^M". Now "update-grub" completed without error.

    So if you edit a Grub 2 configuration file, you need to make sure that you use an editor which uses unix line breaks.

  3. #53
    Join Date
    Dec 2009
    Beans
    5

    Re: Grub 2 Title Tweaks Thread

    Quote Originally Posted by meierfra. View Post
    Did you edit 10_os-prober from Windows?

    I downloaded your 10_os-prober file, placed in my "/etc/grub.d" and run "update-grub". I got the same error message. I then opened "10_os-prober" in emacs and noticed a "^M" at the end of the "continue" statement. "^M" is a Dos style line break. I removed the "^M". Now "update-grub" completed without error.

    So if you edit a Grub 2 configuration file, you need to make sure that you use an editor which uses unix line breaks.
    Nice that was it. I did use gedit in Ubuntu to edit the file, so I am glad you caught that. I edited the file with emacs as you mentioned, saw the "^M" character you noted, ran "update-grub" and that did it. Thank you very much.

  4. #54
    Join Date
    Apr 2008
    Beans
    3,317
    Distro
    Kubuntu 9.10 Karmic Koala

    Re: Grub 2 Title Tweaks Thread

    I did use gedit in Ubuntu to edit the file,
    That's weird. I would be surprised if it problem was really caused by Gedit.
    Nice that was it.
    Great. I enjoyed solving this little puzzle.
    Last edited by meierfra.; January 28th, 2010 at 02:54 AM.

  5. #55
    Join Date
    Aug 2007
    Beans
    9

    Re: Grub 2 Title Tweaks Thread

    Greetings!

    Does anyone know how to set the menu FONT SIZE?

    Thanks!
    Dave

  6. #56
    Join Date
    Jan 2007
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Grub 2 Title Tweaks Thread

    Quote Originally Posted by djg5211 View Post
    Greetings!

    Does anyone know how to set the menu FONT SIZE?

    Thanks!
    Dave
    The Grub 2 menu font size can be indirectly set with the /etc/default/grub line - in that the screen resolution set by this line will effect how large the fonts are on the standard Grub 2 menu. You can see the available resolutions by typing "c" while the Grub 2 menu is displayed and typing "vbeinfo" without the quotes. :

    GRUB_GFXMODE=640x480
    If you want to directly set the font-size via a font command, I don't think that is yet possible in 1.97beta.
    GRUB2

    Retired.

  7. #57
    Join Date
    Aug 2007
    Beans
    9

    Re: Grub 2 Title Tweaks Thread

    Quote Originally Posted by drs305 View Post
    The Grub 2 menu font size can be indirectly set with the /etc/default/grub line - in that the screen resolution set by this line will effect how large the fonts are on the standard Grub 2 menu. You can see the available resolutions by typing "c" while the Grub 2 menu is displayed and typing "vbeinfo" without the quotes. :



    If you want to directly set the font-size via a font command, I don't think that is yet possible in 1.97beta.
    drs305,

    Hey! Thanks for the response! I understand what you are saying and will
    try that. It just seemed a bit odd that there are all of those fonts
    there but no way to adjust SIZE? I got the font color thing figured
    out and the progress bar the color i wanted it.... now if the font
    size thing works i'll be set.

    Thanks Again!
    Dave

  8. #58
    Join Date
    Jan 2007
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Grub 2 Title Tweaks Thread

    Quote Originally Posted by djg5211 View Post
    drs305,

    Hey! Thanks for the response! .... now if the font
    size thing works i'll be set.

    Thanks Again!
    Dave
    I love optimism.

    But what will happen next is: If you have a Grub 2 splash image, you are going to have to resize it to the same proportions as your new resolution or it won't appear correctly (if at all).

    Theming is coming along in Grub 2 and BURG probably already has the capabilities you are looking for. That is where a lot of the font tweaking will probably become available.

    Note Added: BURG is not Grub. Discussing the differences is beyond the scope of this thread.
    Last edited by drs305; January 29th, 2010 at 03:18 PM.
    GRUB2

    Retired.

  9. #59
    Join Date
    Aug 2007
    Beans
    9

    Re: Grub 2 Title Tweaks Thread

    Hey Y'all...

    The stuff below came from another thread by Bean123 regarding
    burg (since you mentioned it re:font settings). Just thought
    it might be useful to someone else???
    --------------------------------------

    First you need to open /boot/burg/fonts/font.lst to see what fonts are available, then you can replace the font parameter, for example "Fixed Regular 20".

    You can use burg-mkfont to generate new fonts, -h option to show all options, for example:

    Code:

    burg-mkfont -o my_font.pf2 -s 20 my_font.bdf

    You can also convert TTF.

    Then, copy my_font.pf2 to /boot/burg/fonts, and use the following command to update the font list:

    Code:

    cd /boot/burg/fonts
    sudo burg-mkfont -i *.pf2 > font.lst

    -----------------------
    Thanks Again Again!!!
    Dave

  10. #60
    Join Date
    Oct 2009
    Beans
    5

    Re: Grub 2 Title Tweaks Thread

    I am using Kubuntu 9.10. What is the script to change /etc/grub.d/10_linux from default linux kernel menu to show instead "Kubuntu 9.10 Karmic Koala". Thanks.

Page 6 of 24 FirstFirst ... 4567816 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •